aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-12-04 22:45:07 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-12-04 23:06:19 +0000
commit31200877cb24704207a4ddf28a00dd8826e284e4 (patch)
treecee31801bfb5a11ed189f915f62effabb62d72b8
parent6028d572985b81e934c9ed029da890d01ef4ce8c (diff)
downloadports-31200877cb24704207a4ddf28a00dd8826e284e4.tar.gz
ports-31200877cb24704207a4ddf28a00dd8826e284e4.zip
cad/scotch: Add missing include statements in include/scotch.h
Otherwise int64_t and FILE are not found. PR: 275527 Approved by: thierry@FreeBSD.org (maintainer) (cherry picked from commit 77594feff67cf6792d805e079eb5567c21a125a7)
-rw-r--r--cad/scotch/Makefile2
-rw-r--r--cad/scotch/files/patch-src_libscotch_library.h16
2 files changed, 17 insertions, 1 deletions
diff --git a/cad/scotch/Makefile b/cad/scotch/Makefile
index 9fb933476d7d..94b860411305 100644
--- a/cad/scotch/Makefile
+++ b/cad/scotch/Makefile
@@ -1,6 +1,6 @@
PORTNAME= scotch
DISTVERSION= 6.0.4-aster7
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= cad science
MAINTAINER= thierry@FreeBSD.org
diff --git a/cad/scotch/files/patch-src_libscotch_library.h b/cad/scotch/files/patch-src_libscotch_library.h
new file mode 100644
index 000000000000..9af926eebfad
--- /dev/null
+++ b/cad/scotch/files/patch-src_libscotch_library.h
@@ -0,0 +1,16 @@
+- workaround for:
+- - https://gitlab.inria.fr/scotch/scotch/-/issues/35
+- - https://github.com/FreeFem/FreeFem-sources/issues/296
+
+--- src/libscotch/library.h.orig 2017-02-22 07:20:57 UTC
++++ src/libscotch/library.h
+@@ -61,6 +61,9 @@
+ #ifndef SCOTCH_H
+ #define SCOTCH_H
+
++#include <sys/types.h>
++#include <stdio.h>
++
+ /*
+ ** The type and structure definitions.
+ */