aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2021-06-07 11:07:11 +0000
committerMark Linimon <linimon@FreeBSD.org>2021-06-07 11:07:11 +0000
commit31703df4a991a24dfa7309480b3cecf2c24c0a2c (patch)
treefcb1b3ed15d29b5835a5bd64d8becb7d264ed966
parent6f0ab53bf8d991f6a8ef986ce10d7f64a095e325 (diff)
downloadports-31703df4a991a24dfa7309480b3cecf2c24c0a2c.tar.gz
ports-31703df4a991a24dfa7309480b3cecf2c24c0a2c.zip
sysutils/pxp-agent: fix build on GCC-based systems
by adding compiler:c++11-lang to USES: cc1plus: error: unrecognized command line option "-Wno-unused-local-typedefs" cc1plus: error: unrecognized command line option "-Wno-maybe-uninitialized" cc1plus: error: unrecognized command line option "-std=c++11"
-rw-r--r--sysutils/pxp-agent/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/sysutils/pxp-agent/Makefile b/sysutils/pxp-agent/Makefile
index 8f89f96ab35b..2dec8aa06268 100644
--- a/sysutils/pxp-agent/Makefile
+++ b/sysutils/pxp-agent/Makefile
@@ -13,7 +13,7 @@ LIB_DEPENDS= liblibcpp-pcp-client.so:net/cpp-pcp-client \
liblibcpp-hocon.so:devel/cpp-hocon \
libleatherman_util.so:devel/leatherman
-USES= cmake shebangfix ssl
+USES= cmake compiler:c++11-lang shebangfix ssl
USE_GITHUB= yes
GH_ACCOUNT= puppetlabs