aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-03-21 18:35:47 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-03-21 19:19:57 +0000
commit318634b5966eb37ed7e19375af1858909d3838a5 (patch)
tree7cfc99dafd5991f3a33382abd3225d7884c8f383
parentfdeca47640997f46f3c3e3b76d7b9b7aced8d3d4 (diff)
downloadports-318634b5966eb37ed7e19375af1858909d3838a5.tar.gz
ports-318634b5966eb37ed7e19375af1858909d3838a5.zip
devel/rubygem-google-apis-iam_v2: Add rubygem-google-apis-iam_v2 0.2.0
This is the simple REST client for Identity and Access Management (IAM) API V2. Simple REST clients are Ruby client libraries that provide access to Google services via their HTTP REST API endpoints. These libraries are generated and updated automatically based on the discovery documents published by the service, and they handle most concerns such as authentication, pagination, retry, timeouts, and logging. You can use this client to access the Identity and Access Management (IAM) API, but note that some services may provide a separate modern client that is easier to use.
-rw-r--r--devel/Makefile1
-rw-r--r--devel/rubygem-google-apis-iam_v2/Makefile19
-rw-r--r--devel/rubygem-google-apis-iam_v2/distinfo3
-rw-r--r--devel/rubygem-google-apis-iam_v2/pkg-descr8
4 files changed, 31 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index eb92d773a8d0..6110228d8e49 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -6731,6 +6731,7 @@
SUBDIR += rubygem-google-apis-drive_v3
SUBDIR += rubygem-google-apis-generator
SUBDIR += rubygem-google-apis-iam_v1
+ SUBDIR += rubygem-google-apis-iam_v2
SUBDIR += rubygem-google-apis-iamcredentials_v1
SUBDIR += rubygem-google-apis-monitoring_v3
SUBDIR += rubygem-google-apis-pubsub_v1
diff --git a/devel/rubygem-google-apis-iam_v2/Makefile b/devel/rubygem-google-apis-iam_v2/Makefile
new file mode 100644
index 000000000000..de543198b4d9
--- /dev/null
+++ b/devel/rubygem-google-apis-iam_v2/Makefile
@@ -0,0 +1,19 @@
+PORTNAME= google-apis-iam_v2
+PORTVERSION= 0.2.0
+CATEGORIES= devel rubygems
+MASTER_SITES= RG
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Simple REST client for Identity and Access Management (IAM) API V2
+WWW= https://github.com/googleapis/google-api-ruby-client/tree/main/generated/google-apis-iam_v2
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
+
+RUN_DEPENDS= rubygem-google-apis-core>=0.11.0<2.0:devel/rubygem-google-apis-core
+
+USES= gem
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-google-apis-iam_v2/distinfo b/devel/rubygem-google-apis-iam_v2/distinfo
new file mode 100644
index 000000000000..b95dc57dc31f
--- /dev/null
+++ b/devel/rubygem-google-apis-iam_v2/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1677770971
+SHA256 (rubygem/google-apis-iam_v2-0.2.0.gem) = bc210482a1c8e97914e1d43bc552da6861793e6f85e9c82984fce3b2da5bc29c
+SIZE (rubygem/google-apis-iam_v2-0.2.0.gem) = 19456
diff --git a/devel/rubygem-google-apis-iam_v2/pkg-descr b/devel/rubygem-google-apis-iam_v2/pkg-descr
new file mode 100644
index 000000000000..8af03159bb6b
--- /dev/null
+++ b/devel/rubygem-google-apis-iam_v2/pkg-descr
@@ -0,0 +1,8 @@
+This is the simple REST client for Identity and Access Management (IAM) API V2.
+Simple REST clients are Ruby client libraries that provide access to Google
+services via their HTTP REST API endpoints. These libraries are generated and
+updated automatically based on the discovery documents published by the service,
+and they handle most concerns such as authentication, pagination, retry,
+timeouts, and logging. You can use this client to access the Identity and Access
+Management (IAM) API, but note that some services may provide a separate modern
+client that is easier to use.