aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2021-10-08 15:03:39 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2021-10-08 15:04:17 +0000
commit31c3987ca885317be8ef65800ed411fd2e260e83 (patch)
tree0e4166f84376ea2921f7caa0ff0f8830deb2d756
parent891044fd844759b9d0adf2a7f3329bb1e2e38ac4 (diff)
downloadports-31c3987ca885317be8ef65800ed411fd2e260e83.tar.gz
ports-31c3987ca885317be8ef65800ed411fd2e260e83.zip
net/freeradius3: Update to 3.0.25
-rw-r--r--net/freeradius3/Makefile3
-rw-r--r--net/freeradius3/distinfo6
-rw-r--r--net/freeradius3/files/patch-src__main__state.c86
-rw-r--r--net/freeradius3/pkg-plist10
4 files changed, 14 insertions, 91 deletions
diff --git a/net/freeradius3/Makefile b/net/freeradius3/Makefile
index 76703c532217..8c8b8e3eeab2 100644
--- a/net/freeradius3/Makefile
+++ b/net/freeradius3/Makefile
@@ -1,8 +1,7 @@
# Created by: Ryan Steinmetz <zi@FreeBSD.org>
PORTNAME= freeradius
-DISTVERSION= 3.0.23
-PORTREVISION= 1
+DISTVERSION= 3.0.25
CATEGORIES= net
MASTER_SITES= ftp://ftp.freeradius.org/pub/freeradius/%SUBDIR%/ \
ftp://ftp.ntua.gr/pub/net/radius/freeradius/%SUBDIR%/ \
diff --git a/net/freeradius3/distinfo b/net/freeradius3/distinfo
index 9a55a96f7aaf..1cf1ba661fa3 100644
--- a/net/freeradius3/distinfo
+++ b/net/freeradius3/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1626398009
-SHA256 (freeradius-server-3.0.23.tar.bz2) = 08ce42bf0ec217704ca163619c06efcae8a6d6a8ae7a626d77da9a6fd210e235
-SIZE (freeradius-server-3.0.23.tar.bz2) = 3381917
+TIMESTAMP = 1633704252
+SHA256 (freeradius-server-3.0.25.tar.bz2) = fc158cdab4a705b179b1a91cd72473006ef4dfb570b0d097db6c9c34049a4509
+SIZE (freeradius-server-3.0.25.tar.bz2) = 3402380
diff --git a/net/freeradius3/files/patch-src__main__state.c b/net/freeradius3/files/patch-src__main__state.c
deleted file mode 100644
index ea33f43de798..000000000000
--- a/net/freeradius3/files/patch-src__main__state.c
+++ /dev/null
@@ -1,86 +0,0 @@
---- src/main/state.c.orig
-+++ src/main/state.c
-@@ -311,15 +311,30 @@ static state_entry_t *fr_state_cleanup_find(fr_state_t *state)
- continue;
- }
-
-+ /*
-+ * Not yet time to clean it up.
-+ */
-+ if (entry->cleanup > now) {
-+ continue;
-+ }
-+
-+ /*
-+ * We're not running the "client lost" section.
-+ * Just nuke the entry now.
-+ */
-+ if (!main_config.postauth_client_lost) {
-+ state_entry_free(state, entry);
-+ continue;
-+ }
-+
- /*
- * Old enough that the request has been removed.
- * We can add it to the cleanup list.
- */
-- if (entry->cleanup < now) {
-- (*tail) = entry;
-- state_entry_unlink(state, entry);
-- tail = &entry->next;
-- }
-+ state_entry_unlink(state, entry);
-+ entry->next = NULL;
-+ (*tail) = entry;
-+ tail = &entry->next;
- }
-
- return head;
-@@ -335,30 +349,28 @@ static void fr_state_cleanup(state_entry_t *head)
- if (!head) return;
-
- for (entry = head; entry != NULL; entry = next) {
-- next = entry->next;
-+ REQUEST *request;
-
-- if (main_config.postauth_client_lost) {
-- REQUEST *request;
-+ next = entry->next;
-
-- request = fr_state_cleanup_request(entry);
-- if (request) {
-- RDEBUG2("No response from client, cleaning up expired state");
-- RDEBUG2("Restoring &session-state");
-+ request = fr_state_cleanup_request(entry);
-+ if (request) {
-+ RDEBUG2("No response from client, cleaning up expired state");
-+ RDEBUG2("Restoring &session-state");
-
-- /*
-- * @todo - print out message
-- * saying where the handler was
-- * in the process? i.e. "sent
-- * server cert", etc. This will
-- * require updating the EAP code
-- * to put a new attribute into
-- * the session state list.
-- */
-+ /*
-+ * @todo - print out message
-+ * saying where the handler was
-+ * in the process? i.e. "sent
-+ * server cert", etc. This will
-+ * require updating the EAP code
-+ * to put a new attribute into
-+ * the session state list.
-+ */
-
-- rdebug_pair_list(L_DBG_LVL_2, request, request->state, "&session-state:");
-+ rdebug_pair_list(L_DBG_LVL_2, request, request->state, "&session-state:");
-
-- request_inject(request);
-- }
-+ request_inject(request);
- }
-
- talloc_free(entry);
diff --git a/net/freeradius3/pkg-plist b/net/freeradius3/pkg-plist
index 1493f6d54d21..130e9fe685a5 100644
--- a/net/freeradius3/pkg-plist
+++ b/net/freeradius3/pkg-plist
@@ -520,6 +520,12 @@ sbin/radmin
%%PORTDOCS%%%%DOCSDIR%%/antora/modules/howto/pages/protocols/dhcp/policy_subnet_options.adoc
%%PORTDOCS%%%%DOCSDIR%%/antora/modules/howto/pages/protocols/dhcp/prepare.adoc
%%PORTDOCS%%%%DOCSDIR%%/antora/modules/howto/pages/protocols/dhcp/test.adoc
+%%PORTDOCS%%%%DOCSDIR%%/antora/modules/howto/pages/protocols/proxy/enable_proxy_protocol.adoc
+%%PORTDOCS%%%%DOCSDIR%%/antora/modules/howto/pages/protocols/proxy/enable_radsec.adoc
+%%PORTDOCS%%%%DOCSDIR%%/antora/modules/howto/pages/protocols/proxy/index.adoc
+%%PORTDOCS%%%%DOCSDIR%%/antora/modules/howto/pages/protocols/proxy/radsec_client.adoc
+%%PORTDOCS%%%%DOCSDIR%%/antora/modules/howto/pages/protocols/proxy/radsec_with_haproxy.adoc
+%%PORTDOCS%%%%DOCSDIR%%/antora/modules/howto/pages/protocols/proxy/radsec_with_traefik.adoc
%%PORTDOCS%%%%DOCSDIR%%/antora/modules/installation/nav.adoc
%%PORTDOCS%%%%DOCSDIR%%/antora/modules/installation/pages/dependencies.adoc
%%PORTDOCS%%%%DOCSDIR%%/antora/modules/installation/pages/index.adoc
@@ -700,14 +706,17 @@ sbin/radmin
%%EXAMPLESDIR%%/raddb/mods-config/sql/counter/mysql/expire_on_login.conf
%%EXAMPLESDIR%%/raddb/mods-config/sql/counter/mysql/monthlycounter.conf
%%EXAMPLESDIR%%/raddb/mods-config/sql/counter/mysql/noresetcounter.conf
+%%EXAMPLESDIR%%/raddb/mods-config/sql/counter/mysql/weeklycounter.conf
%%EXAMPLESDIR%%/raddb/mods-config/sql/counter/postgresql/dailycounter.conf
%%EXAMPLESDIR%%/raddb/mods-config/sql/counter/postgresql/expire_on_login.conf
%%EXAMPLESDIR%%/raddb/mods-config/sql/counter/postgresql/monthlycounter.conf
%%EXAMPLESDIR%%/raddb/mods-config/sql/counter/postgresql/noresetcounter.conf
+%%EXAMPLESDIR%%/raddb/mods-config/sql/counter/postgresql/weeklycounter.conf
%%EXAMPLESDIR%%/raddb/mods-config/sql/counter/sqlite/dailycounter.conf
%%EXAMPLESDIR%%/raddb/mods-config/sql/counter/sqlite/expire_on_login.conf
%%EXAMPLESDIR%%/raddb/mods-config/sql/counter/sqlite/monthlycounter.conf
%%EXAMPLESDIR%%/raddb/mods-config/sql/counter/sqlite/noresetcounter.conf
+%%EXAMPLESDIR%%/raddb/mods-config/sql/counter/sqlite/weeklycounter.conf
%%EXAMPLESDIR%%/raddb/mods-config/sql/cui/mysql/queries.conf
%%EXAMPLESDIR%%/raddb/mods-config/sql/cui/mysql/schema.sql
%%EXAMPLESDIR%%/raddb/mods-config/sql/cui/postgresql/queries.conf
@@ -919,6 +928,7 @@ sbin/radmin
%%DATADIR%%/dictionary.bt
%%DATADIR%%/dictionary.cablelabs
%%DATADIR%%/dictionary.cabletron
+%%DATADIR%%/dictionary.cambium
%%DATADIR%%/dictionary.camiant
%%DATADIR%%/dictionary.centec
%%DATADIR%%/dictionary.checkpoint