aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2021-07-20 02:10:17 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2021-07-20 02:10:17 +0000
commit321f3162b9e16542343ba16948813103482d839b (patch)
treeb721fb86a0e3ae6f601f0e89d9647f259ed271c6
parentf24b11ec1ed4f27f0a5e78dd28103a48756d4ade (diff)
downloadports-321f3162b9e16542343ba16948813103482d839b.tar.gz
ports-321f3162b9e16542343ba16948813103482d839b.zip
devel/pecl-swoole: update to 4.7.0, also add CARES option.
-rw-r--r--devel/pecl-swoole/Makefile7
-rw-r--r--devel/pecl-swoole/distinfo6
-rw-r--r--devel/pecl-swoole/files/patch-config.m44
-rw-r--r--devel/pecl-swoole/files/patch-ext-src_php__swoole__private.h4
-rw-r--r--devel/pecl-swoole/files/patch-include_swoole__socket.h10
5 files changed, 22 insertions, 9 deletions
diff --git a/devel/pecl-swoole/Makefile b/devel/pecl-swoole/Makefile
index 5cc6cdb50d8a..d7e43b1c4945 100644
--- a/devel/pecl-swoole/Makefile
+++ b/devel/pecl-swoole/Makefile
@@ -1,7 +1,7 @@
# Created by: vanilla@
PORTNAME= swoole
-PORTVERSION= 4.6.7
+PORTVERSION= 4.7.0
CATEGORIES= devel net
MAINTAINER= vanilla@FreeBSD.org
@@ -15,13 +15,16 @@ USE_PHP= hash:build pcre
CONFIGURE_ARGS+= --enable-mysqlnd
-OPTIONS_DEFINE= HTTP2 SOCKETS JSON CURL
+OPTIONS_DEFINE= CARES HTTP2 SOCKETS JSON CURL
+CARES_LIB_DEPENDS= libcares.so:dns/c-ares
+CARES_CONFIGURE_ON= --enable-cares
HTTP2_CONFIGURE_ON= --enable-http2 --enable-openssl
SOCKETS_USE= PHP=sockets:build
SOCKETS_DESC= Use native php sockets extension
SOCKETS_CONFIGURE_ON= --enable-sockets
CURL_LIB_DEPENDS= libcurl.so:ftp/curl
CURL_CONFIGURE_ON= --enable-swoole-curl
+CURL_USE= PHP=curl
JSON_CONFIGURE_ON= --enable-swoole-json
JSON_USE= PHP=json:build
diff --git a/devel/pecl-swoole/distinfo b/devel/pecl-swoole/distinfo
index 00f537b23515..ae6bc8e2410f 100644
--- a/devel/pecl-swoole/distinfo
+++ b/devel/pecl-swoole/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1621425782
-SHA256 (PECL/swoole-4.6.7.tgz) = c5842d3209d1db49a1a6102fb1892a1d73e3bddf8088ca329e53a33f00b9fc80
-SIZE (PECL/swoole-4.6.7.tgz) = 1649407
+TIMESTAMP = 1626746854
+SHA256 (PECL/swoole-4.7.0.tgz) = 690bc9d4d4877e0a7d26e9a18b61ea7b2352caab5022a37d87b4cf7c776d4051
+SIZE (PECL/swoole-4.7.0.tgz) = 1667209
diff --git a/devel/pecl-swoole/files/patch-config.m4 b/devel/pecl-swoole/files/patch-config.m4
index 2688d067148d..dfdcd4f5c616 100644
--- a/devel/pecl-swoole/files/patch-config.m4
+++ b/devel/pecl-swoole/files/patch-config.m4
@@ -1,6 +1,6 @@
---- config.m4.orig 2021-04-22 09:33:36 UTC
+--- config.m4.orig 2021-07-16 07:18:11 UTC
+++ config.m4
-@@ -337,7 +337,7 @@ if test "$PHP_SWOOLE" != "no"; then
+@@ -340,7 +340,7 @@ if test "$PHP_SWOOLE" != "no"; then
AC_CHECK_LIB(c, poll, AC_DEFINE(HAVE_POLL, 1, [have poll]))
AC_CHECK_LIB(c, sendfile, AC_DEFINE(HAVE_SENDFILE, 1, [have sendfile]))
AC_CHECK_LIB(c, kqueue, AC_DEFINE(HAVE_KQUEUE, 1, [have kqueue]))
diff --git a/devel/pecl-swoole/files/patch-ext-src_php__swoole__private.h b/devel/pecl-swoole/files/patch-ext-src_php__swoole__private.h
index 5adb5764f752..c67c8b8473dd 100644
--- a/devel/pecl-swoole/files/patch-ext-src_php__swoole__private.h
+++ b/devel/pecl-swoole/files/patch-ext-src_php__swoole__private.h
@@ -1,6 +1,6 @@
---- ext-src/php_swoole_private.h.orig 2021-04-23 05:47:52 UTC
+--- ext-src/php_swoole_private.h.orig 2021-07-16 07:18:11 UTC
+++ ext-src/php_swoole_private.h
-@@ -894,7 +894,7 @@ static sw_inline zend_bool sw_zend_is_callable_at_fram
+@@ -890,7 +890,7 @@ static sw_inline zend_bool sw_zend_is_callable_at_fram
char **error) {
zend_string *name;
zend_bool ret;
diff --git a/devel/pecl-swoole/files/patch-include_swoole__socket.h b/devel/pecl-swoole/files/patch-include_swoole__socket.h
new file mode 100644
index 000000000000..302c92fb3b28
--- /dev/null
+++ b/devel/pecl-swoole/files/patch-include_swoole__socket.h
@@ -0,0 +1,10 @@
+--- include/swoole_socket.h.orig 2021-07-16 07:18:11 UTC
++++ include/swoole_socket.h
+@@ -17,6 +17,7 @@
+
+ #pragma once
+
++#include <sys/types.h>
+ #include <sys/socket.h>
+ #include <sys/un.h>
+ #include <sys/uio.h>