aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHiroki Tagato <tagattie@FreeBSD.org>2024-02-02 04:44:45 +0000
committerHiroki Tagato <tagattie@FreeBSD.org>2024-02-02 04:46:55 +0000
commit329e3223c2e8fb46134ed055de381e9f6df0ebc7 (patch)
tree6f200b1070e499eeeeef44fc05135daa627d531c
parent6e1793964066b323627cd6508244458dc46736f1 (diff)
downloadports-329e3223c2e8fb46134ed055de381e9f6df0ebc7.tar.gz
ports-329e3223c2e8fb46134ed055de381e9f6df0ebc7.zip
devel/electron26: update to 26.6.8
Changelog: https://github.com/electron/electron/releases/tag/v26.6.8 Reported by: GitHub (watch releases) MFH: 2024Q1 Security: 13a8c4bf-cb2b-48ec-b49c-a3875c72b3e8
-rw-r--r--devel/electron26/Makefile.version2
-rw-r--r--devel/electron26/distinfo10
-rw-r--r--devel/electron26/files/patch-electron_shell_app_node__main.cc10
-rw-r--r--devel/electron26/files/patch-electron_spec_api-crash-reporter-spec.ts14
-rw-r--r--devel/electron26/files/patch-electron_spec_api-utility-process-spec.ts4
5 files changed, 20 insertions, 20 deletions
diff --git a/devel/electron26/Makefile.version b/devel/electron26/Makefile.version
index f2b633415185..4fc2a6d537e0 100644
--- a/devel/electron26/Makefile.version
+++ b/devel/electron26/Makefile.version
@@ -1,2 +1,2 @@
-ELECTRON_VER= 26.6.7
+ELECTRON_VER= 26.6.8
ELECTRON_VER_MAJOR= ${ELECTRON_VER:C/\..*//}
diff --git a/devel/electron26/distinfo b/devel/electron26/distinfo
index e8c11c1cfeff..60275661c6b8 100644
--- a/devel/electron26/distinfo
+++ b/devel/electron26/distinfo
@@ -1,14 +1,14 @@
-TIMESTAMP = 1705645728
+TIMESTAMP = 1706776440
SHA256 (electron/chromium-116.0.5845.228.tar.xz) = ccf3d7f2e17fd2fcda6ebaef576787b2aaba7a6b2b4e3103b92260ac26fbc6a1
SIZE (electron/chromium-116.0.5845.228.tar.xz) = 1447024772
SHA256 (electron/937cea04689b7b8dcf3cb9adbb12c79d1d6c38bb) = f7f7f38661b107fc1d91b7918f36362d9180e87f34e3027562eb5db8735746fe
SIZE (electron/937cea04689b7b8dcf3cb9adbb12c79d1d6c38bb) = 8881070
SHA256 (electron/336e775eec536b2d785cc80eff6ac39051931286) = a2ca2962daf482a8f943163541e1c73ba4b2694fabcd2510981f2db4eda493c8
SIZE (electron/336e775eec536b2d785cc80eff6ac39051931286) = 32624734
-SHA256 (electron/electron-yarn-cache-26.6.7.tar.xz) = 0fbc5dfd81619c971c29a865cfe496c8a54fefcbbb34429896a3ae6901960719
-SIZE (electron/electron-yarn-cache-26.6.7.tar.xz) = 32345420
-SHA256 (electron/electron-electron-v26.6.7_GH0.tar.gz) = 5740e74390a817984b17f6c33240b673557e6b9423a39a7ca7be0f4963410a38
-SIZE (electron/electron-electron-v26.6.7_GH0.tar.gz) = 11392322
+SHA256 (electron/electron-yarn-cache-26.6.8.tar.xz) = 0fbc5dfd81619c971c29a865cfe496c8a54fefcbbb34429896a3ae6901960719
+SIZE (electron/electron-yarn-cache-26.6.8.tar.xz) = 32345420
+SHA256 (electron/electron-electron-v26.6.8_GH0.tar.gz) = d37721fcb006b5372faca94f53648e795968e222348563004b2f691649de4e27
+SIZE (electron/electron-electron-v26.6.8_GH0.tar.gz) = 11396271
SHA256 (electron/nodejs-node-v18.16.1_GH0.tar.gz) = 750b09907a0b7054bda042bfc26879b9ccb84f9f436182a820ea188b654ce77b
SIZE (electron/nodejs-node-v18.16.1_GH0.tar.gz) = 112039326
SHA256 (electron/nodejs-nan-16fa32231e2ccd89d2804b3f765319128b20c4ac_GH0.tar.gz) = 3807ae6a1e451a29f068540472f100f9718d457c60ac62f2f8469d1d57475d39
diff --git a/devel/electron26/files/patch-electron_shell_app_node__main.cc b/devel/electron26/files/patch-electron_shell_app_node__main.cc
index b6cfdaf0f223..5511b3f850a8 100644
--- a/devel/electron26/files/patch-electron_shell_app_node__main.cc
+++ b/devel/electron26/files/patch-electron_shell_app_node__main.cc
@@ -1,4 +1,4 @@
---- electron/shell/app/node_main.cc.orig 2024-01-10 12:22:10 UTC
+--- electron/shell/app/node_main.cc.orig 2024-01-29 19:56:59 UTC
+++ electron/shell/app/node_main.cc
@@ -48,7 +48,7 @@
#include "shell/common/mac/codesign_util.h"
@@ -9,16 +9,16 @@
#include "components/crash/core/app/crashpad.h" // nogncheck
#include "shell/app/electron_crash_reporter_client.h"
#include "shell/common/crash_keys.h"
-@@ -82,7 +82,7 @@ void ExitIfContainsDisallowedFlags(const std::vector<s
- }
+@@ -99,7 +99,7 @@ bool UnsetHijackableEnvs(base::Environment* env) {
}
+ #endif
-#if IS_MAS_BUILD()
+#if IS_MAS_BUILD() || BUILDFLAG(IS_BSD)
void SetCrashKeyStub(const std::string& key, const std::string& value) {}
void ClearCrashKeyStub(const std::string& key) {}
#endif
-@@ -93,7 +93,7 @@ v8::Local<v8::Value> GetParameters(v8::Isolate* isolat
+@@ -110,7 +110,7 @@ v8::Local<v8::Value> GetParameters(v8::Isolate* isolat
v8::Local<v8::Value> GetParameters(v8::Isolate* isolate) {
std::map<std::string, std::string> keys;
@@ -27,7 +27,7 @@
electron::crash_keys::GetCrashKeys(&keys);
#endif
return gin::ConvertToV8(isolate, keys);
-@@ -253,7 +253,7 @@ int NodeMain(int argc, char* argv[]) {
+@@ -270,7 +270,7 @@ int NodeMain(int argc, char* argv[]) {
// Setup process.crashReporter in child node processes
gin_helper::Dictionary reporter = gin::Dictionary::CreateEmpty(isolate);
reporter.SetMethod("getParameters", &GetParameters);
diff --git a/devel/electron26/files/patch-electron_spec_api-crash-reporter-spec.ts b/devel/electron26/files/patch-electron_spec_api-crash-reporter-spec.ts
index 04d61a46f44b..c5193cfaee55 100644
--- a/devel/electron26/files/patch-electron_spec_api-crash-reporter-spec.ts
+++ b/devel/electron26/files/patch-electron_spec_api-crash-reporter-spec.ts
@@ -1,6 +1,6 @@
---- electron/spec/api-crash-reporter-spec.ts.orig 2023-05-31 14:28:29 UTC
+--- electron/spec/api-crash-reporter-spec.ts.orig 2024-01-29 19:56:59 UTC
+++ electron/spec/api-crash-reporter-spec.ts
-@@ -12,7 +12,7 @@ import * as uuid from 'uuid';
+@@ -11,7 +11,7 @@ const isWindowsOnArm = process.platform === 'win32' &&
import { setTimeout } from 'timers/promises';
const isWindowsOnArm = process.platform === 'win32' && process.arch === 'arm64';
@@ -9,7 +9,7 @@
type CrashInfo = {
prod: string
-@@ -45,7 +45,7 @@ function checkCrash (expectedProcessType: string, fiel
+@@ -44,7 +44,7 @@ function checkCrash (expectedProcessType: string, fiel
// TODO(nornagon): minidumps are sometimes (not always) turning up empty on
// 32-bit Linux. Figure out why.
@@ -18,7 +18,7 @@
expect(fields.upload_file_minidump.length).to.be.greaterThan(0);
}
}
-@@ -182,7 +182,7 @@ ifdescribe(!isLinuxOnArm && !process.mas && !process.e
+@@ -181,7 +181,7 @@ ifdescribe(!isLinuxOnArm && !process.mas && !process.e
// Ensures that passing in crashpadHandlerPID flag for Linx child processes
// does not affect child proocess args.
@@ -27,7 +27,7 @@
const { port, waitForCrash } = await startServer();
let exitCode: number | null = null;
const appPath = path.join(__dirname, 'fixtures', 'apps', 'crash');
-@@ -531,7 +531,7 @@ ifdescribe(!isLinuxOnArm && !process.mas && !process.e
+@@ -530,7 +530,7 @@ ifdescribe(!isLinuxOnArm && !process.mas && !process.e
}
}
@@ -36,7 +36,7 @@
: ['main', 'renderer', 'sandboxed-renderer', 'node'];
for (const crashingProcess of processList) {
describe(`when ${crashingProcess} crashes`, () => {
-@@ -543,7 +543,7 @@ ifdescribe(!isLinuxOnArm && !process.mas && !process.e
+@@ -542,7 +542,7 @@ ifdescribe(!isLinuxOnArm && !process.mas && !process.e
return app.getPath('crashDumps');
});
let reportsDir = crashesDir;
@@ -45,7 +45,7 @@
reportsDir = path.join(crashesDir, 'completed');
} else if (process.platform === 'win32') {
reportsDir = path.join(crashesDir, 'reports');
-@@ -567,7 +567,7 @@ ifdescribe(!isLinuxOnArm && !process.mas && !process.e
+@@ -566,7 +566,7 @@ ifdescribe(!isLinuxOnArm && !process.mas && !process.e
expect(remoteCrashesDir).to.equal(crashesDir);
let reportsDir = crashesDir;
diff --git a/devel/electron26/files/patch-electron_spec_api-utility-process-spec.ts b/devel/electron26/files/patch-electron_spec_api-utility-process-spec.ts
index aff143ca5a33..9b9a1622e94f 100644
--- a/devel/electron26/files/patch-electron_spec_api-utility-process-spec.ts
+++ b/devel/electron26/files/patch-electron_spec_api-utility-process-spec.ts
@@ -1,6 +1,6 @@
---- electron/spec/api-utility-process-spec.ts.orig 2023-10-24 20:32:34 UTC
+--- electron/spec/api-utility-process-spec.ts.orig 2024-01-29 19:56:59 UTC
+++ electron/spec/api-utility-process-spec.ts
-@@ -375,7 +375,7 @@ describe('utilityProcess module', () => {
+@@ -376,7 +376,7 @@ describe('utilityProcess module', () => {
await closeWindow(w);
});