aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJose Luis Duran <jlduran@gmail.com>2024-04-03 06:54:58 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2024-04-20 17:13:10 +0000
commit32cab2d7dceac27377907d13d2ea35bf9e7d2e2a (patch)
treea085c52eba148986c67695dc0355e83fa27f5061
parentaa07dee24869a6ee835bc1831e08d6f1845e56ff (diff)
downloadports-32cab2d7dceac27377907d13d2ea35bf9e7d2e2a.tar.gz
ports-32cab2d7dceac27377907d13d2ea35bf9e7d2e2a.zip
security/strongswan: Update to 5.9.14
ChangeLog: https://github.com/strongswan/strongswan/releases/tag/5.9.14 PR: 278137 Reported by: jlduran@gmail.com Approved by: strongswan@Nanoteq.com (maintainer, timeout > 2 weeks)
-rw-r--r--security/strongswan/Makefile7
-rw-r--r--security/strongswan/distinfo6
-rw-r--r--security/strongswan/files/patch-src_charon_charon.c11
-rw-r--r--security/strongswan/pkg-plist4
4 files changed, 11 insertions, 17 deletions
diff --git a/security/strongswan/Makefile b/security/strongswan/Makefile
index 3375aa5445af..a096ec2d2257 100644
--- a/security/strongswan/Makefile
+++ b/security/strongswan/Makefile
@@ -1,6 +1,5 @@
PORTNAME= strongswan
-DISTVERSION= 5.9.13
-PORTREVISION= 1
+DISTVERSION= 5.9.14
CATEGORIES= security net-vpn
MASTER_SITES= https://download.strongswan.org/ \
https://download2.strongswan.org/
@@ -42,7 +41,7 @@ CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc \
INSTALL_TARGET= install-strip
TEST_TARGET= check
-OPTIONS_DEFINE= CTR CURL EAPAKA3GPP2 EAPDYNAMIC EAPRADIUS \
+OPTIONS_DEFINE= CTR CURL DHCP EAPAKA3GPP2 EAPDYNAMIC EAPRADIUS \
EAPSIMFILE FARP GCM IKEV1 IPSECKEY KDF \
KERNELLIBIPSEC LDAP LOADTESTER MEDIATION MYSQL \
PKCS11 PKI PYTHON SMP SQLITE SWANCTL \
@@ -57,6 +56,7 @@ OPTIONS_SUB= yes
BUILTIN_DESC= Use builtin printf hooks
CTR_DESC= Enable CTR cipher mode wrapper plugin
CURL_DESC= Enable CURL to fetch CRL/OCSP
+DHCP_DESC= Enable DHCP based attribute provider plugin
EAPAKA3GPP2_DESC= Enable EAP AKA with 3gpp2 backend
EAPDYNAMIC_DESC= Enable EAP dynamic proxy module
EAPRADIUS_DESC= Enable EAP Radius proxy authentication
@@ -90,6 +90,7 @@ BUILTIN_CONFIGURE_ON= --with-printf-hooks=builtin
CTR_CONFIGURE_ON= --enable-ctr
CURL_LIB_DEPENDS= libcurl.so:ftp/curl
CURL_CONFIGURE_ON= --enable-curl
+DHCP_CONFIGURE_ON= --enable-dhcp
EAPAKA3GPP2_LIB_DEPENDS= libgmp.so:math/gmp
EAPAKA3GPP2_CONFIGURE_ON= --enable-eap-aka \
--enable-eap-aka-3gpp2
diff --git a/security/strongswan/distinfo b/security/strongswan/distinfo
index b24347585614..086d5c11d152 100644
--- a/security/strongswan/distinfo
+++ b/security/strongswan/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1702006969
-SHA256 (strongswan-5.9.13.tar.bz2) = 56e30effb578fd9426d8457e3b76c8c3728cd8a5589594b55649b2719308ba55
-SIZE (strongswan-5.9.13.tar.bz2) = 4825644
+TIMESTAMP = 1712096228
+SHA256 (strongswan-5.9.14.tar.bz2) = 728027ddda4cb34c67c4cec97d3ddb8c274edfbabdaeecf7e74693b54fc33678
+SIZE (strongswan-5.9.14.tar.bz2) = 4869709
diff --git a/security/strongswan/files/patch-src_charon_charon.c b/security/strongswan/files/patch-src_charon_charon.c
deleted file mode 100644
index 164a98677bcc..000000000000
--- a/security/strongswan/files/patch-src_charon_charon.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/charon/charon.c.orig 2019-01-12 00:15:48 UTC
-+++ src/charon/charon.c
-@@ -377,7 +377,7 @@ int main(int argc, char *argv[])
- status = 0;
- goto deinit;
- case 'v':
-- printf("Linux strongSwan %s\n", VERSION);
-+ printf("FreeBSD strongSwan %s\n", VERSION);
- status = 0;
- goto deinit;
- case 'l':
diff --git a/security/strongswan/pkg-plist b/security/strongswan/pkg-plist
index 9cdb6871b528..b8d1fb6e6288 100644
--- a/security/strongswan/pkg-plist
+++ b/security/strongswan/pkg-plist
@@ -17,6 +17,7 @@
%%CURL%%@sample %%ETCDIR%%.d/charon/curl.conf.sample
@sample %%ETCDIR%%.d/charon/curve25519.conf.sample
@sample %%ETCDIR%%.d/charon/des.conf.sample
+%%DHCP%%%%ETCDIR%%.d/charon/dhcp.conf.sample
@sample %%ETCDIR%%.d/charon/dnskey.conf.sample
@sample %%ETCDIR%%.d/charon/drbg.conf.sample
%%EAPAKA3GPP2%%@sample %%ETCDIR%%.d/charon/eap-aka-3gpp2.conf.sample
@@ -144,6 +145,8 @@ lib/ipsec/plugins/libstrongswan-curve25519.la
lib/ipsec/plugins/libstrongswan-curve25519.so
lib/ipsec/plugins/libstrongswan-des.la
lib/ipsec/plugins/libstrongswan-des.so
+%%DHCP%%lib/ipsec/plugins/libstrongswan-dhcp.la
+%%DHCP%%lib/ipsec/plugins/libstrongswan-dhcp.so
lib/ipsec/plugins/libstrongswan-dnskey.la
lib/ipsec/plugins/libstrongswan-dnskey.so
lib/ipsec/plugins/libstrongswan-drbg.la
@@ -321,6 +324,7 @@ sbin/ipsec
%%CURL%%%%DATADIR%%/templates/config/plugins/curl.conf
%%DATADIR%%/templates/config/plugins/curve25519.conf
%%DATADIR%%/templates/config/plugins/des.conf
+%%DHCP%%%%DATADIR%%/templates/config/plugins/dhcp.conf
%%DATADIR%%/templates/config/plugins/dnskey.conf
%%DATADIR%%/templates/config/plugins/drbg.conf
%%EAPAKA3GPP2%%%%DATADIR%%/templates/config/plugins/eap-aka-3gpp2.conf