aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-08-27 06:44:19 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-08-27 08:27:58 +0000
commit330fcb3b9c05e66d9c12721795e9a3f710ec0a06 (patch)
tree280dc870849acabdf3322b9fea821a3e008368c4
parent3c71654cbd40d81863acc47cee71345c058684be (diff)
downloadports-330fcb3b9c05e66d9c12721795e9a3f710ec0a06.tar.gz
ports-330fcb3b9c05e66d9c12721795e9a3f710ec0a06.zip
www/py-google-cloud-bigquery: New port: Google BigQuery API client library
-rw-r--r--www/Makefile1
-rw-r--r--www/py-google-cloud-bigquery/Makefile30
-rw-r--r--www/py-google-cloud-bigquery/distinfo3
-rw-r--r--www/py-google-cloud-bigquery/pkg-descr3
4 files changed, 37 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 6092467b3962..7aa846af50cb 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1664,6 +1664,7 @@
SUBDIR += py-google-api-python-client
SUBDIR += py-google-cloud-appengine-logging
SUBDIR += py-google-cloud-audit-log
+ SUBDIR += py-google-cloud-bigquery
SUBDIR += py-google-cloud-bigtable
SUBDIR += py-google-cloud-core
SUBDIR += py-google-cloud-datastore
diff --git a/www/py-google-cloud-bigquery/Makefile b/www/py-google-cloud-bigquery/Makefile
new file mode 100644
index 000000000000..6037d1bf2c20
--- /dev/null
+++ b/www/py-google-cloud-bigquery/Makefile
@@ -0,0 +1,30 @@
+PORTNAME= google-cloud-bigquery
+PORTVERSION= 3.11.4
+CATEGORIES= www python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Google BigQuery API client library
+WWW= https://github.com/googleapis/python-bigquery
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}google-api-core>=1.31.5:www/py-google-api-core@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}google-cloud-core>=1.6.0:www/py-google-cloud-core@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}google-resumable-media>=0.6.0:www/py-google-resumable-media@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}grpcio>=1.47.0:devel/py-grpcio@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}grpcio>=1.49.1:devel/py-grpcio@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}packaging>=20.0.0:devel/py-packaging@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}proto-plus>=1.15.0:devel/py-proto-plus@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}protobuf>=3.19.5:devel/py-protobuf@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}dateutil>0:devel/py-dateutil@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>=2.21.0:www/py-requests@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist distutils pytest # tests are broken because they use an outdated Python package 'autotest' that breaks on configure
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/www/py-google-cloud-bigquery/distinfo b/www/py-google-cloud-bigquery/distinfo
new file mode 100644
index 000000000000..0c3510b6c7e9
--- /dev/null
+++ b/www/py-google-cloud-bigquery/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1693116602
+SHA256 (google-cloud-bigquery-3.11.4.tar.gz) = 697df117241a2283bcbb93b21e10badc14e51c9a90800d2a7e1a3e1c7d842974
+SIZE (google-cloud-bigquery-3.11.4.tar.gz) = 410777
diff --git a/www/py-google-cloud-bigquery/pkg-descr b/www/py-google-cloud-bigquery/pkg-descr
new file mode 100644
index 000000000000..00703c7fcb3e
--- /dev/null
+++ b/www/py-google-cloud-bigquery/pkg-descr
@@ -0,0 +1,3 @@
+Google BigQuery solves the problem of the querying massive datasets problem by
+enabling super-fast, SQL queries against append-mostly tables, using the
+processing power of Google's infrastructure.