aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2021-10-14 10:58:33 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-11-04 23:16:51 +0000
commit333268b786fa8eda0aab1f35e714007a17616227 (patch)
tree0ef187d1b38ab965b7863140897753c2b406025e
parentb50fe7463fdf9d4614f62173d84686202fe22d4a (diff)
downloadports-333268b786fa8eda0aab1f35e714007a17616227.tar.gz
ports-333268b786fa8eda0aab1f35e714007a17616227.zip
graphics/wrapland: add new port
Wrapland is a Qt/C++ library that wraps and mediates the libwayland client and server API for its consumers. Wrapland is an independent part of the KWinFT project with the KWinFT window manager being Wrapland's first and most prominent user. https://gitlab.com/kwinft/wrapland
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/wrapland/Makefile34
-rw-r--r--graphics/wrapland/distinfo3
-rw-r--r--graphics/wrapland/pkg-descr6
-rw-r--r--graphics/wrapland/pkg-plist143
5 files changed, 187 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index a7886d974ad1..5bb899bce1ca 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -1116,6 +1116,7 @@
SUBDIR += webp-pixbuf-loader
SUBDIR += wings
SUBDIR += wmicons
+ SUBDIR += wrapland
SUBDIR += wxsvg
SUBDIR += xaos
SUBDIR += xbmbrowser
diff --git a/graphics/wrapland/Makefile b/graphics/wrapland/Makefile
new file mode 100644
index 000000000000..b24c45084342
--- /dev/null
+++ b/graphics/wrapland/Makefile
@@ -0,0 +1,34 @@
+PORTNAME= wrapland
+DISTVERSIONPREFIX= ${PORTNAME}@
+DISTVERSION= 0.523.0
+CATEGORIES= graphics
+
+MAINTAINER= jbeich@FreeBSD.org
+COMMENT= Qt/C++ library wrapping libwayland
+
+LICENSE= LGPL21+
+LICENSE_FILE= ${WRKSRC}/COPYING.LIB
+
+BUILD_DEPENDS= wayland-protocols>=1.22:graphics/wayland-protocols
+LIB_DEPENDS= libwayland-client.so:graphics/wayland
+TEST_DEPENDS= ${qt-testlib_PORT:T}>0:${qt-testlib_PORT}
+
+USES= cmake:testing gl kde:5 pkgconfig qt:5
+USE_GITLAB= yes
+USE_GL= egl
+USE_KDE= ecm_build
+USE_LDCONFIG= yes
+USE_QT= qmake_build buildtools_build concurrent core gui
+GL_ACCOUNT= kwinft
+GL_COMMIT= d075e49bf723419f7cce0f2fdd4379990bbea26b
+PLIST_SUB= VERSION=${PORTVERSION}
+
+OPTIONS_DEFINE= DOXYGEN
+OPTIONS_DEFAULT=DOXYGEN
+OPTIONS_SUB= yes
+
+DOXYGEN_BUILD_DEPENDS= doxygen:devel/doxygen
+DOXYGEN_USE= QT=help_build
+DOXYGEN_CMAKE_BOOL= BUILD_QCH
+
+.include <bsd.port.mk>
diff --git a/graphics/wrapland/distinfo b/graphics/wrapland/distinfo
new file mode 100644
index 000000000000..7434fc66fb8c
--- /dev/null
+++ b/graphics/wrapland/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1634209113
+SHA256 (kwinft-wrapland-d075e49bf723419f7cce0f2fdd4379990bbea26b_GL0.tar.gz) = c903312dc3129863d9a25c26acac87434c876d172aa2ca693630dc19ce918005
+SIZE (kwinft-wrapland-d075e49bf723419f7cce0f2fdd4379990bbea26b_GL0.tar.gz) = 527595
diff --git a/graphics/wrapland/pkg-descr b/graphics/wrapland/pkg-descr
new file mode 100644
index 000000000000..90d06d214af8
--- /dev/null
+++ b/graphics/wrapland/pkg-descr
@@ -0,0 +1,6 @@
+Wrapland is a Qt/C++ library that wraps and mediates the libwayland
+client and server API for its consumers. Wrapland is an independent
+part of the KWinFT project with the KWinFT window manager being
+Wrapland's first and most prominent user.
+
+WWW: https://gitlab.com/kwinft/wrapland
diff --git a/graphics/wrapland/pkg-plist b/graphics/wrapland/pkg-plist
new file mode 100644
index 000000000000..19dc0b232257
--- /dev/null
+++ b/graphics/wrapland/pkg-plist
@@ -0,0 +1,143 @@
+include/Wrapland/Client/appmenu.h
+include/Wrapland/Client/blur.h
+include/Wrapland/Client/buffer.h
+include/Wrapland/Client/compositor.h
+include/Wrapland/Client/connection_thread.h
+include/Wrapland/Client/contrast.h
+include/Wrapland/Client/datadevice.h
+include/Wrapland/Client/datadevicemanager.h
+include/Wrapland/Client/dataoffer.h
+include/Wrapland/Client/datasource.h
+include/Wrapland/Client/dpms.h
+include/Wrapland/Client/drm_lease_v1.h
+include/Wrapland/Client/event_queue.h
+include/Wrapland/Client/fakeinput.h
+include/Wrapland/Client/fullscreen_shell.h
+include/Wrapland/Client/idle.h
+include/Wrapland/Client/idleinhibit.h
+include/Wrapland/Client/input_method_v2.h
+include/Wrapland/Client/keyboard.h
+include/Wrapland/Client/keyboard_shortcuts_inhibit.h
+include/Wrapland/Client/keystate.h
+include/Wrapland/Client/layer_shell_v1.h
+include/Wrapland/Client/linux_dmabuf_v1.h
+include/Wrapland/Client/output.h
+include/Wrapland/Client/output_configuration_v1.h
+include/Wrapland/Client/output_device_v1.h
+include/Wrapland/Client/output_management_v1.h
+include/Wrapland/Client/plasmashell.h
+include/Wrapland/Client/plasmavirtualdesktop.h
+include/Wrapland/Client/plasmawindowmanagement.h
+include/Wrapland/Client/plasmawindowmodel.h
+include/Wrapland/Client/pointer.h
+include/Wrapland/Client/pointerconstraints.h
+include/Wrapland/Client/pointergestures.h
+include/Wrapland/Client/presentation_time.h
+include/Wrapland/Client/primary_selection.h
+include/Wrapland/Client/region.h
+include/Wrapland/Client/registry.h
+include/Wrapland/Client/relativepointer.h
+include/Wrapland/Client/seat.h
+include/Wrapland/Client/server_decoration_palette.h
+include/Wrapland/Client/shadow.h
+include/Wrapland/Client/shell.h
+include/Wrapland/Client/shm_pool.h
+include/Wrapland/Client/slide.h
+include/Wrapland/Client/subcompositor.h
+include/Wrapland/Client/subsurface.h
+include/Wrapland/Client/surface.h
+include/Wrapland/Client/text_input_v2.h
+include/Wrapland/Client/text_input_v3.h
+include/Wrapland/Client/touch.h
+include/Wrapland/Client/viewporter.h
+include/Wrapland/Client/wlr_output_configuration_v1.h
+include/Wrapland/Client/wlr_output_manager_v1.h
+include/Wrapland/Client/wraplandclient_export.h
+include/Wrapland/Client/xdg_activation_v1.h
+include/Wrapland/Client/xdg_shell.h
+include/Wrapland/Client/xdg_shell_popup.h
+include/Wrapland/Client/xdg_shell_positioner.h
+include/Wrapland/Client/xdg_shell_toplevel.h
+include/Wrapland/Client/xdgdecoration.h
+include/Wrapland/Client/xdgforeign.h
+include/Wrapland/Client/xdgoutput.h
+include/Wrapland/Server/appmenu.h
+include/Wrapland/Server/blur.h
+include/Wrapland/Server/buffer.h
+include/Wrapland/Server/client.h
+include/Wrapland/Server/compositor.h
+include/Wrapland/Server/contrast.h
+include/Wrapland/Server/data_device.h
+include/Wrapland/Server/data_device_manager.h
+include/Wrapland/Server/data_offer.h
+include/Wrapland/Server/data_source.h
+include/Wrapland/Server/display.h
+include/Wrapland/Server/dpms.h
+include/Wrapland/Server/drag_pool.h
+include/Wrapland/Server/drm_lease_v1.h
+include/Wrapland/Server/egl_stream_controller.h
+include/Wrapland/Server/fake_input.h
+include/Wrapland/Server/filtered_display.h
+include/Wrapland/Server/idle_inhibit_v1.h
+include/Wrapland/Server/input_method_v2.h
+include/Wrapland/Server/kde_idle.h
+include/Wrapland/Server/keyboard.h
+include/Wrapland/Server/keyboard_pool.h
+include/Wrapland/Server/keyboard_shortcuts_inhibit.h
+include/Wrapland/Server/keystate.h
+include/Wrapland/Server/layer_shell_v1.h
+include/Wrapland/Server/linux_dmabuf_v1.h
+include/Wrapland/Server/output.h
+include/Wrapland/Server/output_changeset_v1.h
+include/Wrapland/Server/output_configuration_v1.h
+include/Wrapland/Server/output_device_v1.h
+include/Wrapland/Server/output_management_v1.h
+include/Wrapland/Server/plasma_shell.h
+include/Wrapland/Server/plasma_virtual_desktop.h
+include/Wrapland/Server/plasma_window.h
+include/Wrapland/Server/pointer.h
+include/Wrapland/Server/pointer_constraints_v1.h
+include/Wrapland/Server/pointer_gestures_v1.h
+include/Wrapland/Server/pointer_pool.h
+include/Wrapland/Server/presentation_time.h
+include/Wrapland/Server/primary_selection.h
+include/Wrapland/Server/region.h
+include/Wrapland/Server/relative_pointer_v1.h
+include/Wrapland/Server/seat.h
+include/Wrapland/Server/server_decoration_palette.h
+include/Wrapland/Server/shadow.h
+include/Wrapland/Server/slide.h
+include/Wrapland/Server/subcompositor.h
+include/Wrapland/Server/surface.h
+include/Wrapland/Server/text_input_pool.h
+include/Wrapland/Server/text_input_v2.h
+include/Wrapland/Server/text_input_v3.h
+include/Wrapland/Server/touch.h
+include/Wrapland/Server/touch_pool.h
+include/Wrapland/Server/viewporter.h
+include/Wrapland/Server/wl_output.h
+include/Wrapland/Server/wraplandserver_export.h
+include/Wrapland/Server/xdg_activation_v1.h
+include/Wrapland/Server/xdg_decoration.h
+include/Wrapland/Server/xdg_foreign.h
+include/Wrapland/Server/xdg_output.h
+include/Wrapland/Server/xdg_shell.h
+include/Wrapland/Server/xdg_shell_popup.h
+include/Wrapland/Server/xdg_shell_surface.h
+include/Wrapland/Server/xdg_shell_toplevel.h
+include/wrapland_version.h
+lib/cmake/Wrapland/WraplandConfig.cmake
+lib/cmake/Wrapland/WraplandConfigVersion.cmake
+%%DOXYGEN%%lib/cmake/Wrapland/WraplandQchTargets.cmake
+lib/cmake/Wrapland/WraplandTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/Wrapland/WraplandTargets.cmake
+lib/libWraplandClient.so
+lib/libWraplandClient.so.0
+lib/libWraplandClient.so.%%VERSION%%
+lib/libWraplandServer.so
+lib/libWraplandServer.so.0
+lib/libWraplandServer.so.%%VERSION%%
+lib/libexec/org-kde-kf5-wrapland-testserver
+%%DOXYGEN%%%%QT_DOCDIR%%/Wrapland.qch
+%%DOXYGEN%%%%QT_DOCDIR%%/Wrapland.tags
+share/qlogging-categories5/org_kde_wrapland.categories