aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2022-05-22 03:01:11 +0000
committerJason Helfman <jgh@FreeBSD.org>2022-05-22 03:01:11 +0000
commit334cedb860352502e73cb850a3d99bec53c3a978 (patch)
tree449c9400fbb53dd17a8a8b92aaed235051acb61e
parent264653451346b9acee98978d9a12fa1319e9d88d (diff)
downloadports-334cedb860352502e73cb850a3d99bec53c3a978.tar.gz
ports-334cedb860352502e73cb850a3d99bec53c3a978.zip
devel/libayatana-appindicator: Add new port
Reviewed by: koobs@ Ayatana Application Indicators (Shared Library) A library to allow applications to export a menu into the an Application Indicators aware menu bar. Based on KSNI it also works in KDE and will fallback to generic Systray support if none of those are available. This code project was originally started by Canonical Ltd. and has been adapted by various authors with the purpose of making this Application Indicators available on Ubuntu and non-Ubuntu systems alike. WWW: https://github.com/AyatanaIndicators/libayatana-appindicator
-rw-r--r--devel/Makefile1
-rw-r--r--devel/libayatana-appindicator/Makefile33
-rw-r--r--devel/libayatana-appindicator/distinfo3
-rw-r--r--devel/libayatana-appindicator/pkg-descr11
-rw-r--r--devel/libayatana-appindicator/pkg-plist8
5 files changed, 56 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index ec8ee5bafb6f..ce09e8747dd2 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1165,6 +1165,7 @@
SUBDIR += libatomic_ops
SUBDIR += libaura
SUBDIR += libavl
+ SUBDIR += libayatana-appindicator
SUBDIR += libayatana-indicator
SUBDIR += libb2
SUBDIR += libbacktrace
diff --git a/devel/libayatana-appindicator/Makefile b/devel/libayatana-appindicator/Makefile
new file mode 100644
index 000000000000..36b2f21b1c13
--- /dev/null
+++ b/devel/libayatana-appindicator/Makefile
@@ -0,0 +1,33 @@
+PORTNAME= libayatana-appindicator
+PORTVERSION= 0.5.91
+CATEGORIES= devel
+
+MAINTAINER= jgh@FreeBSD.org
+COMMENT= Ayatana Application Indicators Shared Library
+
+LICENSE= LGPL3
+
+BUILD_DEPENDS= lcov>=0:devel/lcov
+
+USES= cmake localbase:ldflags gnome pkgconfig
+
+LIB_DEPENDS+= libharfbuzz.so:print/harfbuzz \
+ libgtest.so:devel/googletest \
+ libayatana-indicator3.so:devel/libayatana-indicator \
+ libdbusmenu-glib.so:devel/libdbusmenu \
+ libayatana-ido3-0.4.so:devel/ayatana-ido
+
+USE_GNOME= introspection gtk30 glib20 pango atk cairo gdkpixbuf2
+CMAKE_OFF= ENABLE_BINDINGS_MONO \
+ FLAVOUR_GTK2 \
+ ENABLE_BINDINGS_VALA
+
+USE_LDCONFIG= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= AyatanaIndicators
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libayatana-appindicator3.so.*
+
+.include <bsd.port.mk>
diff --git a/devel/libayatana-appindicator/distinfo b/devel/libayatana-appindicator/distinfo
new file mode 100644
index 000000000000..03a3107846cb
--- /dev/null
+++ b/devel/libayatana-appindicator/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1652970199
+SHA256 (AyatanaIndicators-libayatana-appindicator-0.5.91_GH0.tar.gz) = 52eb5d0c0de07177833e50fbaee592dcb3939e96c6b789921e2a8caf40a1ed26
+SIZE (AyatanaIndicators-libayatana-appindicator-0.5.91_GH0.tar.gz) = 158269
diff --git a/devel/libayatana-appindicator/pkg-descr b/devel/libayatana-appindicator/pkg-descr
new file mode 100644
index 000000000000..ade0f315d69c
--- /dev/null
+++ b/devel/libayatana-appindicator/pkg-descr
@@ -0,0 +1,11 @@
+Ayatana Application Indicators (Shared Library)
+
+A library to allow applications to export a menu into the an Application
+Indicators aware menu bar. Based on KSNI it also works in KDE and will
+fallback to generic Systray support if none of those are available.
+
+This code project was originally started by Canonical Ltd. and has been
+adapted by various authors with the purpose of making this Application
+Indicators available on Ubuntu and non-Ubuntu systems alike.
+
+WWW: https://github.com/AyatanaIndicators/libayatana-appindicator
diff --git a/devel/libayatana-appindicator/pkg-plist b/devel/libayatana-appindicator/pkg-plist
new file mode 100644
index 000000000000..194a72c4bc3a
--- /dev/null
+++ b/devel/libayatana-appindicator/pkg-plist
@@ -0,0 +1,8 @@
+include/libayatana-appindicator3-0.1/libayatana-appindicator/app-indicator-enum-types.h
+include/libayatana-appindicator3-0.1/libayatana-appindicator/app-indicator.h
+lib/girepository-1.0/AyatanaAppIndicator3-0.1.typelib
+lib/libayatana-appindicator3.so
+lib/libayatana-appindicator3.so.1
+lib/libayatana-appindicator3.so.1.0.0
+libdata/pkgconfig/ayatana-appindicator3-0.1.pc
+share/gir-1.0/AyatanaAppIndicator3-0.1.gir