aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-10-21 09:50:55 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-10-21 10:10:50 +0000
commit33e1ace9db0633e5fb0a2aa135b0db7208874db3 (patch)
tree837eabb484cb0a89c4a1a9d595445c30885b69c4
parenteb64f8ad82f297be34c230ce62ddb34324d01457 (diff)
downloadports-33e1ace9db0633e5fb0a2aa135b0db7208874db3.tar.gz
ports-33e1ace9db0633e5fb0a2aa135b0db7208874db3.zip
ftp/yafc: Optionize INFO
- Update WWW - Refactor pkg-descr
-rw-r--r--ftp/yafc/Makefile18
-rw-r--r--ftp/yafc/pkg-descr2
2 files changed, 12 insertions, 8 deletions
diff --git a/ftp/yafc/Makefile b/ftp/yafc/Makefile
index f5733fdd0361..e151310cb5dd 100644
--- a/ftp/yafc/Makefile
+++ b/ftp/yafc/Makefile
@@ -5,14 +5,14 @@ CATEGORIES= ftp
MAINTAINER= bofh@FreeBSD.org
COMMENT= Yet another FTP client, similar to ftp(1)
-WWW= https://web.archive.org/web/20180422134425/http://www.yafc-ftp.com/
+WWW= https://github.com/sebastinas/yafc
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= glib>0:devel/glib20
-USES= autoreconf gmake localbase makeinfo pkgconfig ssl tar:xz
+USES= autoreconf gmake localbase pkgconfig ssl tar:xz
USE_GITHUB= yes
GH_ACCOUNT= sebastinas
@@ -23,18 +23,18 @@ CONFIGURE_ARGS= --with-krb5=no \
--with-socks=no
CONFIGURE_ENV= ac_cv_ipv6=yes
-INFO= yafc
PLIST_FILES= bin/yafc \
man/man1/yafc.1.gz
PORTEXAMPLES= inputrc yafcrc
-OPTIONS_DEFINE= BASH EXAMPLES NLS READLINE SSH
-OPTIONS_DEFAULT= BASH SSH
+OPTIONS_DEFINE= BASH EXAMPLES INFO NLS READLINE SSH
+OPTIONS_DEFAULT= BASH INFO SSH
BASH_CONFIGURE_OFF= --with-bash-completion=no
BASH_CONFIGURE_ON= --with-bash-completion=yes
BASH_PLIST_FILES= etc/bash_completion.d/yafc
-
+INFO_USES= makeinfo
+INFO_INFO= yafc
NLS_USES= gettext gnome
NLS_USE= GNOME=intltool
NLS_CONFIGURE_WITH= gettext=${LOCALBASE}
@@ -50,6 +50,12 @@ SSH_CONFIGURE_OFF= --without-ssh
pre-configure:
@(cd ${WRKSRC} && ${LOCALBASE}/bin/glib-gettextize -f -c)
+post-patch-INFO-off:
+ @${REINPLACE_CMD} -e '/^SUBDIRS/s|doc||g' ${WRKSRC}/Makefile.am
+
+post-install-INFO-off:
+ ${INSTALL_MAN} ${WRKSRC}/doc/yafc.1 ${STAGEDIR}${PREFIX}/man/man1/
+
post-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/samples/* ${STAGEDIR}${EXAMPLESDIR}
diff --git a/ftp/yafc/pkg-descr b/ftp/yafc/pkg-descr
index 465a863ef568..2b7bd5496387 100644
--- a/ftp/yafc/pkg-descr
+++ b/ftp/yafc/pkg-descr
@@ -1,5 +1,3 @@
Yafc is yet another ftp client, similar to ftp(1). Features include
Directory cache, remote filename completion, aliases, colored ls,
recursive get/put/ls/rm, nohup mode transfers, and more!
-
-See also: https://github.com/sebastinas/yafc