aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGleb Popov <arrowd@FreeBSD.org>2023-12-27 20:35:18 +0000
committerGleb Popov <arrowd@FreeBSD.org>2024-01-06 15:29:11 +0000
commit33ef38cf0fb2f74b6a80d3490aa293862dd533db (patch)
tree7c6a0496c39f284f5a44ec5014a1bd9d4430d250
parentd81d1dca481620812d6aaa4e97ff594d14bf1477 (diff)
downloadports-33ef38cf0fb2f74b6a80d3490aa293862dd533db.tar.gz
ports-33ef38cf0fb2f74b6a80d3490aa293862dd533db.zip
misc/compat13x: Add port.
This port provides only base OpenSSL 1.1.1 for now.
-rw-r--r--misc/Makefile1
-rw-r--r--misc/compat13x/Makefile39
-rw-r--r--misc/compat13x/distinfo3
-rw-r--r--misc/compat13x/pkg-descr12
-rw-r--r--misc/compat13x/pkg-plist.amd644
-rw-r--r--misc/compat13x/pkg-plist.i3862
6 files changed, 61 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index e11acaaadaee..25cfe2f8a443 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -57,6 +57,7 @@
SUBDIR += compat10x
SUBDIR += compat11x
SUBDIR += compat12x
+ SUBDIR += compat13x
SUBDIR += compat4x
SUBDIR += compat5x
SUBDIR += compat6x
diff --git a/misc/compat13x/Makefile b/misc/compat13x/Makefile
new file mode 100644
index 000000000000..87f1c1374e5a
--- /dev/null
+++ b/misc/compat13x/Makefile
@@ -0,0 +1,39 @@
+PORTNAME= compat13x
+PORTVERSION= 13.2.1302001.20231227
+CATEGORIES= misc
+MASTER_SITES= LOCAL/arrowd
+PKGNAMESUFFIX= -${ARCH}
+DISTNAME= ${PORTNAME}-${ARCH}-${PORTVERSION}
+
+MAINTAINER= arrowd@FreeBSD.org
+COMMENT= Convenience package to install the compat13x libraries
+
+LICENSE= BSD2CLAUSE
+
+USES= tar:xz
+NO_BUILD= yes
+ONLY_FOR_ARCHS= amd64 i386
+PLIST= ${PKGDIR}/pkg-plist.${ARCH}
+TARGET_DIR= ${PREFIX}/lib/compat
+TARGET32_DIR= ${PREFIX}/lib32/compat
+USE_LDCONFIG= ${TARGET_DIR}
+
+.include <bsd.port.pre.mk>
+
+.if ${OSREL:R} < 13
+IGNORE= is for FreeBSD 13.x and newer
+.endif
+
+.if ${ARCH} == amd64
+USE_LDCONFIG32= ${TARGET32_DIR}
+.endif
+
+do-install:
+ @${MKDIR} -m 0755 ${STAGEDIR}${TARGET_DIR}
+ (cd ${WRKSRC}/lib && ${INSTALL_LIB} *.so.* ${STAGEDIR}${TARGET_DIR})
+.if ${ARCH} == amd64
+ @${MKDIR} ${STAGEDIR}${TARGET32_DIR}
+ (cd ${WRKSRC}/lib32 && ${INSTALL_LIB} *.so.* ${STAGEDIR}${TARGET32_DIR})
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/misc/compat13x/distinfo b/misc/compat13x/distinfo
new file mode 100644
index 000000000000..95eb2dc90cd5
--- /dev/null
+++ b/misc/compat13x/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1703708988
+SHA256 (compat13x-amd64-13.2.1302001.20231227.tar.xz) = 6708bb02695031e943921738f5d773cd535f15518d167b0864b1fe5ba33f98db
+SIZE (compat13x-amd64-13.2.1302001.20231227.tar.xz) = 2227724
diff --git a/misc/compat13x/pkg-descr b/misc/compat13x/pkg-descr
new file mode 100644
index 000000000000..f79575bd620a
--- /dev/null
+++ b/misc/compat13x/pkg-descr
@@ -0,0 +1,12 @@
+This package allows you to install the compat13x libraries on your
+system, so you can use legacy binaries that depend on them.
+
+Ports usage example:
+
+--
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 1400000
+LIB_DEPENDS+= libcrypto.so.111:misc/compat13x
+.endif
+--
diff --git a/misc/compat13x/pkg-plist.amd64 b/misc/compat13x/pkg-plist.amd64
new file mode 100644
index 000000000000..b59314439668
--- /dev/null
+++ b/misc/compat13x/pkg-plist.amd64
@@ -0,0 +1,4 @@
+lib/compat/libcrypto.so.111
+lib/compat/libssl.so.111
+lib32/compat/libcrypto.so.111
+lib32/compat/libssl.so.111
diff --git a/misc/compat13x/pkg-plist.i386 b/misc/compat13x/pkg-plist.i386
new file mode 100644
index 000000000000..2ef438e3b03a
--- /dev/null
+++ b/misc/compat13x/pkg-plist.i386
@@ -0,0 +1,2 @@
+lib/compat/libcrypto.so.111
+lib/compat/libssl.so.111