aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2024-05-20 11:53:50 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2024-05-20 11:53:50 +0000
commit34153aff7b7d18bbadb0dea212388678c3da96c1 (patch)
tree8d2ea01659563438ad973208c60d53858ba13e20
parentdeb6cd5697508724131bb97eac0c87f83afc86db (diff)
downloadports-34153aff7b7d18bbadb0dea212388678c3da96c1.tar.gz
ports-34153aff7b7d18bbadb0dea212388678c3da96c1.zip
graphics/libgphoto2: the port had been updated to version 2.5.31
- Clean up USES list (no longer requires GNU make, etc.) - Do not set USE_CSTD, GNU_CONFIGURE_MANPREFIX, and particularly CONFIGURE_ENV which could break the build (doxygen-related) - Drop old patches and sed(1) fixup that are no longer needed PR: 277551 Reported by: portscout
-rw-r--r--graphics/libgphoto2/Makefile24
-rw-r--r--graphics/libgphoto2/distinfo6
-rw-r--r--graphics/libgphoto2/files/patch-camlibs_ax203_jpeg__memsrcdest.h16
-rw-r--r--graphics/libgphoto2/files/patch-camlibs_jl2005c_jpeg__memsrcdest.h16
-rw-r--r--graphics/libgphoto2/files/patch-libgphoto2_port-gphoto2-gphoto2-port-portability.h23
-rw-r--r--graphics/libgphoto2/pkg-plist6
6 files changed, 11 insertions, 80 deletions
diff --git a/graphics/libgphoto2/Makefile b/graphics/libgphoto2/Makefile
index 7a85ccd345c9..529ea779fd27 100644
--- a/graphics/libgphoto2/Makefile
+++ b/graphics/libgphoto2/Makefile
@@ -1,6 +1,5 @@
PORTNAME= libgphoto2
-PORTVERSION= 2.5.26
-PORTREVISION= 3
+PORTVERSION= 2.5.31
CATEGORIES= graphics
MASTER_SITES= SF/gphoto/libgphoto/${PORTVERSION}
@@ -13,19 +12,9 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libltdl.so:devel/libltdl
-USES= compiler:c11 gmake gnome iconv libtool localbase pathfix \
- pkgconfig tar:bzip2
-USE_CSTD= gnu99
+USES= gnome libtool pathfix pkgconfig tar:xz
USE_GNOME= libxml2
-
GNU_CONFIGURE= yes
-GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
-CONFIGURE_ENV= LTDLINCL="-I${LOCALBASE}/include" \
- LIBLTDL="-L${LOCALBASE}/lib -lltdl" \
- PATH="${PATH:C,${HOME}/bin,,}" \
- ac_cv_path_DOT=false \
- ac_cv_path_DOXYGEN=false \
- udevscriptdir=${WRKDIR}
INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
PATHFIX_MAKEFILEIN= Makefile.in \
@@ -33,7 +22,7 @@ PATHFIX_MAKEFILEIN= Makefile.in \
libgphoto2_port/Makefile.in \
libgphoto2_port/configure
-PLIST_SUB= VERSION="${PORTVERSION}" VERSION_PORT=0.12.0
+PLIST_SUB= VERSION=${PORTVERSION} VERSION_PORT=0.12.2
OPTIONS_DEFINE= CURL DOCS GD JPEG LIBEXIF NLS
OPTIONS_DEFAULT= CURL GD JPEG LIBEXIF
@@ -49,13 +38,13 @@ GD_CONFIGURE_OFF= --with-gdlib=no
JPEG_DESC= JPEG image mangling support
JPEG_USES= jpeg
-JPEG_CONFIGURE_WITH= jpeg
+JPEG_CONFIGURE_OFF= --without-jpeg
LIBEXIF_LIB_DEPENDS= libexif.so:graphics/libexif
LIBEXIF_CONFIGURE_OFF= --with-libexif=no
NLS_USES= gettext
-NLS_CONFIGURE_ENABLE= nls
+NLS_CONFIGURE_OFF= --disable-nls
post-patch:
.for i in configure libgphoto2_port/configure
@@ -67,8 +56,5 @@ post-patch:
@${REINPLACE_CMD} -e \
'/^doc_DATA/s|COPYING||' \
${WRKSRC}/Makefile.in
- @${REINPLACE_CMD} -e \
- '/^SUBDIRS/s|linux-hotplug||' \
- ${WRKSRC}/packaging/Makefile.in
.include <bsd.port.mk>
diff --git a/graphics/libgphoto2/distinfo b/graphics/libgphoto2/distinfo
index db4b3349e98b..1569720f4dbc 100644
--- a/graphics/libgphoto2/distinfo
+++ b/graphics/libgphoto2/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1611463219
-SHA256 (libgphoto2-2.5.26.tar.bz2) = 7740fea3cbb78489071cdfec06c07fab528e69e27ac82734eae6a73eaeeabcd4
-SIZE (libgphoto2-2.5.26.tar.bz2) = 7572381
+TIMESTAMP = 1693647231
+SHA256 (libgphoto2-2.5.31.tar.xz) = 8fc7bf40f979459509b87dd4ff1aae9b6c1c2b4724d37db576081eec15406ace
+SIZE (libgphoto2-2.5.31.tar.xz) = 6322264
diff --git a/graphics/libgphoto2/files/patch-camlibs_ax203_jpeg__memsrcdest.h b/graphics/libgphoto2/files/patch-camlibs_ax203_jpeg__memsrcdest.h
deleted file mode 100644
index f38bc4cd5012..000000000000
--- a/graphics/libgphoto2/files/patch-camlibs_ax203_jpeg__memsrcdest.h
+++ /dev/null
@@ -1,16 +0,0 @@
---- camlibs/ax203/jpeg_memsrcdest.h.orig 2015-08-08 15:57:29 UTC
-+++ camlibs/ax203/jpeg_memsrcdest.h
-@@ -1,5 +1,7 @@
- #include <jpeglib.h>
-
-+#if JPEG_LIB_VERSION < 80
-+
- void
- jpeg_mem_src (j_decompress_ptr cinfo, unsigned char * buffer,
- unsigned long bufsize);
-@@ -7,3 +9,5 @@ jpeg_mem_src (j_decompress_ptr cinfo, un
- void
- jpeg_mem_dest (j_compress_ptr cinfo, unsigned char ** outbuffer,
- unsigned long * outsize);
-+
-+#endif
diff --git a/graphics/libgphoto2/files/patch-camlibs_jl2005c_jpeg__memsrcdest.h b/graphics/libgphoto2/files/patch-camlibs_jl2005c_jpeg__memsrcdest.h
deleted file mode 100644
index a439119fbb33..000000000000
--- a/graphics/libgphoto2/files/patch-camlibs_jl2005c_jpeg__memsrcdest.h
+++ /dev/null
@@ -1,16 +0,0 @@
---- camlibs/jl2005c/jpeg_memsrcdest.h.orig 2015-08-08 15:57:29 UTC
-+++ camlibs/jl2005c/jpeg_memsrcdest.h
-@@ -1,5 +1,7 @@
- #include <jpeglib.h>
-
-+#if JPEG_LIB_VERSION < 80
-+
- void
- jpeg_mem_src (j_decompress_ptr cinfo, unsigned char * buffer,
- unsigned long bufsize);
-@@ -7,3 +9,5 @@ jpeg_mem_src (j_decompress_ptr cinfo, un
- void
- jpeg_mem_dest (j_compress_ptr cinfo, unsigned char ** outbuffer,
- unsigned long * outsize);
-+
-+#endif
diff --git a/graphics/libgphoto2/files/patch-libgphoto2_port-gphoto2-gphoto2-port-portability.h b/graphics/libgphoto2/files/patch-libgphoto2_port-gphoto2-gphoto2-port-portability.h
deleted file mode 100644
index 87eae53991ac..000000000000
--- a/graphics/libgphoto2/files/patch-libgphoto2_port-gphoto2-gphoto2-port-portability.h
+++ /dev/null
@@ -1,23 +0,0 @@
---- libgphoto2_port/gphoto2/gphoto2-port-portability.h.orig 2014-06-27 05:26:01 UTC
-+++ libgphoto2_port/gphoto2/gphoto2-port-portability.h
-@@ -174,20 +174,6 @@ typedef struct {
-
- /* yummy. :) */
-
--/* XOPEN needed for usleep */
--#ifndef _XOPEN_SOURCE
--# define _XOPEN_SOURCE 500
--#else
--# if ((_XOPEN_SOURCE - 0) < 500)
--# undef _XOPEN_SOURCE
--# define _XOPEN_SOURCE 500
--# endif
--#endif
--
--/* for nanosleep */
--# ifndef _POSIX_C_SOURCE
--# define _POSIX_C_SOURCE 199309
--# endif
- # include <time.h>
-
- # include <strings.h>
diff --git a/graphics/libgphoto2/pkg-plist b/graphics/libgphoto2/pkg-plist
index c27b3fdc9d00..1be9c0ffe44f 100644
--- a/graphics/libgphoto2/pkg-plist
+++ b/graphics/libgphoto2/pkg-plist
@@ -20,7 +20,7 @@ include/gphoto2/gphoto2-widget.h
include/gphoto2/gphoto2.h
lib/libgphoto2.so
lib/libgphoto2.so.6
-lib/libgphoto2.so.6.1.0
+lib/libgphoto2.so.6.3.0
lib/libgphoto2/%%VERSION%%/ax203.so
lib/libgphoto2/%%VERSION%%/canon.so
lib/libgphoto2/%%VERSION%%/digigr8.so
@@ -44,7 +44,7 @@ lib/libgphoto2/%%VERSION%%/tp6801.so
lib/libgphoto2/print-camera-list
lib/libgphoto2_port.so
lib/libgphoto2_port.so.12
-lib/libgphoto2_port.so.12.0.0
+lib/libgphoto2_port.so.12.2.0
lib/libgphoto2_port/%%VERSION_PORT%%/disk.so
lib/libgphoto2_port/%%VERSION_PORT%%/ptpip.so
lib/libgphoto2_port/%%VERSION_PORT%%/usb1.so
@@ -57,7 +57,6 @@ libdata/pkgconfig/libgphoto2_port.pc
%%PORTDOCS%%%%DOCSDIR%%/README.md
%%PORTDOCS%%%%DOCSDIR%%/README.packaging
%%PORTDOCS%%%%DOCSDIR%%/RELEASE-HOWTO.md
-%%PORTDOCS%%%%DOCSDIR%%/camlibs/ChangeLog
%%PORTDOCS%%%%DOCSDIR%%/camlibs/README.9050
%%PORTDOCS%%%%DOCSDIR%%/camlibs/README.9051
%%PORTDOCS%%%%DOCSDIR%%/camlibs/README.9052
@@ -134,6 +133,7 @@ libdata/pkgconfig/libgphoto2_port.pc
%%NLS%%share/locale/pl/LC_MESSAGES/libgphoto2-6.mo
%%NLS%%share/locale/pl/LC_MESSAGES/libgphoto2_port-12.mo
%%NLS%%share/locale/pt_BR/LC_MESSAGES/libgphoto2_port-12.mo
+%%NLS%%share/locale/ro/LC_MESSAGES/libgphoto2_port-12.mo
%%NLS%%share/locale/ru/LC_MESSAGES/libgphoto2-6.mo
%%NLS%%share/locale/ru/LC_MESSAGES/libgphoto2_port-12.mo
%%NLS%%share/locale/sk/LC_MESSAGES/libgphoto2_port-12.mo