aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-10-13 05:34:01 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-10-13 05:34:01 +0000
commit3468aa764fcc0e130851f5b04c29deb164d84d35 (patch)
tree4b47fa92854b9839b5a4e4cbff050a2c96c6b334
parentfc019f927c76edf3a78432c67c22dd188554e6c8 (diff)
downloadports-3468aa764fcc0e130851f5b04c29deb164d84d35.tar.gz
ports-3468aa764fcc0e130851f5b04c29deb164d84d35.zip
devel/rubygem-google-apis-compute_v1: Add rubygem-google-apis-compute_v1 0.17.0
This is a simple client library for version V1 of the Compute Engine API. It provides: - A client object that connects to the HTTP/JSON REST endpoint for the service. - Ruby objects for data structures related to the service. - Integration with the googleauth gem for authentication using OAuth, API keys, and service accounts. - Control of retry, pagination, and timeouts. WWW: https://github.com/googleapis/google-api-ruby-client WWW: https://github.com/googleapis/google-api-ruby-client/tree/master/generated/google-apis-compute_v1
-rw-r--r--devel/Makefile1
-rw-r--r--devel/rubygem-google-apis-compute_v1/Makefile21
-rw-r--r--devel/rubygem-google-apis-compute_v1/distinfo3
-rw-r--r--devel/rubygem-google-apis-compute_v1/pkg-descr10
4 files changed, 35 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index c2e9cfa73a5e..dccaacfbb27f 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -6336,6 +6336,7 @@
SUBDIR += rubygem-glib2
SUBDIR += rubygem-gobject-introspection
SUBDIR += rubygem-google-api-client
+ SUBDIR += rubygem-google-apis-compute_v1
SUBDIR += rubygem-google-apis-core
SUBDIR += rubygem-google-apis-discovery_v1
SUBDIR += rubygem-google-apis-generator
diff --git a/devel/rubygem-google-apis-compute_v1/Makefile b/devel/rubygem-google-apis-compute_v1/Makefile
new file mode 100644
index 000000000000..ccad8b8e8e6c
--- /dev/null
+++ b/devel/rubygem-google-apis-compute_v1/Makefile
@@ -0,0 +1,21 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+
+PORTNAME= google-apis-compute_v1
+PORTVERSION= 0.17.0
+CATEGORIES= devel rubygems
+MASTER_SITES= RG
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Simple REST client for Compute Engine API V1
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
+
+RUN_DEPENDS= rubygem-google-apis-core>=0.4<2.0:devel/rubygem-google-apis-core
+
+USES= gem
+USE_RUBY= yes
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-google-apis-compute_v1/distinfo b/devel/rubygem-google-apis-compute_v1/distinfo
new file mode 100644
index 000000000000..dd0f3edcb901
--- /dev/null
+++ b/devel/rubygem-google-apis-compute_v1/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1632773608
+SHA256 (rubygem/google-apis-compute_v1-0.17.0.gem) = aac52c457085d0cdf6c06db0bb202b721978c52c2904ddbfa41a83e4b7856369
+SIZE (rubygem/google-apis-compute_v1-0.17.0.gem) = 320000
diff --git a/devel/rubygem-google-apis-compute_v1/pkg-descr b/devel/rubygem-google-apis-compute_v1/pkg-descr
new file mode 100644
index 000000000000..ed512cc6e1c7
--- /dev/null
+++ b/devel/rubygem-google-apis-compute_v1/pkg-descr
@@ -0,0 +1,10 @@
+This is a simple client library for version V1 of the Compute Engine API. It
+provides:
+- A client object that connects to the HTTP/JSON REST endpoint for the service.
+- Ruby objects for data structures related to the service.
+- Integration with the googleauth gem for authentication using OAuth, API keys,
+ and service accounts.
+- Control of retry, pagination, and timeouts.
+
+WWW: https://github.com/googleapis/google-api-ruby-client
+WWW: https://github.com/googleapis/google-api-ruby-client/tree/master/generated/google-apis-compute_v1