aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2022-05-06 12:35:00 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2022-05-06 12:35:00 +0000
commit350359a03444205f8ee4972894ccc7d9346fca51 (patch)
tree1dbba21df39d3992ab8459e055f2a5937e0fa994
parentc57a29284c556431ff8d1e77feb17e1182ca109b (diff)
downloadports-350359a03444205f8ee4972894ccc7d9346fca51.tar.gz
ports-350359a03444205f8ee4972894ccc7d9346fca51.zip
devel/z88dk: unbreak the build when MALLOC_PRODUCTION is unset
In debug mode, malloc() writes some junk to newly allocated memory to help developers discover memory allocation bugs, which results in the subtle compilation errors for this port: gmake --no-print-directory -C stdio zcc +test -O2 -vn -c -c -o obj/_freopen1.o _freopen1.c _freopen1.c:19:36: error: Attempt to modify const lvalue 'mode' _freopen1.c:21:21: error: Attempt to modify const lvalue 'access' _freopen1.c:22:33: error: Attempt to modify const lvalue 'flags' _freopen1.c:25:38: error: Attempt to modify const lvalue 'access' _freopen1.c:26:33: error: Attempt to modify const lvalue 'flags' _freopen1.c:29:38: error: Attempt to modify const lvalue 'access' _freopen1.c:30:33: error: Attempt to modify const lvalue 'flags' _freopen1.c:37:15: error: Attempt to modify const lvalue 'mode' _freopen1.c:39:25: error: Attempt to modify const lvalue 'access' _freopen1.c:40:34: error: Attempt to modify const lvalue 'flags' Idea from: cy (commit 50324bba317c in x11/cde) Reported by: pkg-fallout
-rw-r--r--devel/z88dk/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/devel/z88dk/Makefile b/devel/z88dk/Makefile
index 1b4b16da0266..2a5706571b60 100644
--- a/devel/z88dk/Makefile
+++ b/devel/z88dk/Makefile
@@ -35,7 +35,7 @@ TEST_DEPENDS= dos2unix:converters/unix2dos \
USES= gmake gnome perl5 shebangfix tar:tgz
USE_GNOME= libxml2
USE_PERL5= run
-MAKE_ENV= ZCCCFG=${WRKSRC}/lib/config Q= # force verbose build
+MAKE_ENV= ZCCCFG=${WRKSRC}/lib/config Q= MALLOC_CONF=junk:false
SHEBANG_FILES= src/z80asm/asmpp.pl
TEST_TARGET= testsuite test
WRKSRC= ${WRKDIR}/${PORTNAME}