aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNuno Teixeira <eduardo@FreeBSD.org>2023-11-02 09:50:49 +0000
committerNuno Teixeira <eduardo@FreeBSD.org>2023-11-02 09:57:41 +0000
commit35260b97a5e8551b2e15e66a7f0c3360ef710343 (patch)
treecf635675acc07e86937333c1b7c8bb70fa996ac2
parent00672e3202b318def996cecdddc34116f5950df6 (diff)
downloadports-35260b97a5e8551b2e15e66a7f0c3360ef710343.tar.gz
ports-35260b97a5e8551b2e15e66a7f0c3360ef710343.zip
devel/gitui: Unbreak 32bit archs/Disable vendored-openssl
- Unbreak 32 bit archs: Apply sys-info-0.9.1 fix crate (mixing constant and variable width types) - Disable vendored-openssl - Move crates list to Makefile.crates PR: 267469 MFH: 2023Q4
-rw-r--r--devel/gitui/Makefile236
-rw-r--r--devel/gitui/Makefile.crates217
-rw-r--r--devel/gitui/distinfo4
-rw-r--r--devel/gitui/files/patch-Cargo.lock28
-rw-r--r--devel/gitui/files/patch-asyncgit_Cargo.toml13
5 files changed, 270 insertions, 228 deletions
diff --git a/devel/gitui/Makefile b/devel/gitui/Makefile
index 8430aaa9d6dd..561dbf4b3d70 100644
--- a/devel/gitui/Makefile
+++ b/devel/gitui/Makefile
@@ -1,7 +1,7 @@
PORTNAME= gitui
DISTVERSIONPREFIX= v
-DISTVERSION= 0.24.3
-PORTREVISION= 1
+DISTVERSION= 0.24.3 # After update, `make patch` and `make cargo-crates > Makefile.crates` to avoid fetching vendored openssl-src
+PORTREVISION= 2
CATEGORIES= devel
MAINTAINER= yuri@FreeBSD.org
@@ -11,244 +11,30 @@ WWW= https://github.com/extrawurst/gitui
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE.md
-BROKEN_armv7= error: conflicting types for 'get_proc_total', see https://github.com/FillZpp/sys-info-rs/issues/80
-BROKEN_i386= error: conflicting types for 'get_proc_total', see https://github.com/FillZpp/sys-info-rs/issues/80
-BROKEN_powerpc= error: conflicting types for 'get_proc_total', see https://github.com/FillZpp/sys-info-rs/issues/80
-
BUILD_DEPENDS= bash:shells/bash \
gmake:devel/gmake
LIB_DEPENDS= libgit2.so:devel/libgit2 \
libssh2.so:security/libssh2
-USES= cargo pkgconfig localbase:ldflags perl5 python:build xorg
+USES= cargo localbase:ldflags perl5 pkgconfig python:build ssl xorg
USE_XORG= xcb
USE_GITHUB= yes
GH_ACCOUNT= extrawurst
-CARGO_CRATES= addr2line-0.19.0 \
- adler-1.0.2 \
- aho-corasick-1.0.2 \
- android-tzdata-0.1.1 \
- android_system_properties-0.1.5 \
- anstream-0.5.0 \
- anstyle-1.0.2 \
- anstyle-parse-0.2.1 \
- anstyle-query-1.0.0 \
- anstyle-wincon-2.1.0 \
- anyhow-1.0.75 \
- autocfg-1.1.0 \
- backtrace-0.3.67 \
- base64-0.13.1 \
- bincode-1.3.3 \
- bit-set-0.5.3 \
- bit-vec-0.6.3 \
- bitflags-1.3.2 \
- bugreport-0.5.0 \
- bumpalo-3.12.0 \
- bwrap-1.3.0 \
- bytesize-1.3.0 \
- cassowary-0.3.0 \
- cc-1.0.79 \
- cfg-if-1.0.0 \
- chrono-0.4.30 \
- clap-4.4.2 \
- clap_builder-4.4.2 \
- clap_lex-0.5.1 \
- codespan-reporting-0.11.1 \
- colorchoice-1.0.0 \
- core-foundation-sys-0.8.3 \
- crc32fast-1.3.2 \
- crossbeam-channel-0.5.8 \
- crossbeam-deque-0.8.2 \
- crossbeam-epoch-0.9.13 \
- crossbeam-utils-0.8.14 \
- crossterm-0.26.1 \
- crossterm_winapi-0.9.0 \
- cxx-1.0.90 \
- cxx-build-1.0.90 \
- cxxbridge-flags-1.0.90 \
- cxxbridge-macro-1.0.90 \
- dashmap-5.4.0 \
- diff-0.1.13 \
- dirs-5.0.1 \
- dirs-sys-0.4.1 \
- easy-cast-0.5.2 \
- either-1.8.1 \
- env_logger-0.10.0 \
- errno-0.2.8 \
- errno-dragonfly-0.1.2 \
- fancy-regex-0.11.0 \
- fastrand-1.9.0 \
- filetime-0.2.20 \
- flate2-1.0.25 \
- fnv-1.0.7 \
- form_urlencoded-1.2.0 \
- fsevent-sys-4.1.0 \
- futures-0.3.26 \
- futures-channel-0.3.26 \
- futures-core-0.3.26 \
- futures-executor-0.3.26 \
- futures-io-0.3.26 \
- futures-sink-0.3.26 \
- futures-task-0.3.26 \
- futures-util-0.3.26 \
- fuzzy-matcher-0.3.7 \
- getrandom-0.2.8 \
- gh-emoji-1.0.7 \
- gimli-0.27.3 \
- git-version-0.3.5 \
- git-version-macro-0.3.5 \
- git2-0.17.2 \
- hashbrown-0.12.3 \
- hermit-abi-0.3.2 \
- humantime-2.1.0 \
- iana-time-zone-0.1.53 \
- iana-time-zone-haiku-0.1.1 \
- idna-0.4.0 \
- indexmap-1.9.3 \
- inotify-0.9.6 \
- inotify-sys-0.1.5 \
- instant-0.1.12 \
- io-lifetimes-1.0.5 \
- is-terminal-0.4.3 \
- itertools-0.11.0 \
- itoa-1.0.8 \
- jobserver-0.1.25 \
- js-sys-0.3.61 \
- kqueue-1.0.7 \
- kqueue-sys-1.0.3 \
- lazy_static-1.4.0 \
- libc-0.2.139 \
- libgit2-sys-0.15.2+1.6.4 \
- libssh2-sys-0.3.0 \
- libz-sys-1.1.8 \
- link-cplusplus-1.0.8 \
- linux-raw-sys-0.1.4 \
- lock_api-0.4.10 \
- log-0.4.20 \
- memchr-2.5.0 \
- memoffset-0.7.1 \
- miniz_oxide-0.6.2 \
- mio-0.8.5 \
- notify-5.2.0 \
- notify-debouncer-mini-0.2.1 \
- num-traits-0.2.15 \
- num_cpus-1.16.0 \
- object-0.30.3 \
- once_cell-1.18.0 \
- onig-6.4.0 \
- onig_sys-69.8.1 \
- openssl-probe-0.1.5 \
- openssl-src-300.1.3+3.1.2 \
- openssl-sys-0.9.93 \
- option-ext-0.2.0 \
- parking_lot-0.12.1 \
- parking_lot_core-0.9.7 \
- percent-encoding-2.3.0 \
- phf-0.11.1 \
- phf_shared-0.11.1 \
- pin-project-lite-0.2.9 \
- pin-utils-0.1.0 \
- pkg-config-0.3.26 \
- pretty_assertions-1.4.0 \
- proc-macro-error-1.0.4 \
- proc-macro-error-attr-1.0.4 \
- proc-macro-hack-0.5.20+deprecated \
- proc-macro2-1.0.63 \
- quote-1.0.29 \
- ratatui-0.21.0 \
- rayon-1.7.0 \
- rayon-core-1.11.0 \
- redox_syscall-0.2.16 \
- redox_users-0.4.3 \
- regex-1.9.1 \
- regex-automata-0.3.4 \
- regex-syntax-0.7.4 \
- ron-0.8.0 \
- rustc-demangle-0.1.21 \
- rustix-0.36.8 \
- ryu-1.0.14 \
- same-file-1.0.6 \
- scopeguard-1.2.0 \
- scratch-1.0.3 \
- serde-1.0.156 \
- serde_derive-1.0.156 \
- serde_json-1.0.93 \
- serial_test-1.0.0 \
- serial_test_derive-1.0.0 \
- shell-escape-0.1.5 \
- shellexpand-3.1.0 \
- signal-hook-0.3.15 \
- signal-hook-mio-0.2.3 \
- signal-hook-registry-1.4.1 \
- simplelog-0.12.1 \
- siphasher-0.3.10 \
- slab-0.4.8 \
- smallvec-1.11.0 \
- strsim-0.10.0 \
- struct-patch-0.2.3 \
- struct-patch-derive-0.2.3 \
- syn-1.0.107 \
- syntect-5.1.0 \
- sys-info-0.9.1 \
- tempfile-3.4.0 \
- termcolor-1.2.0 \
- thiserror-1.0.39 \
- thiserror-impl-1.0.39 \
- thread_local-1.1.7 \
- time-0.3.22 \
- time-core-0.1.1 \
- time-macros-0.2.9 \
- tinyvec-1.6.0 \
- tinyvec_macros-0.1.1 \
- unicode-bidi-0.3.10 \
- unicode-ident-1.0.6 \
- unicode-normalization-0.1.22 \
- unicode-segmentation-1.10.1 \
- unicode-truncate-0.2.0 \
- unicode-width-0.1.10 \
- url-2.4.1 \
- utf8parse-0.2.1 \
- vcpkg-0.2.15 \
- version_check-0.9.4 \
- walkdir-2.3.3 \
- wasi-0.11.0+wasi-snapshot-preview1 \
- wasm-bindgen-0.2.84 \
- wasm-bindgen-backend-0.2.84 \
- wasm-bindgen-macro-0.2.84 \
- wasm-bindgen-macro-support-0.2.84 \
- wasm-bindgen-shared-0.2.84 \
- which-4.4.0 \
- winapi-0.3.9 \
- winapi-i686-pc-windows-gnu-0.4.0 \
- winapi-util-0.1.5 \
- winapi-x86_64-pc-windows-gnu-0.4.0 \
- windows-sys-0.42.0 \
- windows-sys-0.45.0 \
- windows-sys-0.48.0 \
- windows-targets-0.42.1 \
- windows-targets-0.48.1 \
- windows_aarch64_gnullvm-0.42.1 \
- windows_aarch64_gnullvm-0.48.0 \
- windows_aarch64_msvc-0.42.1 \
- windows_aarch64_msvc-0.48.0 \
- windows_i686_gnu-0.42.1 \
- windows_i686_gnu-0.48.0 \
- windows_i686_msvc-0.42.1 \
- windows_i686_msvc-0.48.0 \
- windows_x86_64_gnu-0.42.1 \
- windows_x86_64_gnu-0.48.0 \
- windows_x86_64_gnullvm-0.42.1 \
- windows_x86_64_gnullvm-0.48.0 \
- windows_x86_64_msvc-0.42.1 \
- windows_x86_64_msvc-0.48.0 \
- yansi-0.5.1
RUSTFLAGS+= --cap-lints=warn
PLIST_FILES= bin/${PORTNAME}
BINARY_ALIAS= python3=${PYTHON_CMD} # xcb requires python3
+# Fix build on armv7, i386 and powerpc
+# sys-info-0.9.1 crate issue: https://github.com/FillZpp/sys-info-rs/issues/80
+post-patch:
+ @${REINPLACE_CMD} \
+ -e '/get_cpu/s|unsigned long|uint64_t|' \
+ -e '/get_proc_total/s|unsigned long|uint64_t|' \
+ ${WRKSRC}/cargo-crates/sys-info-0.9.1/c/*.[ch]
+
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
diff --git a/devel/gitui/Makefile.crates b/devel/gitui/Makefile.crates
new file mode 100644
index 000000000000..307e9175b8d4
--- /dev/null
+++ b/devel/gitui/Makefile.crates
@@ -0,0 +1,217 @@
+CARGO_CRATES= addr2line-0.19.0 \
+ adler-1.0.2 \
+ aho-corasick-1.0.2 \
+ android-tzdata-0.1.1 \
+ android_system_properties-0.1.5 \
+ anstream-0.5.0 \
+ anstyle-1.0.2 \
+ anstyle-parse-0.2.1 \
+ anstyle-query-1.0.0 \
+ anstyle-wincon-2.1.0 \
+ anyhow-1.0.75 \
+ autocfg-1.1.0 \
+ backtrace-0.3.67 \
+ base64-0.13.1 \
+ bincode-1.3.3 \
+ bit-set-0.5.3 \
+ bit-vec-0.6.3 \
+ bitflags-1.3.2 \
+ bugreport-0.5.0 \
+ bumpalo-3.12.0 \
+ bwrap-1.3.0 \
+ bytesize-1.3.0 \
+ cassowary-0.3.0 \
+ cc-1.0.79 \
+ cfg-if-1.0.0 \
+ chrono-0.4.30 \
+ clap-4.4.2 \
+ clap_builder-4.4.2 \
+ clap_lex-0.5.1 \
+ codespan-reporting-0.11.1 \
+ colorchoice-1.0.0 \
+ core-foundation-sys-0.8.3 \
+ crc32fast-1.3.2 \
+ crossbeam-channel-0.5.8 \
+ crossbeam-deque-0.8.2 \
+ crossbeam-epoch-0.9.13 \
+ crossbeam-utils-0.8.14 \
+ crossterm-0.26.1 \
+ crossterm_winapi-0.9.0 \
+ cxx-1.0.90 \
+ cxx-build-1.0.90 \
+ cxxbridge-flags-1.0.90 \
+ cxxbridge-macro-1.0.90 \
+ dashmap-5.4.0 \
+ diff-0.1.13 \
+ dirs-5.0.1 \
+ dirs-sys-0.4.1 \
+ easy-cast-0.5.2 \
+ either-1.8.1 \
+ env_logger-0.10.0 \
+ errno-0.2.8 \
+ errno-dragonfly-0.1.2 \
+ fancy-regex-0.11.0 \
+ fastrand-1.9.0 \
+ filetime-0.2.20 \
+ flate2-1.0.25 \
+ fnv-1.0.7 \
+ form_urlencoded-1.2.0 \
+ fsevent-sys-4.1.0 \
+ futures-0.3.26 \
+ futures-channel-0.3.26 \
+ futures-core-0.3.26 \
+ futures-executor-0.3.26 \
+ futures-io-0.3.26 \
+ futures-sink-0.3.26 \
+ futures-task-0.3.26 \
+ futures-util-0.3.26 \
+ fuzzy-matcher-0.3.7 \
+ getrandom-0.2.8 \
+ gh-emoji-1.0.7 \
+ gimli-0.27.3 \
+ git-version-0.3.5 \
+ git-version-macro-0.3.5 \
+ git2-0.17.2 \
+ hashbrown-0.12.3 \
+ hermit-abi-0.3.2 \
+ humantime-2.1.0 \
+ iana-time-zone-0.1.53 \
+ iana-time-zone-haiku-0.1.1 \
+ idna-0.4.0 \
+ indexmap-1.9.3 \
+ inotify-0.9.6 \
+ inotify-sys-0.1.5 \
+ instant-0.1.12 \
+ io-lifetimes-1.0.5 \
+ is-terminal-0.4.3 \
+ itertools-0.11.0 \
+ itoa-1.0.8 \
+ jobserver-0.1.25 \
+ js-sys-0.3.61 \
+ kqueue-1.0.7 \
+ kqueue-sys-1.0.3 \
+ lazy_static-1.4.0 \
+ libc-0.2.139 \
+ libgit2-sys-0.15.2+1.6.4 \
+ libssh2-sys-0.3.0 \
+ libz-sys-1.1.8 \
+ link-cplusplus-1.0.8 \
+ linux-raw-sys-0.1.4 \
+ lock_api-0.4.10 \
+ log-0.4.20 \
+ memchr-2.5.0 \
+ memoffset-0.7.1 \
+ miniz_oxide-0.6.2 \
+ mio-0.8.5 \
+ notify-5.2.0 \
+ notify-debouncer-mini-0.2.1 \
+ num-traits-0.2.15 \
+ num_cpus-1.16.0 \
+ object-0.30.3 \
+ once_cell-1.18.0 \
+ onig-6.4.0 \
+ onig_sys-69.8.1 \
+ openssl-probe-0.1.5 \
+ openssl-sys-0.9.93 \
+ option-ext-0.2.0 \
+ parking_lot-0.12.1 \
+ parking_lot_core-0.9.7 \
+ percent-encoding-2.3.0 \
+ phf-0.11.1 \
+ phf_shared-0.11.1 \
+ pin-project-lite-0.2.9 \
+ pin-utils-0.1.0 \
+ pkg-config-0.3.26 \
+ pretty_assertions-1.4.0 \
+ proc-macro-error-1.0.4 \
+ proc-macro-error-attr-1.0.4 \
+ proc-macro-hack-0.5.20+deprecated \
+ proc-macro2-1.0.63 \
+ quote-1.0.29 \
+ ratatui-0.21.0 \
+ rayon-1.7.0 \
+ rayon-core-1.11.0 \
+ redox_syscall-0.2.16 \
+ redox_users-0.4.3 \
+ regex-1.9.1 \
+ regex-automata-0.3.4 \
+ regex-syntax-0.7.4 \
+ ron-0.8.0 \
+ rustc-demangle-0.1.21 \
+ rustix-0.36.8 \
+ ryu-1.0.14 \
+ same-file-1.0.6 \
+ scopeguard-1.2.0 \
+ scratch-1.0.3 \
+ serde-1.0.156 \
+ serde_derive-1.0.156 \
+ serde_json-1.0.93 \
+ serial_test-1.0.0 \
+ serial_test_derive-1.0.0 \
+ shell-escape-0.1.5 \
+ shellexpand-3.1.0 \
+ signal-hook-0.3.15 \
+ signal-hook-mio-0.2.3 \
+ signal-hook-registry-1.4.1 \
+ simplelog-0.12.1 \
+ siphasher-0.3.10 \
+ slab-0.4.8 \
+ smallvec-1.11.0 \
+ strsim-0.10.0 \
+ struct-patch-0.2.3 \
+ struct-patch-derive-0.2.3 \
+ syn-1.0.107 \
+ syntect-5.1.0 \
+ sys-info-0.9.1 \
+ tempfile-3.4.0 \
+ termcolor-1.2.0 \
+ thiserror-1.0.39 \
+ thiserror-impl-1.0.39 \
+ thread_local-1.1.7 \
+ time-0.3.22 \
+ time-core-0.1.1 \
+ time-macros-0.2.9 \
+ tinyvec-1.6.0 \
+ tinyvec_macros-0.1.1 \
+ unicode-bidi-0.3.10 \
+ unicode-ident-1.0.6 \
+ unicode-normalization-0.1.22 \
+ unicode-segmentation-1.10.1 \
+ unicode-truncate-0.2.0 \
+ unicode-width-0.1.10 \
+ url-2.4.1 \
+ utf8parse-0.2.1 \
+ vcpkg-0.2.15 \
+ version_check-0.9.4 \
+ walkdir-2.3.3 \
+ wasi-0.11.0+wasi-snapshot-preview1 \
+ wasm-bindgen-0.2.84 \
+ wasm-bindgen-backend-0.2.84 \
+ wasm-bindgen-macro-0.2.84 \
+ wasm-bindgen-macro-support-0.2.84 \
+ wasm-bindgen-shared-0.2.84 \
+ which-4.4.0 \
+ winapi-0.3.9 \
+ winapi-i686-pc-windows-gnu-0.4.0 \
+ winapi-util-0.1.5 \
+ winapi-x86_64-pc-windows-gnu-0.4.0 \
+ windows-sys-0.42.0 \
+ windows-sys-0.45.0 \
+ windows-sys-0.48.0 \
+ windows-targets-0.42.1 \
+ windows-targets-0.48.1 \
+ windows_aarch64_gnullvm-0.42.1 \
+ windows_aarch64_gnullvm-0.48.0 \
+ windows_aarch64_msvc-0.42.1 \
+ windows_aarch64_msvc-0.48.0 \
+ windows_i686_gnu-0.42.1 \
+ windows_i686_gnu-0.48.0 \
+ windows_i686_msvc-0.42.1 \
+ windows_i686_msvc-0.48.0 \
+ windows_x86_64_gnu-0.42.1 \
+ windows_x86_64_gnu-0.48.0 \
+ windows_x86_64_gnullvm-0.42.1 \
+ windows_x86_64_gnullvm-0.48.0 \
+ windows_x86_64_msvc-0.42.1 \
+ windows_x86_64_msvc-0.48.0 \
+ yansi-0.5.1
diff --git a/devel/gitui/distinfo b/devel/gitui/distinfo
index af9cf9841588..a8b4c9d7b2de 100644
--- a/devel/gitui/distinfo
+++ b/devel/gitui/distinfo
@@ -1,4 +1,4 @@
-TIMESTAMP = 1694319114
+TIMESTAMP = 1698870993
SHA256 (rust/crates/addr2line-0.19.0.crate) = a76fd60b23679b7d19bd066031410fb7e458ccc5e958eb5c325888ce4baedc97
SIZE (rust/crates/addr2line-0.19.0.crate) = 33210
SHA256 (rust/crates/adler-1.0.2.crate) = f26201604c87b1e01bd3d98f8d5d9a8fcbb815e8cedb41ffccbeb4bf593a35fe
@@ -227,8 +227,6 @@ SHA256 (rust/crates/onig_sys-69.8.1.crate) = 7b829e3d7e9cc74c7e315ee8edb185bf419
SIZE (rust/crates/onig_sys-69.8.1.crate) = 638216
SHA256 (rust/crates/openssl-probe-0.1.5.crate) = ff011a302c396a5197692431fc1948019154afc178baf7d8e37367442a4601cf
SIZE (rust/crates/openssl-probe-0.1.5.crate) = 7227
-SHA256 (rust/crates/openssl-src-300.1.3+3.1.2.crate) = cd2c101a165fff9935e34def4669595ab1c7847943c42be86e21503e482be107
-SIZE (rust/crates/openssl-src-300.1.3+3.1.2.crate) = 8823710
SHA256 (rust/crates/openssl-sys-0.9.93.crate) = db4d56a4c0478783083cfafcc42493dd4a981d41669da64b4572a2a089b51b1d
SIZE (rust/crates/openssl-sys-0.9.93.crate) = 66922
SHA256 (rust/crates/option-ext-0.2.0.crate) = 04744f49eae99ab78e0d5c0b603ab218f515ea8cfe5a456d7629ad883a3b6e7d
diff --git a/devel/gitui/files/patch-Cargo.lock b/devel/gitui/files/patch-Cargo.lock
new file mode 100644
index 000000000000..3003c2017a17
--- /dev/null
+++ b/devel/gitui/files/patch-Cargo.lock
@@ -0,0 +1,28 @@
+Remove vendored openssl-src
+
+--- Cargo.lock.orig 2023-11-01 20:34:52 UTC
++++ Cargo.lock
+@@ -1147,15 +1147,6 @@ checksum = "ff011a302c396a5197692431fc1948019154afc178
+ checksum = "ff011a302c396a5197692431fc1948019154afc178baf7d8e37367442a4601cf"
+
+ [[package]]
+-name = "openssl-src"
+-version = "300.1.3+3.1.2"
+-source = "registry+https://github.com/rust-lang/crates.io-index"
+-checksum = "cd2c101a165fff9935e34def4669595ab1c7847943c42be86e21503e482be107"
+-dependencies = [
+- "cc",
+-]
+-
+-[[package]]
+ name = "openssl-sys"
+ version = "0.9.93"
+ source = "registry+https://github.com/rust-lang/crates.io-index"
+@@ -1163,7 +1154,6 @@ dependencies = [
+ dependencies = [
+ "cc",
+ "libc",
+- "openssl-src",
+ "pkg-config",
+ "vcpkg",
+ ]
diff --git a/devel/gitui/files/patch-asyncgit_Cargo.toml b/devel/gitui/files/patch-asyncgit_Cargo.toml
new file mode 100644
index 000000000000..2c07ec24cf9c
--- /dev/null
+++ b/devel/gitui/files/patch-asyncgit_Cargo.toml
@@ -0,0 +1,13 @@
+Do not use vendored openssl
+
+--- asyncgit/Cargo.toml.orig 2023-11-01 20:43:42 UTC
++++ asyncgit/Cargo.toml
+@@ -21,7 +21,7 @@ log = "0.4"
+ # git2 = { path = "../../extern/git2-rs", features = ["vendored-openssl"]}
+ # git2 = { git="https://github.com/extrawurst/git2-rs.git", rev="fc13dcc", features = ["vendored-openssl"]}
+ # pinning to vendored openssl, using the git2 feature this gets lost with new resolver
+-openssl-sys = { version = '0.9', features = ["vendored"], optional = true }
++openssl-sys = { version = '0.9', optional = true }
+ rayon = "1.7"
+ rayon-core = "1.11"
+ scopetime = { path = "../scopetime", version = "0.1" }