aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorgeorg lastname <georg.lastname@web.de>2021-07-18 14:19:11 +0000
committerNuno Teixeira <eduardo@FreeBSD.org>2021-07-18 14:22:35 +0000
commit35345a43885aea9d60ab0e65ee33274af382a689 (patch)
tree0ad267649db13e2fc4b7783f92f182c4fce19747
parent0b6fb0695f0ac655fd7636d1be60802edfc8555e (diff)
downloadports-35345a43885aea9d60ab0e65ee33274af382a689.tar.gz
ports-35345a43885aea9d60ab0e65ee33274af382a689.zip
sysutils/brut: New port
GUI for various admin tasks Graphical user interface (GUI) for various administrative tasks: - partition editor, disk editor - user/group management - date, time, timezone - and more. Some desktop users might find this port helpful. It uses gtk3 for the GUI elements. It has a sudo backend. WWW: https://github.com/random532/brut PR: 251373
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/brut/Makefile39
-rw-r--r--sysutils/brut/distinfo3
-rw-r--r--sysutils/brut/pkg-descr8
-rw-r--r--sysutils/brut/pkg-message8
5 files changed, 59 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index dcb1339ff931..3af247267be8 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -126,6 +126,7 @@
SUBDIR += bpytop
SUBDIR += brasero
SUBDIR += brename
+ SUBDIR += brut
SUBDIR += bsd-splash-changer
SUBDIR += bsdconfig
SUBDIR += bsdcrashtar
diff --git a/sysutils/brut/Makefile b/sysutils/brut/Makefile
new file mode 100644
index 000000000000..838ba519ff76
--- /dev/null
+++ b/sysutils/brut/Makefile
@@ -0,0 +1,39 @@
+PORTNAME= brut
+DISTVERSION= 1.55
+CATEGORIES= sysutils
+
+MAINTAINER= georg.lastname@web.de
+COMMENT= Multitool, Partition Editor, Manage User/Groups
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= sudo>0:security/sudo
+
+USES= gnome
+USE_GITHUB= yes
+GH_ACCOUNT= random532
+USE_GNOME= gtk30
+
+PLIST_FILES= bin/brut
+
+PORTDOCS= README.md
+PORTEXAMPLES= screenshot/*.png
+
+OPTIONS_DEFINE= DOCS EXAMPLES
+
+EXAMPLES_PLIST_FILES= ${EXAMPLESDIR}/scrot20.png \
+ ${EXAMPLESDIR}/scrot21.png
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${STAGEDIR}${DOCSDIR}
+
+do-install-EXAMPLES-on:
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTEXAMPLES} ${STAGEDIR}${EXAMPLESDIR}
+
+.include <bsd.port.mk>
diff --git a/sysutils/brut/distinfo b/sysutils/brut/distinfo
new file mode 100644
index 000000000000..a33c52b49eb3
--- /dev/null
+++ b/sysutils/brut/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1626092404
+SHA256 (random532-brut-1.55_GH0.tar.gz) = 1ffd0e405c39bbed4dddfbf5902315d8fba17857452f51ba2de8b1d583cd6f70
+SIZE (random532-brut-1.55_GH0.tar.gz) = 104338
diff --git a/sysutils/brut/pkg-descr b/sysutils/brut/pkg-descr
new file mode 100644
index 000000000000..b6680aecb8a6
--- /dev/null
+++ b/sysutils/brut/pkg-descr
@@ -0,0 +1,8 @@
+Graphical user interface (GUI) for various administrative tasks.
+
+Features:
+- partition editor, disk editor
+- group/user management
+- date, time, timezone
+
+WWW: https://github.com/random532/brut
diff --git a/sysutils/brut/pkg-message b/sysutils/brut/pkg-message
new file mode 100644
index 000000000000..052c779ffc3c
--- /dev/null
+++ b/sysutils/brut/pkg-message
@@ -0,0 +1,8 @@
+[
+{ type: install
+ message: <<EOM
+- Sudo is used as backend. The file ${PREFIX}/etc/sudoers handles its permissions.
+- If dbus complains about a missing machine-id, run "dbus-uuidgen --ensure".
+EOM
+}
+]