aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2024-06-08 12:55:18 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2024-06-08 12:56:11 +0000
commit354276d399bec77592634e058d591cf5afffbbce (patch)
tree48081e3940a8c609aefdafd6687bf611790185fd
parent7b5af3671ab16bfb3de386a2fffc47d6596c3a5a (diff)
downloadports-354276d399bec77592634e058d591cf5afffbbce.tar.gz
ports-354276d399bec77592634e058d591cf5afffbbce.zip
devel/pecl-swoole: fix building, also remove obsolete options.
-rw-r--r--devel/pecl-swoole/Makefile7
1 files changed, 2 insertions, 5 deletions
diff --git a/devel/pecl-swoole/Makefile b/devel/pecl-swoole/Makefile
index df1cdd747db7..368f64b54491 100644
--- a/devel/pecl-swoole/Makefile
+++ b/devel/pecl-swoole/Makefile
@@ -16,23 +16,20 @@ USES= compiler:c11 localbase:ldflags php:build,pecl pkgconfig ssl
CONFIGURE_ARGS+= --enable-mysqlnd
-OPTIONS_DEFINE= BROTLI CARES CURL HTTP2 JSON PGSQL SOCKETS
+OPTIONS_DEFINE= BROTLI CARES CURL PGSQL SOCKETS
CARES_LIB_DEPENDS= libcares.so:dns/c-ares
CARES_CONFIGURE_ON= --enable-cares
-HTTP2_CONFIGURE_ON= --enable-http2 \
- --enable-openssl
SOCKETS_USE= PHP=sockets:build
SOCKETS_DESC= Use native php sockets extension
SOCKETS_CONFIGURE_ON= --enable-sockets
CURL_LIB_DEPENDS= libcurl.so:ftp/curl
CURL_CONFIGURE_ON= --enable-swoole-curl
CURL_USE= PHP=curl
-JSON_CONFIGURE_ON= --enable-swoole-json
-JSON_USES= php:build
PGSQL_CONFIGURE_ON= --enable-swoole-pgsql
PGSQL_USES= pgsql
PGSQL_USE= PHP=pdo:build
BROTLI_CONFIGURE_ON= --enable-brotli
+BROTLI_CONFIGURE_OFF= --disable-brotli
BROTLI_LIB_DEPENDS= libbrotlicommon.so:archivers/brotli
.include <bsd.port.mk>