aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-01-30 12:33:10 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-01-30 13:00:12 +0000
commit3563550bd334b8f28a7048efc20f4da8dcfa066f (patch)
tree1f42b4cf3a05d43a92e35938504ae7c7ecd5ac59
parent67f818b7a30c3edac8c2724839bcf9b3f96ebfb3 (diff)
downloadports-3563550bd334b8f28a7048efc20f4da8dcfa066f.tar.gz
ports-3563550bd334b8f28a7048efc20f4da8dcfa066f.zip
misc/py-alive-progress: Update to 3.0.0
- Update WWW - Add missing RUN_DEPENDS - Take maintainership Changes: https://github.com/rsalmei/alive-progress/blob/main/CHANGELOG.md
-rw-r--r--misc/py-alive-progress/Makefile12
-rw-r--r--misc/py-alive-progress/distinfo6
-rw-r--r--misc/py-alive-progress/files/patch-setup.py10
3 files changed, 21 insertions, 7 deletions
diff --git a/misc/py-alive-progress/Makefile b/misc/py-alive-progress/Makefile
index ff1e57e6d664..6b0a2c5100a7 100644
--- a/misc/py-alive-progress/Makefile
+++ b/misc/py-alive-progress/Makefile
@@ -1,18 +1,22 @@
PORTNAME= alive-progress
-DISTVERSION= 2.4.1
+DISTVERSION= 3.0.0
CATEGORIES= misc
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Enhanced Python Progress Bar
-WWW= https://pypi.org/project/alive-progress/
+WWW= https://github.com/rsalmei/alive-progress
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= python:3.2+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}about-time>=4.2.1:devel/py-about-time@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}grapheme>=0.6.0<0.6.0_99:textproc/py-grapheme@${PY_FLAVOR}
+
+USES= python:3.7+
USE_PYTHON= autoplist concurrent distutils
+
NO_ARCH= yes
.include <bsd.port.mk>
diff --git a/misc/py-alive-progress/distinfo b/misc/py-alive-progress/distinfo
index 4af300bb4b09..0b714559e7ac 100644
--- a/misc/py-alive-progress/distinfo
+++ b/misc/py-alive-progress/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1649479107
-SHA256 (alive-progress-2.4.1.tar.gz) = 089757c8197f27ad972ba27e1060f6db92368d83c736884e159034fd74865323
-SIZE (alive-progress-2.4.1.tar.gz) = 104725
+TIMESTAMP = 1674589964
+SHA256 (alive-progress-3.0.0.tar.gz) = 9c122a47162fea67918b656cf3687ef3d8a661b451114bb07f4409bc869309cc
+SIZE (alive-progress-3.0.0.tar.gz) = 101587
diff --git a/misc/py-alive-progress/files/patch-setup.py b/misc/py-alive-progress/files/patch-setup.py
new file mode 100644
index 000000000000..2c013587ef34
--- /dev/null
+++ b/misc/py-alive-progress/files/patch-setup.py
@@ -0,0 +1,10 @@
+--- setup.py.orig 2022-12-22 05:23:53 UTC
++++ setup.py
+@@ -55,7 +55,6 @@ setup(
+ 'multi-threaded REPL alive animated visual feedback simple live efficient monitor '
+ 'stats elapsed time throughput'.split(),
+ packages=find_packages(exclude=['tests*']),
+- data_files=[('', ['LICENSE'])],
+ python_requires='>=3.7, <4',
+ install_requires=['about_time==4.2.1', 'grapheme==0.6.0'],
+ )