aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNeel Chauhan <nc@FreeBSD.org>2021-10-11 21:13:38 +0000
committerNeel Chauhan <nc@FreeBSD.org>2021-10-11 21:13:46 +0000
commit3589351d03702d2fcf7892057f78635d6887acff (patch)
treee7a6251afd83a2fff4fec15dd32e790483aa2447
parent70dbc09675b7b9da3a4505e938bb8f74c1a5297e (diff)
downloadports-3589351d03702d2fcf7892057f78635d6887acff.tar.gz
ports-3589351d03702d2fcf7892057f78635d6887acff.zip
net-mgmt/sblim-wbemcli: Update to 1.6.3
-rw-r--r--net-mgmt/sblim-wbemcli/Makefile7
-rw-r--r--net-mgmt/sblim-wbemcli/distinfo5
-rw-r--r--net-mgmt/sblim-wbemcli/files/patch-CimCurl.cpp6
-rw-r--r--net-mgmt/sblim-wbemcli/files/patch-CimXml.h18
4 files changed, 11 insertions, 25 deletions
diff --git a/net-mgmt/sblim-wbemcli/Makefile b/net-mgmt/sblim-wbemcli/Makefile
index 7a0ada7161fe..e4d734019078 100644
--- a/net-mgmt/sblim-wbemcli/Makefile
+++ b/net-mgmt/sblim-wbemcli/Makefile
@@ -1,6 +1,5 @@
PORTNAME= sblim-wbemcli
-PORTVERSION= 1.6.1
-PORTREVISION= 5
+PORTVERSION= 1.6.3
CATEGORIES= net-mgmt
MASTER_SITES= SF/sblim/${PORTNAME}/${PORTVERSION}
@@ -10,10 +9,10 @@ COMMENT= CLI for Web Based Enterprise Management by SBLIM
BUILD_DEPENDS= libwww-config:www/libwww
LIB_DEPENDS= libcurl.so:ftp/curl
-USES= tar:bzip2
+USES= tar:bzip2
GNU_CONFIGURE= YES
+MAKE_ARGS= RM="${RM}"
CPPFLAGS+= -I${PREFIX}/include
LDFLAGS+= -L${PREFIX}/lib
-MAKE_ARGS= RM="${RM}"
.include <bsd.port.mk>
diff --git a/net-mgmt/sblim-wbemcli/distinfo b/net-mgmt/sblim-wbemcli/distinfo
index 71cdb338d9ef..601307ce5a6a 100644
--- a/net-mgmt/sblim-wbemcli/distinfo
+++ b/net-mgmt/sblim-wbemcli/distinfo
@@ -1,2 +1,3 @@
-SHA256 (sblim-wbemcli-1.6.1.tar.bz2) = 6d3b5d6ef2cd0b6fab282aabfdedf8d6a0b3e4a2743ddd7bb2def9e8cad71fac
-SIZE (sblim-wbemcli-1.6.1.tar.bz2) = 189383
+TIMESTAMP = 1633986312
+SHA256 (sblim-wbemcli-1.6.3.tar.bz2) = e493065a6a485ef19cdae5d2bb1561eb9aa4b3d53f35237f6c32cf101a93a796
+SIZE (sblim-wbemcli-1.6.3.tar.bz2) = 198866
diff --git a/net-mgmt/sblim-wbemcli/files/patch-CimCurl.cpp b/net-mgmt/sblim-wbemcli/files/patch-CimCurl.cpp
index 82a8b0f3a154..55546c85b97a 100644
--- a/net-mgmt/sblim-wbemcli/files/patch-CimCurl.cpp
+++ b/net-mgmt/sblim-wbemcli/files/patch-CimCurl.cpp
@@ -1,4 +1,4 @@
---- CimCurl.cpp.orig 2009-03-04 19:10:54.000000000 +0000
+--- CimCurl.cpp.orig 2013-09-20 23:26:32 UTC
+++ CimCurl.cpp
@@ -27,6 +27,7 @@
#include <string.h>
@@ -6,5 +6,5 @@
+#include <unistd.h>
#include "CimCurl.h"
-
- extern int useNl;
+ #include <unistd.h> // for getpass()
+ #include <cerrno>
diff --git a/net-mgmt/sblim-wbemcli/files/patch-CimXml.h b/net-mgmt/sblim-wbemcli/files/patch-CimXml.h
index 1d312c7488b8..734c69c437a5 100644
--- a/net-mgmt/sblim-wbemcli/files/patch-CimXml.h
+++ b/net-mgmt/sblim-wbemcli/files/patch-CimXml.h
@@ -1,6 +1,6 @@
---- CimXml.h.orig 2009-06-24 17:44:48.000000000 +0000
+--- CimXml.h.orig 2013-03-25 04:05:49 UTC
+++ CimXml.h
-@@ -54,7 +54,7 @@ class StringArray : public vector<string
+@@ -54,7 +54,7 @@ class StringArray : public vector<string> {
StringArray() : vector<string>() {}
StringArray(int n) : vector<string>(n) {}
StringArray(int n, const string& s) : vector<string>(n,s) {}
@@ -9,17 +9,3 @@
void toStringBuffer(string &sb, const char *sep=" ",const char *q="") {
for (size_type n=0; n<size(); n++) {
sb = sb + (*this).at(n) + q;
-@@ -129,10 +129,10 @@ template<class T> class ArrayXml : publi
- public:
- ArrayXml() {}
- ArrayXml<T> * clone() const { return new ArrayXml<T>(*this);}
-- void add(const T& t) { push_back(t); }
-+ void add(const T& t) { this->push_back(t); }
- #if !defined(GCC_VERSION) || GCC_VERSION >= 3000
-- T& operator[] (size_type n) {return at(n);}
-- const T& operator[] (size_type n) const {return at(n);}
-+ T& operator[] (size_type n) {return this->at(n);}
-+ const T& operator[] (size_type n) const {return this->at(n);}
- #endif
- T *get(int n) { return &(*this)[n]; }
- void toStringBuffer(string &sb, const char *sep=" ",const char *q="") {