aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-09-29 18:48:39 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-09-29 19:05:07 +0000
commit35c100fff530a6006bfd86ed0d77de47f8131b95 (patch)
tree01141a7b07ba7e66383d30efd15e8c41bf9dc58b
parentf5461d3a4c004737ccb6b17a6c5bd20bcb6edb93 (diff)
downloadports-35c100fff530a6006bfd86ed0d77de47f8131b95.tar.gz
ports-35c100fff530a6006bfd86ed0d77de47f8131b95.zip
editors/imhex: Remove CC/CPP/CXX exports
- USES=llvm now by default exports CC/CPP/CXX so remove those - Utilize USES=localbase Approved by: portmgr (blanket)
-rw-r--r--editors/imhex/Makefile8
1 files changed, 2 insertions, 6 deletions
diff --git a/editors/imhex/Makefile b/editors/imhex/Makefile
index dd72a64bc076..8074a2aed6e5 100644
--- a/editors/imhex/Makefile
+++ b/editors/imhex/Makefile
@@ -40,7 +40,7 @@ LIB_DEPENDS= libcurl.so:ftp/curl \
libmbedtls.so:security/mbedtls \
libtre.so:textproc/libtre
-USES= cmake desktop-file-utils gl gnome llvm:min=16,build pkgconfig python xorg
+USES= cmake desktop-file-utils gl gnome llvm:min=16,build localbase pkgconfig python xorg
USE_GL= gl glu
USE_GNOME= cairo gdkpixbuf2 gtk30
USE_XORG= x11 xcb xau xdmcp
@@ -70,11 +70,7 @@ GH_TAG_NATIVEFILEDIALOG= 7909f55
GH_TAG_PATTERN_LANGUAGE= 57dc02b
GH_TAG_YARA= 96790e5
-CC= ${LOCALBASE}/bin/clang16
-CXX= ${LOCALBASE}/bin/clang++16
-CFLAGS+= -I${LOCALBASE}/include
-CXXFLAGS+= -I${LOCALBASE}/include \
- -I${WRKSRC}/lib/external/pattern_language/generators/include \
+CXXFLAGS+= -I${WRKSRC}/lib/external/pattern_language/generators/include \
-Wno-error=deprecated-declarations \
-Wno-error=literal-conversion