aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-05 16:50:32 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-05 18:09:01 +0000
commit365553bf46d1d4de026b4fbe2ebff8628707b285 (patch)
treefd515ae5eeb1a56217815e6dcb42c9164550a790
parent47e6a6d4599e94a8bdce1c42a911e16dbbcb1122 (diff)
downloadports-365553bf46d1d4de026b4fbe2ebff8628707b285.tar.gz
ports-365553bf46d1d4de026b4fbe2ebff8628707b285.zip
graphics/py-ming: Fix build with llvm15
Approved by: portmgr (blanket)
-rw-r--r--graphics/py-ming/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/graphics/py-ming/Makefile b/graphics/py-ming/Makefile
index ea4c561726f3..9e7b634cca09 100644
--- a/graphics/py-ming/Makefile
+++ b/graphics/py-ming/Makefile
@@ -35,6 +35,12 @@ GH_PROJECT= libming
PORTSCOUT= limit:^ming-
+.include <bsd.port.pre.mk>
+
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400079 || ( ${OSVERSION} >= 1302505 && ${OSVERSION} < 1400000 ))
+CFLAGS+= -Wno-error=int-conversion
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's| --root ".*"||' ${WRKSRC}/py_ext/Makefile.am
@${REINPLACE_CMD} -e 's|/usr/local/|${LOCALBASE}/|g' ${WRKSRC}/py_ext/setup.py.in
@@ -43,4 +49,4 @@ post-patch:
post-install:
${FIND} ${STAGEDIR}${PYTHON_SITELIBDIR} -name '*.so' -exec ${STRIP_CMD} {} +
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>