aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-22 05:49:52 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-22 06:11:21 +0000
commit3692bdfb4769d7a43e02d88abe9b2bdbaa25f401 (patch)
tree1519fb7463f54ee912eeec62ed969e6c837bc5cc
parentca332d577a93486753d105971aa8358cda18c131 (diff)
downloadports-3692bdfb4769d7a43e02d88abe9b2bdbaa25f401.tar.gz
ports-3692bdfb4769d7a43e02d88abe9b2bdbaa25f401.zip
mail/vmailmgr: Fix build with llvm16
- Pet portclippy - OPTION PYTHONLIBS was defined while all post targets were based on PYTHONLIB. So simplify using OPTIONSNG with new OPTION named PYTHON and mark OPTION BROKEN as it fails to build with newer python. - Mark DEPRECATED as last upstream release was in 2005 and upstream points to a different site - Set EXPIRATION_DATE to 2023-08-22 Approved by: portmgr (blanket) Sponsored by: The FreeBSD Foundation
-rw-r--r--mail/vmailmgr/Makefile25
1 files changed, 12 insertions, 13 deletions
diff --git a/mail/vmailmgr/Makefile b/mail/vmailmgr/Makefile
index c7f0e45f9cdf..4ad5cf85a59c 100644
--- a/mail/vmailmgr/Makefile
+++ b/mail/vmailmgr/Makefile
@@ -10,29 +10,28 @@ WWW= http://www.vmailmgr.org
LICENSE= GPLv2+
+DEPRECATED= Last upstream release was in 2005 and upstream points to different site
+EXPIRATION_DATE= 2023-08-22
+
# get python paths (PYTHON_SITELIBDIR) in case we install the python API
USES= autoreconf gmake perl5 python
-GNU_CONFIGURE= yes
+USE_CXXSTD= c++14
USE_PERL5= build
+GNU_CONFIGURE= yes
+
+BINARY_ALIAS= python=${PYTHON_CMD}
+
PORTDOCS= AUTHORS ChangeLog NEWS README TODO
-OPTIONS_DEFINE= DOCS GDBM PYTHONLIBS
-PYTHONLIBS_DESC= Install the Python API
+OPTIONS_DEFINE= DOCS GDBM PYTHON
+OPTIONS_SUB= yes
GDBM_LIB_DEPENDS= libgdbm.so:databases/gdbm
GDBM_USES= localbase
GDBM_CONFIGURE_ON= --with-vpwtable=gdbm
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MPYTHONLIB}
-CONFIGURE_ARGS+= --with-pythonapi=${PYTHON_SITELIBDIR}
-PLIST_SUB+= PYTHON_SITELIBDIR="${PYTHON_SITELIBDIR}"
-PLIST_SUB+= PYTHON=""
-.else
-PLIST_SUB+= PYTHON="@comment "
-.endif
+PYTHON_BROKEN= Do not support recent python versions
+PYTHON_CONFIGURE_ON= --with-pythonapi=${PYTHON_SITELIBDIR}
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}