aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-02-21 14:13:55 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-02-21 15:06:13 +0000
commit3692fcde653ffcecbaefeb54ad3d2f00ac5c2aad (patch)
tree8f2e93d0cafd4c5fc920d44bd27f69c4d5555d89
parent789295878ab64b0fe93921ba8d4c4981d124f6b0 (diff)
downloadports-3692fcde653ffcecbaefeb54ad3d2f00ac5c2aad.tar.gz
ports-3692fcde653ffcecbaefeb54ad3d2f00ac5c2aad.zip
devel/rubygem-lrama: Add rubygem-lrama 0.6.0
Lrama is LALR (1) parser generator written by Ruby. The first goal of this project is providing error tolerant parser for CRuby with minimal changes on CRuby parse.y file. Features: - Bison style grammar file is supported with some assumptions - b4_locations_if is always true - b4_pure_if is always true - b4_pull_if is always false - b4_lac_if is always false - Error Tolerance parser - Subset of Repairing Syntax Errors in LR Parsers (Corchuelo et al.) algorithm is supported.
-rw-r--r--devel/Makefile1
-rw-r--r--devel/rubygem-lrama/Makefile20
-rw-r--r--devel/rubygem-lrama/distinfo3
-rw-r--r--devel/rubygem-lrama/pkg-descr13
4 files changed, 37 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 9fe103c578f6..d1ad8dffbf43 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -7125,6 +7125,7 @@
SUBDIR += rubygem-logging
SUBDIR += rubygem-logster
SUBDIR += rubygem-loquacious
+ SUBDIR += rubygem-lrama
SUBDIR += rubygem-lru_redux
SUBDIR += rubygem-lumberjack
SUBDIR += rubygem-main
diff --git a/devel/rubygem-lrama/Makefile b/devel/rubygem-lrama/Makefile
new file mode 100644
index 000000000000..5fd8c85e563f
--- /dev/null
+++ b/devel/rubygem-lrama/Makefile
@@ -0,0 +1,20 @@
+PORTNAME= lrama
+PORTVERSION= 0.6.0
+CATEGORIES= devel rubygems
+MASTER_SITES= RG
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= LALR (1) parser generator written by Ruby
+WWW= https://github.com/ruby/lrama
+
+LICENSE= GPLv3+ MIT
+LICENSE_COMB= multi
+LICENSE_FILE_MIT= ${WRKSRC}/MIT
+
+USES= gem
+
+NO_ARCH= yes
+
+PLIST_FILES= bin/lrama
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-lrama/distinfo b/devel/rubygem-lrama/distinfo
new file mode 100644
index 000000000000..269897bc1af9
--- /dev/null
+++ b/devel/rubygem-lrama/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1708448870
+SHA256 (rubygem/lrama-0.6.0.gem) = fb8a4580d70d94e737b6825ef16fbc4ab3654e9300858cc81974df73bb54ecba
+SIZE (rubygem/lrama-0.6.0.gem) = 81408
diff --git a/devel/rubygem-lrama/pkg-descr b/devel/rubygem-lrama/pkg-descr
new file mode 100644
index 000000000000..6a7ffb4fe1d2
--- /dev/null
+++ b/devel/rubygem-lrama/pkg-descr
@@ -0,0 +1,13 @@
+Lrama is LALR (1) parser generator written by Ruby. The first goal of this
+project is providing error tolerant parser for CRuby with minimal changes on
+CRuby parse.y file.
+
+Features:
+- Bison style grammar file is supported with some assumptions
+ - b4_locations_if is always true
+ - b4_pure_if is always true
+ - b4_pull_if is always false
+ - b4_lac_if is always false
+- Error Tolerance parser
+ - Subset of Repairing Syntax Errors in LR Parsers (Corchuelo et al.) algorithm
+ is supported.