aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDimitry Andric <dim@FreeBSD.org>2023-12-03 14:35:33 +0000
committerDimitry Andric <dim@FreeBSD.org>2023-12-03 14:40:25 +0000
commit37790b26cbda11cd4bb6f237b86cd94739c4059c (patch)
treed919c7bd3a2f4d9a4422b63bc27dfbb5f04dcae4
parente7ab92cc6d835887c3e7cdd4e593b512c0ee5c22 (diff)
downloadports-37790b26cbda11cd4bb6f237b86cd94739c4059c.tar.gz
ports-37790b26cbda11cd4bb6f237b86cd94739c4059c.zip
x11/virtualgl: fix build with lld 17
Building x11/virtualgl with lld 17 results in the following link errors: ld: error: version script assignment of 'global' to symbol 'clCreateContext' failed: symbol not defined Since the same linker version script is used for all "libvglfaker" library variants, where only one of the implements the clCreateContext symbol, suppress errors with lld >= 17 due to this undefined symbol. PR: 273753 MFH: 2023Q4
-rw-r--r--x11/virtualgl/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/x11/virtualgl/Makefile b/x11/virtualgl/Makefile
index 3e2f0c99cafb..2f777cefb3b0 100644
--- a/x11/virtualgl/Makefile
+++ b/x11/virtualgl/Makefile
@@ -25,6 +25,11 @@ CMAKE_ARGS= -DTJPEG_INCLUDE_DIR=${LOCALBASE}/include \
-DCMAKE_INSTALL_DOCDIR=${DOCSDIR}
CMAKE_INSTALL_PREFIX= ${LOCALBASE}/VirtualGL
+# Some versioned symbols in virtualgl are undefined when libvglfaker.so
+# is linked. Suppress errors with lld >= 17 due to these undefined
+# symbols.
+LDFLAGS+= -Wl,--undefined-version
+
DOCSDIR= ${LOCALBASE}/VirtualGL/doc
OPTIONS_DEFINE= OPENCL OPENSSL XVIDEO DOCS