aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-10-09 15:19:06 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-10-09 15:37:43 +0000
commit378064ea844682f60c3f2611e272090f73567a40 (patch)
treeb4dc006e3a289ee47dbaa79e7cd7248727d93142
parentb91a0f27766668817a5b6aa5148b245095e9dab5 (diff)
downloadports-378064ea844682f60c3f2611e272090f73567a40.tar.gz
ports-378064ea844682f60c3f2611e272090f73567a40.zip
devel/py-async-lru: Add py-async-lru 1.0.3
async_lru is 100% port of Python built-in function functools.lru_cache for asyncio.
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-async-lru/Makefile19
-rw-r--r--devel/py-async-lru/distinfo3
-rw-r--r--devel/py-async-lru/pkg-descr2
4 files changed, 25 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 0370c74b9f90..6408a48bd647 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4164,6 +4164,7 @@
SUBDIR += py-astroid253
SUBDIR += py-asttokens
SUBDIR += py-astunparse
+ SUBDIR += py-async-lru
SUBDIR += py-async_generator
SUBDIR += py-async_timeout
SUBDIR += py-asynctest
diff --git a/devel/py-async-lru/Makefile b/devel/py-async-lru/Makefile
new file mode 100644
index 000000000000..48406dfb27fa
--- /dev/null
+++ b/devel/py-async-lru/Makefile
@@ -0,0 +1,19 @@
+PORTNAME= async-lru
+PORTVERSION= 1.0.3
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Simple lru_cache for asyncio
+WWW= https://github.com/aio-libs/async-lru
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= python:3.6+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-async-lru/distinfo b/devel/py-async-lru/distinfo
new file mode 100644
index 000000000000..543c41003551
--- /dev/null
+++ b/devel/py-async-lru/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1665073068
+SHA256 (async-lru-1.0.3.tar.gz) = c2cb9b2915eb14e6cf3e717154b40f715bf90e596d73623677affd0d1fbcd32a
+SIZE (async-lru-1.0.3.tar.gz) = 4861
diff --git a/devel/py-async-lru/pkg-descr b/devel/py-async-lru/pkg-descr
new file mode 100644
index 000000000000..f4ab5e108b83
--- /dev/null
+++ b/devel/py-async-lru/pkg-descr
@@ -0,0 +1,2 @@
+async_lru is 100% port of Python built-in function functools.lru_cache for
+asyncio.