aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2021-04-10 06:42:43 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2021-04-10 06:44:53 +0000
commit378e5d07d635c18745eb462f2e80e608bbd2fc6c (patch)
tree715f47e75a6ade21933fedc6cfd142fed0bb1372
parent21e76fc62fa61290a6d43972317f8d3bc464eaaf (diff)
downloadports-378e5d07d635c18745eb462f2e80e608bbd2fc6c.tar.gz
ports-378e5d07d635c18745eb462f2e80e608bbd2fc6c.zip
www/miniflux: reformat Makefile
(cherry picked from commit 893f2c6a347c1e2061f4e5351eab008f48f66e73)
-rw-r--r--www/miniflux/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/www/miniflux/Makefile b/www/miniflux/Makefile
index 9d9cae701bcb..430e90a3f14f 100644
--- a/www/miniflux/Makefile
+++ b/www/miniflux/Makefile
@@ -13,16 +13,11 @@ RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:security/ca_root_nss
USES= go:modules
-USERS= miniflux
-GROUPS= miniflux
-
WANT_PGSQL= client
-USE_RC_SUBR= miniflux
USE_GITHUB= yes
GH_PROJECT= v2
-GH_TUPLE= \
- PuerkitoBio:goquery:v1.6.1:puerkitobio_goquery/vendor/github.com/PuerkitoBio/goquery \
+GH_TUPLE= PuerkitoBio:goquery:v1.6.1:puerkitobio_goquery/vendor/github.com/PuerkitoBio/goquery \
andybalholm:cascadia:v1.1.0:andybalholm_cascadia/vendor/github.com/andybalholm/cascadia \
beorn7:perks:v1.0.1:beorn7_perks/vendor/github.com/beorn7/perks \
cespare:xxhash:v2.1.1:cespare_xxhash_v2/vendor/github.com/cespare/xxhash/v2 \
@@ -53,11 +48,16 @@ GH_TUPLE= \
tdewolff:minify:v2.9.13:tdewolff_minify_v2/vendor/github.com/tdewolff/minify/v2 \
tdewolff:parse:v2.5.10:tdewolff_parse_v2/vendor/github.com/tdewolff/parse/v2
+USE_RC_SUBR= miniflux
+
GO_PKGNAME= miniflux.app
GO_TARGET= :${PORTNAME}
GO_BUILDFLAGS= -ldflags="-X miniflux.app/version.Version=${DISTVERSION} \
-X miniflux.app/version.BuildDate=$$(date +'%Y-%m-%dT%H:%M:%SZ')"
+USERS= miniflux
+GROUPS= miniflux
+
OPTIONS_DEFINE= PGSQL_SERVER
PGSQL_SERVER_DESC= Install the PostgreSQL Server Component
PGSQL_SERVER_VARS= WANT_PGSQL=server,contrib