aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-02-21 14:29:42 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-02-21 15:06:48 +0000
commit37c4249febbb08b3664032e79a301cb624277d78 (patch)
treedaf21a140019f5578b574bad6bce49500eb9cec2
parent3124676f76e7f420566f249af3a8dc575b86db35 (diff)
downloadports-37c4249febbb08b3664032e79a301cb624277d78.tar.gz
ports-37c4249febbb08b3664032e79a301cb624277d78.zip
www/libnghttp2: Convert back to autotools
- Remove unnecessary substitution
-rw-r--r--www/libnghttp2/Makefile26
-rw-r--r--www/libnghttp2/files/patch-CMakeLists.txt11
-rw-r--r--www/libnghttp2/files/patch-Makefile.in16
3 files changed, 24 insertions, 29 deletions
diff --git a/www/libnghttp2/Makefile b/www/libnghttp2/Makefile
index 98257399a7c2..33063cf78338 100644
--- a/www/libnghttp2/Makefile
+++ b/www/libnghttp2/Makefile
@@ -1,7 +1,7 @@
PORTNAME= nghttp2
-DISTVERSION= 1.59.0
+PORTVERSION= 1.59.0
CATEGORIES= www net
-MASTER_SITES= https://github.com/${PORTNAME}/${PORTNAME}/releases/download/v${DISTVERSION}/
+MASTER_SITES= https://github.com/nghttp2/nghttp2/releases/download/v${PORTVERSION}/
PKGNAMEPREFIX= lib
MAINTAINER= sunpoet@FreeBSD.org
@@ -12,22 +12,12 @@ WWW= https://nghttp2.org/ \
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= cmake cpe pathfix pkgconfig tar:xz
-USE_LDCONFIG= yes
+USES= compiler:c++14-lang cpe libtool pathfix pkgconfig tar:xz
-CMAKE_OFF= ENABLE_DOC \
- ENABLE_FAILMALLOC \
- ENABLE_HTTP3
-CMAKE_ON= ENABLE_LIB_ONLY \
- ENABLE_STATIC_LIB \
- CMAKE_DISABLE_FIND_PACKAGE_Jansson \
- CMAKE_DISABLE_FIND_PACKAGE_Jemalloc \
- CMAKE_DISABLE_FIND_PACKAGE_Libcares \
- CMAKE_DISABLE_FIND_PACKAGE_Libev \
- CMAKE_DISABLE_FIND_PACKAGE_Libevent \
- CMAKE_DISABLE_FIND_PACKAGE_Libnghttp3 \
- CMAKE_DISABLE_FIND_PACKAGE_Libngtcp2 \
- CMAKE_DISABLE_FIND_PACKAGE_Libngtcp2_crypto_openssl \
- CMAKE_DISABLE_FIND_PACKAGE_LibXml2
+CONFIGURE_ARGS= --enable-lib-only
+GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
+USE_CXXSTD= c++14
+USE_LDCONFIG= yes
.include <bsd.port.mk>
diff --git a/www/libnghttp2/files/patch-CMakeLists.txt b/www/libnghttp2/files/patch-CMakeLists.txt
deleted file mode 100644
index 7d11bf640cd7..000000000000
--- a/www/libnghttp2/files/patch-CMakeLists.txt
+++ /dev/null
@@ -1,11 +0,0 @@
---- CMakeLists.txt.orig 2023-09-15 17:17:34 UTC
-+++ CMakeLists.txt
-@@ -483,7 +483,7 @@ if(ENABLE_DOC)
- add_subdirectory(doc)
- endif()
- add_subdirectory(contrib)
--add_subdirectory(script)
-+#add_subdirectory(script)
- add_subdirectory(bpf)
-
-
diff --git a/www/libnghttp2/files/patch-Makefile.in b/www/libnghttp2/files/patch-Makefile.in
new file mode 100644
index 000000000000..d4174dca7bda
--- /dev/null
+++ b/www/libnghttp2/files/patch-Makefile.in
@@ -0,0 +1,16 @@
+--- Makefile.in.orig 2023-02-13 12:02:52 UTC
++++ Makefile.in
+@@ -448,11 +448,10 @@ top_srcdir = @top_srcdir@
+ # LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION
+ # OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION
+ # WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+-SUBDIRS = lib third-party src bpf examples tests integration-tests \
+- doc contrib script
++SUBDIRS = lib
+
+ ACLOCAL_AMFLAGS = -I m4
+-dist_doc_DATA = README.rst
++dist_doc_DATA =
+ EXTRA_DIST = nghttpx.conf.sample proxy.pac.sample android-config android-env \
+ Dockerfile.android \
+ cmakeconfig.h.in \