aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-07-18 17:47:05 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-07-18 17:47:05 +0000
commit385f1f2dadca42748240f553fc8fe8eb86ef585f (patch)
tree99b9fe067897ea72f9f3b3a8afe3e3c7d5c86e35
parent1bf386432b033fd5c9e1f4aab6eccbdea01b05f1 (diff)
downloadports-385f1f2dadca42748240f553fc8fe8eb86ef585f.tar.gz
ports-385f1f2dadca42748240f553fc8fe8eb86ef585f.zip
graphics/p5-Image-Sane: Fix RUN_DEPENDS
- Sort *_DEPENDS - Add TEST_DEPENDS - Strip shared library - Bump PORTREVISION for dependency and package change - Take maintainership
-rw-r--r--graphics/p5-Image-Sane/Makefile13
1 files changed, 10 insertions, 3 deletions
diff --git a/graphics/p5-Image-Sane/Makefile b/graphics/p5-Image-Sane/Makefile
index c7eb88f4286b..940083234432 100644
--- a/graphics/p5-Image-Sane/Makefile
+++ b/graphics/p5-Image-Sane/Makefile
@@ -2,23 +2,30 @@
PORTNAME= Image-Sane
PORTVERSION= 5
+PORTREVISION= 1
CATEGORIES= graphics perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Perl extension for the SANE (Scanner Access Now Easy) Project
LICENSE= ART10 GPLv1+
LICENSE_COMB= dual
BUILD_DEPENDS= p5-ExtUtils-Depends>=0:devel/p5-ExtUtils-Depends \
- p5-ExtUtils-PkgConfig>=0:devel/p5-ExtUtils-PkgConfig
+ p5-ExtUtils-PkgConfig>=0:devel/p5-ExtUtils-PkgConfig \
+ ${RUN_DEPENDS}
+LIB_DEPENDS= libsane.so:graphics/sane-backends
RUN_DEPENDS= p5-Exception-Class>=1.43:devel/p5-Exception-Class \
+ p5-Readonly>=0:devel/p5-Readonly
+TEST_DEPENDS= p5-Test-Requires>=0:devel/p5-Test-Requires \
p5-Try-Tiny>=0.28:lang/p5-Try-Tiny
-LIB_DEPENDS= libsane.so:graphics/sane-backends
USES= perl5
USE_PERL5= configure
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Image/Sane/Sane.so
+
.include <bsd.port.mk>