aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2023-03-07 21:00:12 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2023-03-07 21:00:12 +0000
commit386b28c3c1babc5d17d35b7044b8a485b488dc5a (patch)
tree9d611fae57f6ee96da3479b3247bf857c9442f8d
parent52e78f89c4a53786057d310cb2e9a717c0f62844 (diff)
downloadports-386b28c3c1babc5d17d35b7044b8a485b488dc5a.tar.gz
ports-386b28c3c1babc5d17d35b7044b8a485b488dc5a.zip
devel/got: update to 0.85
User-visible changes: - fall back to vi(1) instead of ed(1) if neither EDITOR nor VISUAL are set
-rw-r--r--devel/got/Makefile2
-rw-r--r--devel/got/distinfo6
-rw-r--r--devel/got/files/openbsd-compat/sha2.h11
-rw-r--r--devel/got/files/patch-regress_cmdline_commit.sh20
-rw-r--r--devel/got/files/patch-regress_cmdline_common.sh23
-rw-r--r--devel/got/files/patch-regress_cmdline_histedit.sh47
6 files changed, 15 insertions, 94 deletions
diff --git a/devel/got/Makefile b/devel/got/Makefile
index f63c17119a66..ec7a9c5dec40 100644
--- a/devel/got/Makefile
+++ b/devel/got/Makefile
@@ -1,5 +1,5 @@
PORTNAME= got
-PORTVERSION= 0.84
+PORTVERSION= 0.85
CATEGORIES= devel
MASTER_SITES= https://gameoftrees.org/releases/
diff --git a/devel/got/distinfo b/devel/got/distinfo
index 2e08f69776c8..f6237a522f2a 100644
--- a/devel/got/distinfo
+++ b/devel/got/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1677106306
-SHA256 (got-0.84.tar.gz) = 43d573e37f2a1cce7ed6d30c459d19a44a4e7ca77ca3f92cf982bb747341628c
-SIZE (got-0.84.tar.gz) = 801305
+TIMESTAMP = 1678215583
+SHA256 (got-0.85.tar.gz) = 4d11f22fc1bf73cb4b9ac0fab836dd973b752ca67c98d6701e4ec1b9bf1557b3
+SIZE (got-0.85.tar.gz) = 804469
diff --git a/devel/got/files/openbsd-compat/sha2.h b/devel/got/files/openbsd-compat/sha2.h
new file mode 100644
index 000000000000..28eb07763b8f
--- /dev/null
+++ b/devel/got/files/openbsd-compat/sha2.h
@@ -0,0 +1,11 @@
+#ifndef _OPENBSD_COMPAT_SHA2_H_
+#define _OPENBSD_COMPAT_SHA2_H_
+
+#include <sha256.h>
+
+#define SHA2_CTX SHA256_CTX
+#define SHA256Init SHA256_Init
+#define SHA256Update SHA256_Update
+#define SHA256Final SHA256_Final
+
+#endif
diff --git a/devel/got/files/patch-regress_cmdline_commit.sh b/devel/got/files/patch-regress_cmdline_commit.sh
deleted file mode 100644
index 6113f815e739..000000000000
--- a/devel/got/files/patch-regress_cmdline_commit.sh
+++ /dev/null
@@ -1,20 +0,0 @@
---- regress/cmdline/commit.sh.orig 2023-01-30 08:56:03 UTC
-+++ regress/cmdline/commit.sh
-@@ -1492,7 +1492,7 @@ test_commit_prepared_logmsg() {
-
- cat > $testroot/editor.sh <<EOF
- #!/bin/sh
--sed -i 's/foo/bar/' "\$1"
-+sed -i '' 's/foo/bar/' "\$1"
- EOF
- chmod +x $testroot/editor.sh
-
-@@ -1755,7 +1755,7 @@ test_commit_logmsg_ref() {
-
- cat > $testroot/editor.sh <<EOF
- #!/bin/sh
--sed -i 's/# l/l/' "\$1"
-+sed -i '' 's/# l/l/' "\$1"
- EOF
- chmod +x $testroot/editor.sh
-
diff --git a/devel/got/files/patch-regress_cmdline_common.sh b/devel/got/files/patch-regress_cmdline_common.sh
deleted file mode 100644
index 52633c021556..000000000000
--- a/devel/got/files/patch-regress_cmdline_common.sh
+++ /dev/null
@@ -1,23 +0,0 @@
---- regress/cmdline/common.sh.orig 2022-10-24 22:00:47 UTC
-+++ regress/cmdline/common.sh
-@@ -27,6 +27,20 @@ export GOT_IGNORE_GITCONFIG=1
-
- export MALLOC_OPTIONS=S
-
-+# compat wrapper
-+sed()
-+(
-+ for i; do
-+ arg=$1
-+ shift
-+ case $arg in
-+ -i) set - "$@" "$arg" '' ;;
-+ *) set - "$@" "$arg" ;;
-+ esac
-+ done
-+ exec sed "$@"
-+)
-+
- git_init()
- {
- git init -q "$1"
diff --git a/devel/got/files/patch-regress_cmdline_histedit.sh b/devel/got/files/patch-regress_cmdline_histedit.sh
deleted file mode 100644
index fa6d904094fb..000000000000
--- a/devel/got/files/patch-regress_cmdline_histedit.sh
+++ /dev/null
@@ -1,47 +0,0 @@
---- regress/cmdline/histedit.sh.orig 2023-01-29 10:30:53 UTC
-+++ regress/cmdline/histedit.sh
-@@ -1564,7 +1564,7 @@ test_histedit_fold_only() {
-
- cat > $testroot/editor.sh <<EOF
- #!/bin/sh
--sed -i 's/.*/committing folded changes/' "\$1"
-+sed -i '' 's/.*/committing folded changes/' "\$1"
- EOF
- chmod +x $testroot/editor.sh
-
-@@ -1680,7 +1680,7 @@ test_histedit_fold_only_empty_logmsg() {
-
- cat > $testroot/editor.sh <<EOF
- #!/bin/sh
--sed -i 'd' "\$1"
-+sed -i '' 'd' "\$1"
- EOF
- chmod +x $testroot/editor.sh
-
-@@ -1814,7 +1814,7 @@ test_histedit_edit_only() {
-
- cat > $testroot/editor.sh <<EOF
- #!/bin/sh
--sed -i 's/.*/committing edited changes 1/' "\$1"
-+sed -i '' 's/.*/committing edited changes 1/' "\$1"
- EOF
- chmod +x $testroot/editor.sh
-
-@@ -1843,7 +1843,7 @@ EOF
-
- cat > $testroot/editor.sh <<EOF
- #!/bin/sh
--sed -i 's/.*/committing edited changes 2/' "\$1"
-+sed -i '' 's/.*/committing edited changes 2/' "\$1"
- EOF
- chmod +x $testroot/editor.sh
-
-@@ -2239,7 +2239,7 @@ test_histedit_mesg_filemode_change() {
-
- cat > $testroot/editor.sh <<EOF
- #!/bin/sh
--sed -i 's/ x bit / executable bit /' "\$1"
-+sed -i '' 's/ x bit / executable bit /' "\$1"
- EOF
-
- chmod +x $testroot/editor.sh