aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-03-21 18:48:20 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-03-21 19:21:20 +0000
commit38a4d5c2e1b7cedf68638d253be6e80803cf3e58 (patch)
tree095c1655e0094a5b9819f41ebae297e105932c71
parentaef6d375a267cedaec1585cdef0448732209bca4 (diff)
downloadports-38a4d5c2e1b7cedf68638d253be6e80803cf3e58.tar.gz
ports-38a4d5c2e1b7cedf68638d253be6e80803cf3e58.zip
textproc/py-markdown-it-py: Convert to USE_PYTHON=pep517
- Bump PORTREVISION for dependency and package change
-rw-r--r--textproc/py-markdown-it-py/Makefile7
-rw-r--r--textproc/py-markdown-it-py/files/setup.py58
2 files changed, 3 insertions, 62 deletions
diff --git a/textproc/py-markdown-it-py/Makefile b/textproc/py-markdown-it-py/Makefile
index 6cace119ce79..2db4e27364cf 100644
--- a/textproc/py-markdown-it-py/Makefile
+++ b/textproc/py-markdown-it-py/Makefile
@@ -1,5 +1,6 @@
PORTNAME= markdown-it-py
PORTVERSION= 2.1.0
+PORTREVISION= 1
CATEGORIES= textproc python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,10 +12,11 @@ WWW= https://github.com/executablebooks/markdown-it-py
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}flit-core>=3.4<4:devel/py-flit-core@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mdurl>=0.1<1:textproc/py-mdurl@${PY_FLAVOR}
USES= python:3.7+
-USE_PYTHON= autoplist concurrent distutils
+USE_PYTHON= autoplist concurrent pep517
NO_ARCH= yes
@@ -24,7 +26,4 @@ NO_ARCH= yes
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}typing-extensions>=3.7.4:devel/py-typing-extensions@${PY_FLAVOR}
.endif
-post-patch:
- @${SED} -e 's|%%PORTVERSION%%|${PORTVERSION}|' ${FILESDIR}/setup.py > ${WRKSRC}/setup.py
-
.include <bsd.port.post.mk>
diff --git a/textproc/py-markdown-it-py/files/setup.py b/textproc/py-markdown-it-py/files/setup.py
deleted file mode 100644
index a2166377b371..000000000000
--- a/textproc/py-markdown-it-py/files/setup.py
+++ /dev/null
@@ -1,58 +0,0 @@
-#!/usr/bin/env python
-# setup.py generated by flit for tools that don't yet use PEP 517
-
-from distutils.core import setup
-
-packages = \
-['markdown_it',
- 'markdown_it.cli',
- 'markdown_it.common',
- 'markdown_it.helpers',
- 'markdown_it.presets',
- 'markdown_it.rules_block',
- 'markdown_it.rules_core',
- 'markdown_it.rules_inline']
-
-package_data = \
-{'': ['*']}
-
-install_requires = \
-['mdurl~=0.1']
-
-extras_require = \
-{":python_version<'3.8'": ['typing_extensions>=3.7.4'],
- 'benchmarking': ['psutil', 'pytest', 'pytest-benchmark~=3.2'],
- 'code_style': ['pre-commit==2.6'],
- 'compare': ['commonmark~=0.9.1',
- 'markdown~=3.3.6',
- 'mistletoe~=0.8.1',
- 'mistune~=2.0.2',
- 'panflute~=2.1.3'],
- 'linkify': ['linkify-it-py~=1.0'],
- 'plugins': ['mdit-py-plugins'],
- 'profiling': ['gprof2dot'],
- 'rtd': ['attrs',
- 'myst-parser',
- 'pyyaml',
- 'sphinx',
- 'sphinx-copybutton',
- 'sphinx-design',
- 'sphinx_book_theme'],
- 'testing': ['coverage', 'pytest', 'pytest-cov', 'pytest-regressions']}
-
-entry_points = \
-{'console_scripts': ['markdown-it = markdown_it.cli.parse:main']}
-
-setup(name='markdown-it-py',
- version='%%PORTVERSION%%',
- description='Python port of markdown-it. Markdown parsing, done right!',
- author=None,
- author_email='Chris Sewell <chrisj_sewell@hotmail.com>',
- url=None,
- packages=packages,
- package_data=package_data,
- install_requires=install_requires,
- extras_require=extras_require,
- entry_points=entry_points,
- python_requires='>=3.7',
- )