aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDimitry Andric <dim@FreeBSD.org>2023-05-18 15:43:15 +0000
committerDimitry Andric <dim@FreeBSD.org>2023-05-18 18:21:48 +0000
commit38f54301414a3f446ff99de936c985672ff8e8c8 (patch)
treed08fd3a972a40f7165fcc9bb64753b23ce0c160f
parent537df332967dd0c28777cce2edafbf802aea4d76 (diff)
downloadports-38f54301414a3f446ff99de936c985672ff8e8c8.tar.gz
ports-38f54301414a3f446ff99de936c985672ff8e8c8.zip
textproc/jade: fix build with clang 16
Since clang 16 (and gcc 11) the default C++ standard is now gnu++17. Because textproc/jade's Makefile does not explicitly set its C++ standard, this leads to an error: Recognizer.cxx:40:3: error: ISO C++17 does not allow 'register' storage class specifier [-Wregister] register const Trie *pos = trie_.pointer(); ^~~~~~~~~ Add USE_CXXSTD=gnu++98 to compile for C++98 with GNU extensions instead. PR: 271494 Approved by: cy (maintainer) MFH: 2023Q2
-rw-r--r--textproc/jade/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/textproc/jade/Makefile b/textproc/jade/Makefile
index 4c13aa2bfae4..21e818789dc0 100644
--- a/textproc/jade/Makefile
+++ b/textproc/jade/Makefile
@@ -1,6 +1,6 @@
PORTNAME= jade
PORTVERSION= 1.2.1
-PORTREVISION= 10
+PORTREVISION= 11
CATEGORIES= textproc
MASTER_SITES= ftp://ftp.jclark.com/pub/jade/ \
http://dist.bsdlab.org/
@@ -20,6 +20,7 @@ CONFLICTS= sp-1.*
GNU_CONFIGURE= yes
USES= desthack gmake libtool
+USE_CXXSTD= gnu++98
USE_LDCONFIG= yes
CONFIGURE_ARGS= --enable-default-catalog=${PREFIX}/share/sgml/catalog
MAKE_JOBS_UNSAFE= yes