aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorColin Percival <cperciva@FreeBSD.org>2024-01-30 21:20:11 +0000
committerColin Percival <cperciva@FreeBSD.org>2024-01-30 21:26:23 +0000
commit39126a2d9768e46e0fe8795c815721d122adadad (patch)
tree5534ddab575cea09d8c9ce3aa23faea552957477
parent10f1d7931c6be95e8b48fcba72930519b99ac2d9 (diff)
downloadports-39126a2d9768e46e0fe8795c815721d122adadad.tar.gz
ports-39126a2d9768e46e0fe8795c815721d122adadad.zip
sysutils/firstboot-freebsd-update: HTTP_TIMEOUT=5
If a system with firstboot_freebsd_update_enable="YES" boots without access to the FreeBSD Update mirrors (e.g. an EC2 instance which has an EC2 security group settings which block outbound HTTP) the boot will hang until it times out. The default timeout of 120 seconds is suboptimal. Run freebsd-update with a timeout of 5 seconds, and bump the package version to 1.4 to reflect this change. Reported by: mgrooms@shrew.net PR: 276720 Sponsored by: https://www.patreon.com/cperciva
-rw-r--r--sysutils/firstboot-freebsd-update/Makefile2
-rw-r--r--sysutils/firstboot-freebsd-update/files/firstboot_freebsd_update.in2
2 files changed, 2 insertions, 2 deletions
diff --git a/sysutils/firstboot-freebsd-update/Makefile b/sysutils/firstboot-freebsd-update/Makefile
index ae3a9d035acc..9c8499be35a6 100644
--- a/sysutils/firstboot-freebsd-update/Makefile
+++ b/sysutils/firstboot-freebsd-update/Makefile
@@ -1,5 +1,5 @@
PORTNAME= firstboot-freebsd-update
-PORTVERSION= 1.3
+PORTVERSION= 1.4
CATEGORIES= sysutils
MASTER_SITES= # none
DISTFILES= # none
diff --git a/sysutils/firstboot-freebsd-update/files/firstboot_freebsd_update.in b/sysutils/firstboot-freebsd-update/files/firstboot_freebsd_update.in
index 220825e87710..b5f6d5bccfe1 100644
--- a/sysutils/firstboot-freebsd-update/files/firstboot_freebsd_update.in
+++ b/sysutils/firstboot-freebsd-update/files/firstboot_freebsd_update.in
@@ -41,7 +41,7 @@ firstboot_freebsd_update_run()
esac
fi
- freebsd-update --not-running-from-cron fetch
+ env HTTP_TIMEOUT=5 freebsd-update --not-running-from-cron fetch
if [ -e /var/db/freebsd-update/`echo / | sha256`-install ]; then
freebsd-update install
echo "Requesting reboot after installing updates."