aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2021-10-23 12:39:59 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2021-10-25 14:04:50 +0000
commit394ca3e29b67e855e0249c642baeda58fafd4e48 (patch)
treef5e8afb005170212a88b510763b880a2ebcaba7c
parent15c86847a0af526ce2f95acbb1c6d2e9c4ec3872 (diff)
downloadports-394ca3e29b67e855e0249c642baeda58fafd4e48.tar.gz
ports-394ca3e29b67e855e0249c642baeda58fafd4e48.zip
devel/aws-c-http: Add new port
C99 implementation of the HTTP/1.1 and HTTP/2 specifications
-rw-r--r--devel/aws-c-http/Makefile29
-rw-r--r--devel/aws-c-http/distinfo3
-rw-r--r--devel/aws-c-http/pkg-descr3
-rw-r--r--devel/aws-c-http/pkg-plist15
4 files changed, 50 insertions, 0 deletions
diff --git a/devel/aws-c-http/Makefile b/devel/aws-c-http/Makefile
new file mode 100644
index 000000000000..96daa1509527
--- /dev/null
+++ b/devel/aws-c-http/Makefile
@@ -0,0 +1,29 @@
+# Created by: Danilo Egea Gondolfo <danilo@FreeBSD.org>
+
+PORTNAME= aws-c-http
+PORTVERSION= 0.6.8
+DISTVERSIONPREFIX= v
+CATEGORIES= devel
+
+MAINTAINER= danilo@FreeBSD.org
+COMMENT= C99 implementation of the HTTP/1.1 and HTTP/2 specifications
+
+LICENSE= APACHE20
+
+LIB_DEPENDS= libaws-c-common.so:devel/aws-c-common \
+ libaws-c-cal.so:security/aws-c-cal \
+ libaws-c-io.so:devel/aws-c-io \
+ libaws-c-compression.so:devel/aws-c-compression \
+ libs2n.so:security/s2n
+
+USES= cmake compiler:c11 ssl
+
+USE_GITHUB= yes
+GH_ACCOUNT= awslabs
+
+CMAKE_ARGS+= -DBUILD_TESTING=OFF -DBUILD_SHARED_LIBS=ON \
+ -DCMAKE_PREFIX_PATH=${LOCALBASE}
+
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>
diff --git a/devel/aws-c-http/distinfo b/devel/aws-c-http/distinfo
new file mode 100644
index 000000000000..f59650898759
--- /dev/null
+++ b/devel/aws-c-http/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1634977896
+SHA256 (awslabs-aws-c-http-v0.6.8_GH0.tar.gz) = a3afad3501155f7c1e46274a004db3637a5fca451f15df8ad0d936ea0f7d6bce
+SIZE (awslabs-aws-c-http-v0.6.8_GH0.tar.gz) = 389401
diff --git a/devel/aws-c-http/pkg-descr b/devel/aws-c-http/pkg-descr
new file mode 100644
index 000000000000..ca6c0da54396
--- /dev/null
+++ b/devel/aws-c-http/pkg-descr
@@ -0,0 +1,3 @@
+C99 implementation of the HTTP/1.1 and HTTP/2 specifications
+
+WWW: https://github.com/awslabs/aws-c-http
diff --git a/devel/aws-c-http/pkg-plist b/devel/aws-c-http/pkg-plist
new file mode 100644
index 000000000000..711fb6c35903
--- /dev/null
+++ b/devel/aws-c-http/pkg-plist
@@ -0,0 +1,15 @@
+include/aws/http/connection.h
+include/aws/http/connection_manager.h
+include/aws/http/exports.h
+include/aws/http/http.h
+include/aws/http/proxy.h
+include/aws/http/request_response.h
+include/aws/http/server.h
+include/aws/http/statistics.h
+include/aws/http/status_code.h
+include/aws/http/websocket.h
+lib/aws-c-http/cmake/aws-c-http-config.cmake
+lib/aws-c-http/cmake/shared/aws-c-http-targets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/aws-c-http/cmake/shared/aws-c-http-targets.cmake
+lib/libaws-c-http.so
+lib/libaws-c-http.so.1.0.0