aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Clausecker <fuz@FreeBSD.org>2023-02-09 17:05:46 +0000
committerRobert Clausecker <fuz@FreeBSD.org>2023-03-21 12:53:47 +0000
commit3959c2813bc0ba8bb13f1a36f5e088b0f04e68fe (patch)
treec600b9ec636ead1e3eb39765a586d6bf8519157a
parentadc793d0984fb5fa4bdb4e896ae418ff313f2750 (diff)
downloadports-3959c2813bc0ba8bb13f1a36f5e088b0f04e68fe.tar.gz
ports-3959c2813bc0ba8bb13f1a36f5e088b0f04e68fe.zip
graphics/lux: Update to 1.1.5
Upstream changes: - EXIF metadata is now used to determine field of view - panorama photographs from smartphone camera applications are no heuristically detected - new config file ~/.lux.ini is evaluated - many small improvements and bug fixes Changelog: https://groups.google.com/g/hugin-ptx/c/bfX6Fu3mwy0/m/BNmUoqbnAAAJ
-rw-r--r--graphics/lux/Makefile4
-rw-r--r--graphics/lux/distinfo6
-rw-r--r--graphics/lux/files/patch-CMakeLists.txt59
3 files changed, 28 insertions, 41 deletions
diff --git a/graphics/lux/Makefile b/graphics/lux/Makefile
index 5742f54f8bfe..1432f31cc198 100644
--- a/graphics/lux/Makefile
+++ b/graphics/lux/Makefile
@@ -1,5 +1,5 @@
PORTNAME= lux
-PORTVERSION= 1.1.4
+PORTVERSION= 1.1.5
CATEGORIES= graphics
MASTER_SITES= https://bitbucket.org/kfj/pv/get/
PKGNAMESUFFIX= -pv # distinguish from www/lux
@@ -29,7 +29,7 @@ CXXFLAGS+= -Wno-deprecated-declarations
CONFLICTS= lux
WRKSRC= ${WRKDIR}/kfj-pv-${COMMIT}
-COMMIT= 402942545a06
+COMMIT= 4a1b894733a2
OPTIONS_DEFINE_amd64= SSSE3 SSE42 AVX AVX2 AVX512
OPTIONS_DEFINE_i386= SSE2 SSSE3 SSE42 AVX AVX2 AVX512
diff --git a/graphics/lux/distinfo b/graphics/lux/distinfo
index c7984ec8661a..0026a3e9b5e8 100644
--- a/graphics/lux/distinfo
+++ b/graphics/lux/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1661566212
-SHA256 (402942545a06.tar.bz2) = d266d5cb1308aa033af619eff4e81d0c9e4fec9f406a29177ee519b5d92f36cc
-SIZE (402942545a06.tar.bz2) = 1143378
+TIMESTAMP = 1675961713
+SHA256 (4a1b894733a2.tar.bz2) = 008bdbb6d38740aa984abbdf996f96521ec8dd0f7f0c0960150f5b6166aa0bbd
+SIZE (4a1b894733a2.tar.bz2) = 1158307
diff --git a/graphics/lux/files/patch-CMakeLists.txt b/graphics/lux/files/patch-CMakeLists.txt
index c94ff78923fa..24bbaac3b3e1 100644
--- a/graphics/lux/files/patch-CMakeLists.txt
+++ b/graphics/lux/files/patch-CMakeLists.txt
@@ -1,48 +1,35 @@
---- CMakeLists.txt.orig 2022-08-26 12:57:31 UTC
+--- CMakeLists.txt.orig 2023-02-09 16:33:06 UTC
+++ CMakeLists.txt
-@@ -96,8 +96,8 @@ message(STATUS "***** SYSTEM PROCESSOR ${CMAKE_SYSTEM_
- set(i86 FALSE)
+@@ -139,8 +139,8 @@ message(STATUS "***** => LUX DATA DIRECTORY ${DataDir}
+ message(STATUS "***** SYSTEM PROCESSOR ${CMAKE_SYSTEM_PROCESSOR}")
- if(UNIX OR APPLE)
-- if ( ${CMAKE_SYSTEM_PROCESSOR} STREQUAL x86_64
-- OR ${CMAKE_SYSTEM_PROCESSOR} STREQUAL i686)
-+ if ( ${CMAKE_SYSTEM_PROCESSOR} STREQUAL amd64
-+ OR ${CMAKE_SYSTEM_PROCESSOR} STREQUAL i386)
- set(i86 TRUE)
- endif()
- elseif(WIN32)
-@@ -268,7 +268,7 @@ set(AVX2_FLAGS "${RENDERING_FLAGS} \
+ if ( ${CMAKE_SYSTEM_PROCESSOR} STREQUAL x86_64
+- OR ${CMAKE_SYSTEM_PROCESSOR} STREQUAL AMD64
+- OR ${CMAKE_SYSTEM_PROCESSOR} STREQUAL i686 )
++ OR ${CMAKE_SYSTEM_PROCESSOR} STREQUAL amd64
++ OR ${CMAKE_SYSTEM_PROCESSOR} STREQUAL i386 )
+ set(i86 TRUE)
+ message(STATUS "***** setting i86 TRUE for an intel/AMD target")
+ else()
+@@ -351,7 +351,7 @@ set(AVX2_FLAGS "${RENDERING_FLAGS} \
# about it and I don't have an AVX512 machine.
set(AVX512f_FLAGS "${RENDERING_FLAGS} \
-- -mavx512f -march=skx \
-+ -mavx512f -march=skylake-avx512 \
+- -mavx512f -march=skx -mpclmul -maes \
++ -mavx512f -march=skylake-avx512 -mpclmul -maes \
-D hn=hn_avx512 -D PV_ARCH=PV_AVX512f \
-D PV_ARCHNAME=\\\"avx512f\\\" \
-D PV_PRIORITY=0 -D PV_VIABILITY=has_avx512f -D FLV_AVX512f")
-@@ -553,9 +553,6 @@ install(TARGETS ${_project_name} DESTINATION bin)
- # Copy the NotoSans-Regular font and the readme (as required by the license)
- # to the platform-specific font directory
+@@ -651,12 +651,6 @@ endif()
--install(FILES NotoSans-Regular.ttf noto_font_license.txt DESTINATION
-- "${DataDir}/fonts")
--
- # KFJ 2022-08-24 simplified package versioning, only using a.b.c
-
- set(LUX_PACKAGE_RELEASE "${pv_major}.${pv_minor}.${pv_patch}")
-@@ -618,15 +615,6 @@ install(FILES scripts/512X512/lux.png
+ install(TARGETS ${_project_name} DESTINATION bin)
- install(FILES scripts/1024X1024/lux.png
- DESTINATION share/icons/hicolor/1024x1024/apps)
+-# Copy the NotoSans-Regular font and the readme (as required by the license)
+-# to the platform-specific font directory
-
--install(FILES scripts/256X256/lux.png
-- DESTINATION share/icons/gnome/256x256/apps)
--
--install(FILES scripts/512X512/lux.png
-- DESTINATION share/icons/gnome/512x512/apps)
+-install(FILES NotoSans-Regular.ttf noto_font_license.txt DESTINATION
+- "${DataDir}/fonts")
-
--install(FILES scripts/1024X1024/lux.png
-- DESTINATION share/icons/gnome/1024x1024/apps)
-
- install(FILES scripts/lux.desktop
- DESTINATION share/applications)
+ # The next section could do with sone tidying up. It deals with packaging
+ # lux for distribution. This is used for some distribution channles, e.g.
+ # to make .deb packages for ubuntu and debian, but packaging for windows