aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2021-11-08 16:49:35 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2021-11-08 16:49:35 +0000
commit3a565ff18f6b2c5614ece807728e9f88e88ee279 (patch)
treef61155739f2758ce9a1824d5e559fde86140d04b
parent3595156b716c40c4ebfcd4ff10dde9a949e5beee (diff)
downloadports-3a565ff18f6b2c5614ece807728e9f88e88ee279.tar.gz
ports-3a565ff18f6b2c5614ece807728e9f88e88ee279.zip
archivers/c-blosc2: use GCC on powerpc64le for its SSE translation layer to use AltiVec
C11 is required by tests.
-rw-r--r--archivers/c-blosc2/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/archivers/c-blosc2/Makefile b/archivers/c-blosc2/Makefile
index 038186b25c21..6ce38b81dd06 100644
--- a/archivers/c-blosc2/Makefile
+++ b/archivers/c-blosc2/Makefile
@@ -25,6 +25,13 @@ PLIST_SUB= PORTVERSION=${PORTVERSION}
GH_ACCOUNT= Blosc
USE_GITHUB= yes
+.include <bsd.port.options.mk>
+
+.if ${ARCH} == powerpc64le
+USES+= compiler:gcc-c++11-lib
+USE_CSTD= c11
+.endif
+
do-test:
cd ${TEST_WRKSRC} && ctest