aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRainer Hurling <rhurlin@FreeBSD.org>2021-04-08 14:19:00 +0000
committerRainer Hurling <rhurlin@FreeBSD.org>2021-04-08 14:22:02 +0000
commit3a7eb11ce93254b42a76a55cdaefd50be910f765 (patch)
treefba5913ebe6e23ed58006fac224f6fd286577073
parent3c3ce68d711a5fbfa3e114e96972a3f4d35fe27d (diff)
downloadports-3a7eb11ce93254b42a76a55cdaefd50be910f765.tar.gz
ports-3a7eb11ce93254b42a76a55cdaefd50be910f765.zip
textproc/py-python-language-server: Allow jedi >= v0.18.0
Until this is merged upstream [1], do it here. [1] https://github.com/palantir/python-language-server/pull/918 Reported by: Gleb Popov <arrowd@freebsd.org>
-rw-r--r--textproc/py-python-language-server/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/textproc/py-python-language-server/Makefile b/textproc/py-python-language-server/Makefile
index c3de263d8b1a..53ec10196f1b 100644
--- a/textproc/py-python-language-server/Makefile
+++ b/textproc/py-python-language-server/Makefile
@@ -2,7 +2,7 @@
PORTNAME= python-language-server
PORTVERSION= 0.36.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= textproc python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -30,4 +30,12 @@ USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
+# Until upstream is merged, do it here
+# https://github.com/palantir/python-language-server/pull/918
+post-patch:
+ @${REINPLACE_CMD} -e 's|<0.18.0,||g' \
+ ${WRKSRC}/python_language_server.egg-info/requires.txt
+ @${REINPLACE_CMD} -e 's|,<0.18.0||g' \
+ ${WRKSRC}/setup.py
+
.include <bsd.port.mk>