aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2024-03-27 14:42:17 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2024-03-27 14:42:17 +0000
commit3b23f3c86cb474dc98e2edc9cbef2743c27302f2 (patch)
tree3e09ed87d2e0f21a7bbd2110b2e8e50bc752d892
parentdc29da5db6e6ea3932e48facb66c7bfc97dd8cee (diff)
downloadports-3b23f3c86cb474dc98e2edc9cbef2743c27302f2.tar.gz
ports-3b23f3c86cb474dc98e2edc9cbef2743c27302f2.zip
emulators/vice: fix option FFMPEG
PR: 277971
-rw-r--r--emulators/vice/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/emulators/vice/Makefile b/emulators/vice/Makefile
index 42f5f48cfc24..ed9ee293ce77 100644
--- a/emulators/vice/Makefile
+++ b/emulators/vice/Makefile
@@ -1,6 +1,6 @@
PORTNAME= vice
PORTVERSION= 3.8
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= emulators
MASTER_SITES= SF/vice-emu/releases
@@ -22,7 +22,6 @@ LIB_DEPENDS= libpng.so:graphics/png \
libmp3lame.so:audio/lame \
libogg.so:audio/libogg \
libvorbis.so:audio/libvorbis \
- libavcodec.so:multimedia/ffmpeg \
libFLAC.so:audio/flac \
libpci.so:devel/libpci \
libfontconfig.so:x11-fonts/fontconfig \
@@ -77,6 +76,8 @@ ALSA_CONFIGURE_OFF= --without-alsa
ALSA_LIB_DEPENDS= libasound.so:audio/alsa-lib
PULSEAUDIO_CONFIGURE_OFF= --without-pulse
PULSEAUDIO_LIB_DEPENDS= libpulse.so:audio/pulseaudio
+FFMPEG_LIB_DEPENDS= libavcodec.so.58:multimedia/ffmpeg4
+FFMPEG_CONFIGURE_ENV= PKG_CONFIG_PATH="${LOCALBASE}/ffmpeg4/libdata/pkgconfig"
#ETHERNET_LIB_DEPENDS= libpcap.so:net/libpcap # conflict with base
ETHERNET_BUILD_DEPENDS= ${LOCALBASE}/include/pcap.h:net/libpcap
ETHERNET_RUN_DEPENDS= ${LOCALBASE}/include/pcap.h:net/libpcap