aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNeel Chauhan <nc@FreeBSD.org>2021-04-19 20:22:48 +0000
committerNeel Chauhan <nc@FreeBSD.org>2021-04-19 20:23:14 +0000
commit3bad1f892bd8f4f3345a384665f7546d22f937b9 (patch)
tree1c8f548a43579ad6cf87acccd0e33ae338311dbe
parent0f0336d73dac33fd2746d8334a34290b37475223 (diff)
downloadports-3bad1f892bd8f4f3345a384665f7546d22f937b9.tar.gz
ports-3bad1f892bd8f4f3345a384665f7546d22f937b9.zip
www/py-graphite-web: Update to 1.1.8
-rw-r--r--www/py-graphite-web/Makefile2
-rw-r--r--www/py-graphite-web/distinfo6
-rw-r--r--www/py-graphite-web/files/patch-conf__graphite.wsgi.example8
-rw-r--r--www/py-graphite-web/files/patch-setup.py10
-rw-r--r--www/py-graphite-web/pkg-plist3
5 files changed, 17 insertions, 12 deletions
diff --git a/www/py-graphite-web/Makefile b/www/py-graphite-web/Makefile
index a519fb8974e6..c131c9d4c93f 100644
--- a/www/py-graphite-web/Makefile
+++ b/www/py-graphite-web/Makefile
@@ -1,7 +1,7 @@
# Created by: Evan Sarmiento <esarmiento@wayfair.com>
PORTNAME= graphite-web
-PORTVERSION= 1.1.7
+PORTVERSION= 1.1.8
CATEGORIES= www python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/www/py-graphite-web/distinfo b/www/py-graphite-web/distinfo
index b58150a1e683..1dfb6150ab98 100644
--- a/www/py-graphite-web/distinfo
+++ b/www/py-graphite-web/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1587669526
-SHA256 (graphite-project-graphite-web-1.1.7_GH0.tar.gz) = e8522310913f22f3e93fc96e63b39877153e96f051d3d3dd4d417accfb77fd68
-SIZE (graphite-project-graphite-web-1.1.7_GH0.tar.gz) = 1448722
+TIMESTAMP = 1618863438
+SHA256 (graphite-project-graphite-web-1.1.8_GH0.tar.gz) = 6e35629493b9be77fa9902471053f6789e300c06fe74a0215253d986fc0b866c
+SIZE (graphite-project-graphite-web-1.1.8_GH0.tar.gz) = 1458080
diff --git a/www/py-graphite-web/files/patch-conf__graphite.wsgi.example b/www/py-graphite-web/files/patch-conf__graphite.wsgi.example
index 8fc548066b28..1e2b7d2ec0bf 100644
--- a/www/py-graphite-web/files/patch-conf__graphite.wsgi.example
+++ b/www/py-graphite-web/files/patch-conf__graphite.wsgi.example
@@ -1,7 +1,9 @@
---- conf/graphite.wsgi.example.orig 2018-04-04 07:58:36 UTC
+--- conf/graphite.wsgi.example.orig 2021-04-19 05:24:42 UTC
+++ conf/graphite.wsgi.example
-@@ -1,4 +1,4 @@
- import sys
+@@ -2,6 +2,6 @@ import sys
+ # In case of multi-instance graphite, uncomment and set appropriate name
+ # import os
+ # os.environ['GRAPHITE_SETTINGS_MODULE'] = 'graphite.local_settings'
-sys.path.append('/opt/graphite/webapp')
+sys.path.append('%%PYTHON_SITELIBDIR%%/graphite')
diff --git a/www/py-graphite-web/files/patch-setup.py b/www/py-graphite-web/files/patch-setup.py
index ae43494e00c0..557c74aa3348 100644
--- a/www/py-graphite-web/files/patch-setup.py
+++ b/www/py-graphite-web/files/patch-setup.py
@@ -1,4 +1,4 @@
---- setup.py.orig 2020-03-16 15:55:20 UTC
+--- setup.py.orig 2021-04-19 05:24:42 UTC
+++ setup.py
@@ -39,10 +39,6 @@ else:
cf.add_section('install')
@@ -16,7 +16,7 @@
storage_dirs = []
-for subdir in ('whisper/dummy.txt', 'ceres/dummy.txt', 'rrd/dummy.txt', 'log/dummy.txt', 'log/webapp/dummy.txt'):
-- storage_dirs.append( ('storage/%s' % subdir, []) )
+- storage_dirs.append( ('storage/%s' % subdir, []) )
+for subdir in ('whisper', 'ceres', 'rrd', 'log', 'log/webapp'):
+ storage_dirs.append( ('graphite/storage/%s' % subdir, []) )
@@ -24,9 +24,9 @@
-for root, dirs, files in os.walk('webapp/content'):
+for root, dirs, files in os.walk('graphite/webapp/content'):
- for filename in files:
- filepath = os.path.join(root, filename)
- webapp_content[root].append(filepath)
+ for filename in files:
+ filepath = os.path.join(root, filename)
+ webapp_content[root].append(filepath)
-conf_files = [ ('conf', glob('conf/*.example')) ]
+conf_files = [ ('%%PREFIX%%/etc/graphite', glob('conf/*.example')) ]
diff --git a/www/py-graphite-web/pkg-plist b/www/py-graphite-web/pkg-plist
index 354a6f34138e..4962a6d083de 100644
--- a/www/py-graphite-web/pkg-plist
+++ b/www/py-graphite-web/pkg-plist
@@ -575,6 +575,8 @@ bin/build-index.sh
%%PYTHON_SITELIBDIR%%/graphite/render/__pycache__/glyph.cpython-%%PYTHON_SUFFIX%%.pyc
%%PYTHON_SITELIBDIR%%/graphite/render/__pycache__/grammar.cpython-%%PYTHON_SUFFIX%%.opt-1.pyc
%%PYTHON_SITELIBDIR%%/graphite/render/__pycache__/grammar.cpython-%%PYTHON_SUFFIX%%.pyc
+%%PYTHON_SITELIBDIR%%/graphite/render/__pycache__/grammar_unsafe.cpython-37.opt-1.pyc
+%%PYTHON_SITELIBDIR%%/graphite/render/__pycache__/grammar_unsafe.cpython-37.pyc
%%PYTHON_SITELIBDIR%%/graphite/render/__pycache__/hashing.cpython-%%PYTHON_SUFFIX%%.opt-1.pyc
%%PYTHON_SITELIBDIR%%/graphite/render/__pycache__/hashing.cpython-%%PYTHON_SUFFIX%%.pyc
%%PYTHON_SITELIBDIR%%/graphite/render/__pycache__/urls.cpython-%%PYTHON_SUFFIX%%.opt-1.pyc
@@ -587,6 +589,7 @@ bin/build-index.sh
%%PYTHON_SITELIBDIR%%/graphite/render/functions.py
%%PYTHON_SITELIBDIR%%/graphite/render/glyph.py
%%PYTHON_SITELIBDIR%%/graphite/render/grammar.py
+%%PYTHON_SITELIBDIR%%/graphite/render/grammar_unsafe.py
%%PYTHON_SITELIBDIR%%/graphite/render/hashing.py
%%PYTHON_SITELIBDIR%%/graphite/render/urls.py
%%PYTHON_SITELIBDIR%%/graphite/render/views.py