aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-11-01 13:25:03 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-11-01 13:41:30 +0000
commit3c105acb6e387d22f52180b58c3e599ec2e3479b (patch)
tree38c9c1adaff397b00e082401eb011e59da4d9712
parentf0ecb7ddd3bde19b4f7311f33c735312dba92ed4 (diff)
downloadports-3c105acb6e387d22f52180b58c3e599ec2e3479b.tar.gz
ports-3c105acb6e387d22f52180b58c3e599ec2e3479b.zip
graphics/gdal: Update to 3.3.3
-rw-r--r--graphics/gdal/Makefile3
-rw-r--r--graphics/gdal/distinfo6
-rw-r--r--graphics/gdal/files/patch-frmts-pdf-pdfdataset.cpp37
3 files changed, 4 insertions, 42 deletions
diff --git a/graphics/gdal/Makefile b/graphics/gdal/Makefile
index 598b5458b80b..9812d966c76c 100644
--- a/graphics/gdal/Makefile
+++ b/graphics/gdal/Makefile
@@ -1,8 +1,7 @@
# Created by: Randall Hopper
PORTNAME= gdal
-PORTVERSION= 3.3.2
-PORTREVISION= 2
+PORTVERSION= 3.3.3
CATEGORIES= graphics geography
MASTER_SITES= https://download.osgeo.org/gdal/${PORTVERSION}/ \
LOCAL/sunpoet
diff --git a/graphics/gdal/distinfo b/graphics/gdal/distinfo
index d0365c8f5dac..9b83861868d4 100644
--- a/graphics/gdal/distinfo
+++ b/graphics/gdal/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1632036928
-SHA256 (gdal-3.3.2.tar.xz) = 630e34141cf398c3078d7d8f08bb44e804c65bbf09807b3610dcbfbc37115cc3
-SIZE (gdal-3.3.2.tar.xz) = 12940900
+TIMESTAMP = 1635730919
+SHA256 (gdal-3.3.3.tar.xz) = 1e8fc8b19c77238c7f4c27857d04857b65d8b7e8050d3aac256d70fa48a21e76
+SIZE (gdal-3.3.3.tar.xz) = 12946356
diff --git a/graphics/gdal/files/patch-frmts-pdf-pdfdataset.cpp b/graphics/gdal/files/patch-frmts-pdf-pdfdataset.cpp
deleted file mode 100644
index 486541d94a06..000000000000
--- a/graphics/gdal/files/patch-frmts-pdf-pdfdataset.cpp
+++ /dev/null
@@ -1,37 +0,0 @@
---- frmts/pdf/pdfdataset.cpp.orig 2021-09-01 09:50:03 UTC
-+++ frmts/pdf/pdfdataset.cpp
-@@ -3593,7 +3593,7 @@ void PDFDataset::FindLayersPoppler()
- #if (POPPLER_MAJOR_VERSION >= 1 || POPPLER_MINOR_VERSION >= 72)
- const char* pszLayerName = (const char*)ocg->getName()->c_str();
- #else
-- const char* pszLayerName = (const char*)ocg->getName()->getCString();
-+ const char* pszLayerName = (const char*)ocg->getName()->c_str();
- #endif
- AddLayer(pszLayerName);
- oLayerOCGListPoppler.push_back(std::make_pair(CPLString(pszLayerName), ocg));
-@@ -4982,13 +4982,13 @@ PDFDataset *PDFDataset::Open( GDALOpenInfo * poOpenInf
- #ifdef HAVE_POPPLER
- if (bUseLib.test(PDFLIB_POPPLER))
- {
-- GooString* poMetadata = poCatalogPoppler->readMetadata();
-+ auto poMetadata = poCatalogPoppler->readMetadata();
- if (poMetadata)
- {
- #if (POPPLER_MAJOR_VERSION >= 1 || POPPLER_MINOR_VERSION >= 72)
- const char* pszContent = poMetadata->c_str();
- #else
-- const char* pszContent = poMetadata->getCString();
-+ const char* pszContent = poMetadata->c_str();
- #endif
- if (pszContent != nullptr &&
- STARTS_WITH(pszContent, "<?xpacket begin="))
-@@ -4996,7 +4996,9 @@ PDFDataset *PDFDataset::Open( GDALOpenInfo * poOpenInf
- const char * const apszMDList[2] = { pszContent, nullptr };
- poDS->SetMetadata(const_cast<char**>(apszMDList), "xml:XMP");
- }
-+#if (POPPLER_MAJOR_VERSION < 21 || (POPPLER_MAJOR_VERSION == 21 && POPPLER_MINOR_VERSION <= 9))
- delete poMetadata;
-+#endif
- }
-
- /* Read Info object */