aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-05-14 18:42:34 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-05-14 19:59:09 +0000
commit3c4254f93f4af3fcd8e7b8ff2345272ad0c2d5bf (patch)
tree9db061388c4e688937112bf2203f270013d4b8a9
parent998f3c0457698ebf823858ada8848fa37478fbe5 (diff)
downloadports-3c4254f93f4af3fcd8e7b8ff2345272ad0c2d5bf.tar.gz
ports-3c4254f93f4af3fcd8e7b8ff2345272ad0c2d5bf.zip
mail/hbiff: Unbreak on HEAD
- Pet portclippy - Refactor with USES=loccalbase - Adopt port
-rw-r--r--mail/hbiff/Makefile14
1 files changed, 10 insertions, 4 deletions
diff --git a/mail/hbiff/Makefile b/mail/hbiff/Makefile
index a18c8bc4d636..b8151ac8d443 100644
--- a/mail/hbiff/Makefile
+++ b/mail/hbiff/Makefile
@@ -5,17 +5,23 @@ CATEGORIES= mail
MASTER_SITES= ftp://nuxi.ucdavis.edu/pub/misc/ \
LOCAL/obrien
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= bofh@FreeBSD.org
COMMENT= Replacement for xbiff that handles popup window with mail headers
-USES= xorg
+USES= localbase xorg
USE_XORG= x11
-CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
+CFLAGS+= -L${LOCALBASE}/lib
LDFLAGS+= -lX11
PLIST_FILES= bin/hbiff man/man1/hbiff.1.gz
+.include <bsd.port.pre.mk>
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400079
+CFLAGS+= -Wno-error=int-conversion
+.endif
+
do-build:
${CC} ${CFLAGS} ${LDFLAGS} ${WRKSRC}/hbiff.c -o ${WRKSRC}/${PORTNAME}
@@ -23,4 +29,4 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${MANPREFIX}/man/man1
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>