aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Mingrone <jrm@FreeBSD.org>2023-10-15 20:05:05 +0000
committerJoseph Mingrone <jrm@FreeBSD.org>2023-10-15 20:33:31 +0000
commit3c7361b99facd93c93ed9d8e1b83ffc07c42aea8 (patch)
tree7027a5e32d9d09ccfa670af983172e4c2e48c799
parent292f3a8d54d339a1baebc7ffa719dbf31520a466 (diff)
downloadports-3c7361b99facd93c93ed9d8e1b83ffc07c42aea8.tar.gz
ports-3c7361b99facd93c93ed9d8e1b83ffc07c42aea8.zip
security/cyrus-sasl2-xoauth2: New port
This is a plugin implementation of XOAUTH2 for cyrus-sasl2. WWW: https://github.com/moriyoshi/cyrus-sasl-xoauth2/ PR: 252676 Sponsored by: The FreeBSD Foundation Co-authored-by: Thierry Dussuet <thierry.dussuet@protonmail.com>
-rw-r--r--security/Makefile1
-rw-r--r--security/cyrus-sasl2-xoauth2/Makefile36
-rw-r--r--security/cyrus-sasl2-xoauth2/distinfo3
-rw-r--r--security/cyrus-sasl2-xoauth2/pkg-descr6
4 files changed, 46 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 3d06298314ca..0cdd3c6f96d9 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -120,6 +120,7 @@
SUBDIR += cyrus-sasl2
SUBDIR += cyrus-sasl2-gssapi
SUBDIR += cyrus-sasl2-ldapdb
+ SUBDIR += cyrus-sasl2-xoauth2
SUBDIR += cyrus-sasl2-saslauthd
SUBDIR += cyrus-sasl2-sql
SUBDIR += cyrus-sasl2-srp
diff --git a/security/cyrus-sasl2-xoauth2/Makefile b/security/cyrus-sasl2-xoauth2/Makefile
new file mode 100644
index 000000000000..0f0c1fcc83ad
--- /dev/null
+++ b/security/cyrus-sasl2-xoauth2/Makefile
@@ -0,0 +1,36 @@
+PORTNAME= cyrus-sasl2-xoauth2
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.2
+CATEGORIES= security
+
+MAINTAINER= thierry.dussuet@protonmail.com
+COMMENT= XOAUTH2 plugin for cyrus-sasl2
+WWW= https://github.com/moriyoshi/cyrus-sasl-xoauth2/
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libsasl2.so:security/cyrus-sasl2
+
+USES= autoreconf libtool
+USE_GITHUB= yes
+GH_ACCOUNT= moriyoshi
+GH_PROJECT= cyrus-sasl-xoauth2
+USE_LDCONFIG= ${PREFIX}/lib/sasl2
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-cyrus-sasl=${PREFIX}
+
+post-extract:
+ ${MKDIR} ${WRKSRC}/m4
+
+post-install:
+ ${INSTALL_LIB} ${WRKSRC}/.libs/libxoauth2.so.0.0.0 ${STAGEDIR}${PREFIX}/lib/sasl2
+ ${INSTALL_PROGRAM} ${WRKSRC}/.libs/libxoauth2.a ${STAGEDIR}${PREFIX}/lib/sasl2
+
+PLIST_FILES= lib/sasl2/libxoauth2.a \
+ lib/sasl2/libxoauth2.so \
+ lib/sasl2/libxoauth2.so.0 \
+ lib/sasl2/libxoauth2.so.0.0.0
+
+.include <bsd.port.mk>
diff --git a/security/cyrus-sasl2-xoauth2/distinfo b/security/cyrus-sasl2-xoauth2/distinfo
new file mode 100644
index 000000000000..f064eb906974
--- /dev/null
+++ b/security/cyrus-sasl2-xoauth2/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1610623425
+SHA256 (moriyoshi-cyrus-sasl-xoauth2-v0.2_GH0.tar.gz) = a62c26566098100d30aa254e4c1aa4309876b470f139e1019bb9032b6e2ee943
+SIZE (moriyoshi-cyrus-sasl-xoauth2-v0.2_GH0.tar.gz) = 14120
diff --git a/security/cyrus-sasl2-xoauth2/pkg-descr b/security/cyrus-sasl2-xoauth2/pkg-descr
new file mode 100644
index 000000000000..20e232b1f46b
--- /dev/null
+++ b/security/cyrus-sasl2-xoauth2/pkg-descr
@@ -0,0 +1,6 @@
+This is a plugin implementation of XOAUTH2 for cyrus-sasl2.
+
+OAuth 2.0 is a protocol for authorization. The specification and
+extensions are being developed within the IETF OAuth Working Group.
+XOAUTH2 is standard OAuth 2.0 plus a nonstandard SASL binding for OAuth
+that allows clients to send OAuth 2.0 access tokens.