aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Moench-Tegeder <cmt@FreeBSD.org>2021-07-08 14:06:41 +0000
committerChristoph Moench-Tegeder <cmt@FreeBSD.org>2021-07-08 14:06:41 +0000
commit3ce47693f7215e3d0948b202fa571cc45066a51f (patch)
tree06ed528c0c8b7e50689c6da53c21e0fea00b84a3
parent6ceee2ea1481476ad46195f5debcec5350961e00 (diff)
downloadports-3ce47693f7215e3d0948b202fa571cc45066a51f.tar.gz
ports-3ce47693f7215e3d0948b202fa571cc45066a51f.zip
www/firefox: update to 90.0 (rc1)
Release Notes (soon): https://www.mozilla.org/en-US/firefox/90.0beta/releasenotes/ With this version, gtk2 is not required anymore.
-rw-r--r--Mk/bsd.gecko.mk5
-rw-r--r--www/firefox/Makefile3
-rw-r--r--www/firefox/distinfo6
-rw-r--r--www/firefox/files/patch-bug12885872
-rw-r--r--www/firefox/files/patch-bug161891441
5 files changed, 33 insertions, 24 deletions
diff --git a/Mk/bsd.gecko.mk b/Mk/bsd.gecko.mk
index db118dc96b85..023140b8b050 100644
--- a/Mk/bsd.gecko.mk
+++ b/Mk/bsd.gecko.mk
@@ -64,7 +64,10 @@ USES+= compiler:c++17-lang cpe gl gmake gnome iconv localbase perl5 pkgconfig \
python:3.6+,build desktop-file-utils
CPE_VENDOR?=mozilla
USE_GL= gl
-USE_GNOME= cairo gdkpixbuf2 gtk20 gtk30
+USE_GNOME= cairo gdkpixbuf2 gtk30
+.if ${MOZILLA_VER:R:R} < 90
+USE_GNOME+= gtk20
+.endif
USE_PERL5= build
USE_XORG= x11 xcb xcomposite xdamage xext xfixes xrender xt
HAS_CONFIGURE= yes
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index f6880721406f..297a9404b898 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -1,8 +1,7 @@
# Created by: Alan Eldridge <alane@FreeBSD.org>
PORTNAME= firefox
-DISTVERSION= 89.0.2
-PORTREVISION= 1
+DISTVERSION= 90.0
PORTEPOCH= 2
CATEGORIES= www
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \
diff --git a/www/firefox/distinfo b/www/firefox/distinfo
index ac9bfa1ba30c..9e067e55bcce 100644
--- a/www/firefox/distinfo
+++ b/www/firefox/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1624392261
-SHA256 (firefox-89.0.2.source.tar.xz) = 3225f583c5e36bdf52ad16f71a2c359deb0c765c38205acdeb6b7b6520ac5494
-SIZE (firefox-89.0.2.source.tar.xz) = 371053016
+TIMESTAMP = 1625645143
+SHA256 (firefox-90.0.source.tar.xz) = 43a943e7d7660c6d7f5b41c95b344b7fd6a4a88ad0bb45dbd844b372ea60d58b
+SIZE (firefox-90.0.source.tar.xz) = 378743212
diff --git a/www/firefox/files/patch-bug1288587 b/www/firefox/files/patch-bug1288587
index 6130cf7e30da..ef6c2ffc3b5b 100644
--- a/www/firefox/files/patch-bug1288587
+++ b/www/firefox/files/patch-bug1288587
@@ -7,7 +7,7 @@ index 855214a..1e91d51 100644
@imports(_from="mozbuild.pythonutil", _import="python_executable_version")
@imports(_from="six", _import="ensure_text")
+@imports(_from="__builtin__", _import="KeyError")
- def virtualenv_python3(env_python, virtualenv_name, build_env, mozconfig, help):
+ def virtualenv_python3(env_python, build_env, mozconfig, help):
# Avoid re-executing python when running configure --help.
if help:
@@ -271,6 +272,12 @@ def virtualenv_python3(env_python, virtualenv_name, bu
diff --git a/www/firefox/files/patch-bug1618914 b/www/firefox/files/patch-bug1618914
index 94b7aa8d38e1..c52ac49018b2 100644
--- a/www/firefox/files/patch-bug1618914
+++ b/www/firefox/files/patch-bug1618914
@@ -1,10 +1,18 @@
-[Wayland] Fall back to ftruncate if posix_fallocate isn't supported by filesystem.
+From cea8e6a01bb03bbe565c9bf5dd4f439f30ca953f Mon Sep 17 00:00:00 2001
+From: Jan Beich <jbeich@FreeBSD.org>
+Date: Fri, 28 Feb 2020 16:49:38 +0000
+Subject: Bug 1618914 - [Wayland] Fall back to ftruncate if posix_fallocate isn't supported by filesystem.
-diff --git widget/gtk/WindowSurfaceWayland.cpp widget/gtk/WindowSurfaceWayland.cpp
-index 9a73326399bd5..9e42a7f1c5d18 100644
---- widget/gtk/WindowSurfaceWayland.cpp
-+++ widget/gtk/WindowSurfaceWayland.cpp
-@@ -221,7 +221,9 @@ static int WaylandAllocateShmMemory(int aSize) {
+diff --git widget/gtk/WaylandShmBuffer.cpp widget/gtk/WaylandShmBuffer.cpp
+index 42eeedd3429ac..2a5c23d287413 100644
+--- widget/gtk/WaylandShmBuffer.cpp
++++ widget/gtk/WaylandShmBuffer.cpp
+@@ -67,36 +67,37 @@ static int WaylandAllocateShmMemory(int aSize) {
+ return -1;
+ }
+
+ int ret = 0;
+ #ifdef HAVE_POSIX_FALLOCATE
do {
ret = posix_fallocate(fd, 0, aSize);
} while (ret == EINTR);
@@ -15,7 +23,7 @@ index 9a73326399bd5..9e42a7f1c5d18 100644
NS_WARNING(
nsPrintfCString("posix_fallocate() fails to allocate shm memory: %s",
strerror(ret))
-@@ -229,7 +231,7 @@ static int WaylandAllocateShmMemory(int aSize) {
+ .get());
close(fd);
return -1;
}
@@ -24,7 +32,10 @@ index 9a73326399bd5..9e42a7f1c5d18 100644
do {
ret = ftruncate(fd, aSize);
} while (ret < 0 && errno == EINTR);
-@@ -240,7 +242,6 @@ static int WaylandAllocateShmMemory(int aSize) {
+ if (ret < 0) {
+ NS_WARNING(nsPrintfCString("ftruncate() fails to allocate shm memory: %s",
+ strerror(ret))
+ .get());
close(fd);
fd = -1;
}
@@ -32,12 +43,8 @@ index 9a73326399bd5..9e42a7f1c5d18 100644
return fd;
}
-@@ -253,7 +254,7 @@ static bool WaylandReAllocateShmMemory(int aFd, int aSize) {
- do {
- errno = posix_fallocate(aFd, 0, aSize);
- } while (errno == EINTR);
-- if (errno != 0) {
-+ if (errno != 0 && errno != ENODEV && errno != EINVAL && errno != EOPNOTSUPP) {
- return false;
- }
- #endif
+
+ /* static */
+ RefPtr<WaylandShmPool> WaylandShmPool::Create(
+ const RefPtr<nsWaylandDisplay>& aWaylandDisplay, int aSize) {
+ RefPtr<WaylandShmPool> shmPool = new WaylandShmPool(aSize);