aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDimitry Andric <dim@FreeBSD.org>2024-03-09 21:37:15 +0000
committerXin LI <delphij@FreeBSD.org>2024-03-09 21:37:15 +0000
commit3d75c31b623969e665a9c83337efe34417cd4b78 (patch)
treec08283dcc3cb3ae3b7bffcd8dc1b5939fe65928d
parent6dd8c17a36d4e75a4fb0efae9874f2aa24693555 (diff)
downloadports-3d75c31b623969e665a9c83337efe34417cd4b78.tar.gz
ports-3d75c31b623969e665a9c83337efe34417cd4b78.zip
net/openldap26-server: fix build with lld 17 and DEBUG option off
If the DEBUG option for the net/openldap26-server is turned off, building the port will result in: ld: error: version script assignment of 'OPENLDAP_2.200' to symbol 'ldap_dump_connection' failed: symbol not defined ld: error: version script assignment of 'OPENLDAP_2.200' to symbol 'ldap_dump_requests_and_responses' failed: symbol not defined cc: error: linker command failed with exit code 1 (use -v to see invocation) This is because the mentioned symbols are in a #ifdef LDAP_DEBUG block, and will indeed not be defined if DEBUG option is off. Adjust the port Makefile to delete the undefined symbols from the ldap.map file, if the DEBUG option is off. PR: 277585 Reported by: Matt Magoffin <bugs.freebsd.org@msqr.us> MFH: 2024Q1
-rw-r--r--net/openldap26-server/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/net/openldap26-server/Makefile b/net/openldap26-server/Makefile
index a11473918662..4b3fb061554a 100644
--- a/net/openldap26-server/Makefile
+++ b/net/openldap26-server/Makefile
@@ -390,6 +390,11 @@ post-patch:
@${REINPLACE_CMD} -E ${CONFIGURE_SED} \
${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
.endif
+.if !${PORT_OPTIONS:MDEBUG}
+ @${REINPLACE_CMD} -E \
+ -e '/ldap_dump_(connection|requests_and_responses);/d' \
+ ${WRKSRC}/libraries/libldap/ldap.map
+.endif
pre-configure:
@(cd ${WRKSRC} && ${LOCALBASE}/bin/autoconf)