aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-02-21 14:46:44 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-02-21 15:08:07 +0000
commit3d85fa6e3ea1753e2161959d9317f39c9c168660 (patch)
tree9dd78e2c4e0d8bd6d9af3f9a9ff1191cadf4e327
parenta408913294666a34d38c123855ac7541c7b0046a (diff)
downloadports-3d85fa6e3ea1753e2161959d9317f39c9c168660.tar.gz
ports-3d85fa6e3ea1753e2161959d9317f39c9c168660.zip
www/py-daphne: Update to 4.1.0
- Convert to USE_PYTHON=pep517 Changes: https://github.com/django/daphne/blob/main/CHANGELOG.txt
-rw-r--r--www/py-daphne/Makefile6
-rw-r--r--www/py-daphne/distinfo6
-rw-r--r--www/py-daphne/files/patch-setup.cfg10
-rw-r--r--www/py-daphne/files/patch-setup.py10
4 files changed, 17 insertions, 15 deletions
diff --git a/www/py-daphne/Makefile b/www/py-daphne/Makefile
index 9340cdd57072..f4812d3be9c1 100644
--- a/www/py-daphne/Makefile
+++ b/www/py-daphne/Makefile
@@ -1,5 +1,5 @@
PORTNAME= daphne
-PORTVERSION= 4.0.0
+PORTVERSION= 4.1.0
CATEGORIES= www python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,12 +11,14 @@ WWW= https://github.com/django/daphne
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}asgiref>=3.5.2<4:www/py-asgiref@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}autobahn>=22.4.2:www/py-autobahn@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}twisted>=22.4:devel/py-twisted@${PY_FLAVOR}
USES= python
-USE_PYTHON= autoplist concurrent distutils
+USE_PYTHON= autoplist concurrent pep517
NO_ARCH= yes
diff --git a/www/py-daphne/distinfo b/www/py-daphne/distinfo
index 9420c7dc4fe7..1c3ad86a120c 100644
--- a/www/py-daphne/distinfo
+++ b/www/py-daphne/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1696904102
-SHA256 (daphne-4.0.0.tar.gz) = cce9afc8f49a4f15d4270b8cfb0e0fe811b770a5cc795474e97e4da287497666
-SIZE (daphne-4.0.0.tar.gz) = 28600
+TIMESTAMP = 1708449502
+SHA256 (daphne-4.1.0.tar.gz) = 882fab39d0b90c6b2709b38116c95f660b6cf236600115dd7c13161fb98b3448
+SIZE (daphne-4.1.0.tar.gz) = 37807
diff --git a/www/py-daphne/files/patch-setup.cfg b/www/py-daphne/files/patch-setup.cfg
new file mode 100644
index 000000000000..3e934742f30a
--- /dev/null
+++ b/www/py-daphne/files/patch-setup.cfg
@@ -0,0 +1,10 @@
+--- setup.cfg.orig 2024-02-10 14:45:57 UTC
++++ setup.cfg
+@@ -34,7 +34,6 @@ setup_requires =
+ twisted[tls]>=22.4
+ python_requires = >=3.8
+ setup_requires =
+- pytest-runner
+ zip_safe = False
+
+ [options.entry_points]
diff --git a/www/py-daphne/files/patch-setup.py b/www/py-daphne/files/patch-setup.py
deleted file mode 100644
index 7f1471e1dd55..000000000000
--- a/www/py-daphne/files/patch-setup.py
+++ /dev/null
@@ -1,10 +0,0 @@
---- setup.py.orig 2022-10-07 10:10:21 UTC
-+++ setup.py
-@@ -24,7 +24,6 @@ setup(
- include_package_data=True,
- install_requires=["twisted[tls]>=22.4", "autobahn>=22.4.2", "asgiref>=3.5.2,<4"],
- python_requires=">=3.7",
-- setup_requires=["pytest-runner"],
- extras_require={"tests": ["hypothesis", "pytest", "pytest-asyncio", "django"]},
- entry_points={
- "console_scripts": ["daphne = daphne.cli:CommandLineInterface.entrypoint"]