aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-08-02 11:49:05 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-08-02 12:27:29 +0000
commit3d95151c2eb7d9f8cb1f149506116b470c43b947 (patch)
tree036af82f02333ca3f9c4a172b30cc6e3ef52e464
parent02ed1337f529970065e709e86919222a45f80c1c (diff)
downloadports-3d95151c2eb7d9f8cb1f149506116b470c43b947.tar.gz
ports-3d95151c2eb7d9f8cb1f149506116b470c43b947.zip
audio/ncmpc: Fix build with llvm16
Approved by: portmgr (blanket) Sponsored by: The FreeBSD Foundation
-rw-r--r--audio/ncmpc/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/audio/ncmpc/Makefile b/audio/ncmpc/Makefile
index 204fc02b685c..6a525240bb74 100644
--- a/audio/ncmpc/Makefile
+++ b/audio/ncmpc/Makefile
@@ -46,4 +46,10 @@ NLS_USES= gettext
PORTDOCS= *
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${COMPILER_TYPE} == clang && ${COMPILER_VERSION} >= 160
+CPPFLAGS+= -Wno-error=enum-constexpr-conversion
+.endif
+
+.include <bsd.port.post.mk>