aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-03-21 18:44:07 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-03-21 19:20:42 +0000
commit3daf9238af0a06737482afbec0a6f2985fd3d194 (patch)
tree2e93327f95b03ba7899a6197c9db279665167c1f
parent64d9e32393ae3f1e339400593981eb96d7dadb7e (diff)
downloadports-3daf9238af0a06737482afbec0a6f2985fd3d194.tar.gz
ports-3daf9238af0a06737482afbec0a6f2985fd3d194.zip
devel/py-ipykernel: Convert to USE_PYTHON=pep517
- Bump PORTREVISION for dependency and package change
-rw-r--r--devel/py-ipykernel/Makefile8
-rw-r--r--devel/py-ipykernel/files/setup.py75
2 files changed, 4 insertions, 79 deletions
diff --git a/devel/py-ipykernel/Makefile b/devel/py-ipykernel/Makefile
index 726878b53c68..846a6b4e6994 100644
--- a/devel/py-ipykernel/Makefile
+++ b/devel/py-ipykernel/Makefile
@@ -1,5 +1,6 @@
PORTNAME= ipykernel
PORTVERSION= 6.20.2
+PORTREVISION= 1
CATEGORIES= devel python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,6 +12,8 @@ WWW= https://ipython.org/
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/COPYING.md
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}hatchling>=1.4:devel/py-hatchling@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}jupyter-client>=6:devel/py-jupyter-client@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}comm>=0.1.1:devel/py-comm@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}debugpy>=1.0:devel/py-debugpy@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}ipython>=7.23.1:devel/ipython@${PY_FLAVOR} \
@@ -24,11 +27,8 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}comm>=0.1.1:devel/py-comm@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}traitlets>=5.4.0:devel/py-traitlets@${PY_FLAVOR}
USES= python:3.8+
-USE_PYTHON= autoplist concurrent distutils
+USE_PYTHON= autoplist concurrent pep517
NO_ARCH= yes
-post-patch:
- @${SED} -e 's|%%PORTVERSION%%|${PORTVERSION}|' ${FILESDIR}/setup.py > ${WRKSRC}/setup.py
-
.include <bsd.port.mk>
diff --git a/devel/py-ipykernel/files/setup.py b/devel/py-ipykernel/files/setup.py
deleted file mode 100644
index d38309a685be..000000000000
--- a/devel/py-ipykernel/files/setup.py
+++ /dev/null
@@ -1,75 +0,0 @@
-# -*- coding: utf-8 -*-
-from setuptools import setup
-
-setup(
- name='ipykernel',
- version='%%PORTVERSION%%',
- description='IPython Kernel for Jupyter',
- long_description='# IPython Kernel for Jupyter\n\nThis package provides the IPython kernel for Jupyter.\n\n## Installation from source\n\n1. `git clone`\n2. `cd ipykernel`\n3. `pip install -e ".[test]"`\n\nAfter that, all normal `ipython` commands will use this newly-installed version of the kernel.\n\n## Running tests\n\nFollow the instructions from `Installation from source`.\n\nand then from the root directory\n\n```bash\npytest ipykernel\n```\n\n## Running tests with coverage\n\nFollow the instructions from `Installation from source`.\n\nand then from the root directory\n\n```bash\npytest ipykernel -vv -s --cov ipykernel --cov-branch --cov-report term-missing:skip-covered --durations 10\n```\n',
- author_email='IPython Development Team <ipython-dev@scipy.org>',
- classifiers=[
- 'Intended Audience :: Developers',
- 'Intended Audience :: Science/Research',
- 'Intended Audience :: System Administrators',
- 'License :: OSI Approved :: BSD License',
- 'Programming Language :: Python',
- 'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.8',
- 'Programming Language :: Python :: 3.9',
- 'Programming Language :: Python :: 3.10',
- 'Programming Language :: Python :: 3.11',
- ],
- install_requires=[
- 'appnope; platform_system == "Darwin"',
- 'comm>=0.1.1',
- 'debugpy>=1.0',
- 'ipython>=7.23.1',
- 'jupyter-client>=6.1.12',
- 'matplotlib-inline>=0.1',
- 'nest-asyncio',
- 'packaging',
- 'psutil',
- 'pyzmq>=17',
- 'tornado>=6.1',
- 'traitlets>=5.4.0',
- ],
- extras_require={
- 'doc': [
- 'myst_parser',
- 'pydata_sphinx_theme',
- 'sphinx',
- 'sphinxcontrib_github_alt',
- 'sphinxcontrib-spelling',
- 'sphinx-autodoc-typehints',
- 'trio',
- ],
- 'test': [
- 'flaky',
- 'ipyparallel',
- 'pre-commit',
- 'pytest-cov',
- 'pytest-asyncio',
- 'pytest-timeout',
- 'pytest>=7.0',
- ],
- 'cov': [
- 'coverage[toml]',
- 'pytest-cov',
- 'matplotlib',
- 'curio',
- 'trio',
- ],
- 'pyqt5': ['pyqt5'],
- 'pyside6': ['pyside6'],
- },
- py_modules=['ipykernel_launcher'],
- packages=[
- 'ipykernel',
- 'ipykernel.comm',
- 'ipykernel.gui',
- 'ipykernel.inprocess',
- 'ipykernel.inprocess.tests',
- 'ipykernel.pylab',
- 'ipykernel.tests',
- ],
-)