aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2022-03-19 15:14:47 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2022-03-19 16:26:59 +0000
commit3dd211e911cc4ff4edc2987c644e74194579a7bf (patch)
treef7ef447a07c58dbe64f0acb75da2e01d5a8c3c52
parentda0e29314591ad9cb3efd180b434ea1246c2f396 (diff)
downloadports-3dd211e911cc4ff4edc2987c644e74194579a7bf.tar.gz
ports-3dd211e911cc4ff4edc2987c644e74194579a7bf.zip
deskutils/semantik: prepare for KDE Frameworks 5.92.0
Help the WAF build system out, and directly add the location of the required header files. PR: 262522
-rw-r--r--deskutils/semantik/Makefile15
1 files changed, 15 insertions, 0 deletions
diff --git a/deskutils/semantik/Makefile b/deskutils/semantik/Makefile
index 995e20c29ef9..e8ac654443c1 100644
--- a/deskutils/semantik/Makefile
+++ b/deskutils/semantik/Makefile
@@ -34,6 +34,21 @@ CONFIGURE_ENV= PATH="${KDE_PREFIX}/bin:$$PATH" \
MAKE_ENV= DESTDIR="${STAGEDIR}"
CFLAGS+= -I${LOCALBASE}/include
CPPFLAGS+= -I${LOCALBASE}/include
+# Help WAF a bit more by simply adding the locations to the KF5
+# headers ourselves...
+CXXFLAGS+= -I${LOCALBASE}/include/KF5/KAuthCore \
+ -I${LOCALBASE}/include/KF5/KConfigCore \
+ -I${LOCALBASE}/include/KF5/KConfigGui \
+ -I${LOCALBASE}/include/KF5/KConfigWidgets \
+ -I${LOCALBASE}/include/KF5/KCoreAddons \
+ -I${LOCALBASE}/include/KF5/KDELibs4Support \
+ -I${LOCALBASE}/include/KF5/KI18n \
+ -I${LOCALBASE}/include/KF5/KIOCore \
+ -I${LOCALBASE}/include/KF5/KIOWidgets \
+ -I${LOCALBASE}/include/KF5/KWidgetsAddons \
+ -I${LOCALBASE}/include/KF5/KXmlGui \
+ -I${LOCALBASE}/include/KF5/SonnetUi \
+
PLIST_SUB= PORTVERSION="${PORTVERSION}"