aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Gmelin <grembo@FreeBSD.org>2024-02-12 11:20:11 +0000
committerMichael Gmelin <grembo@FreeBSD.org>2024-02-18 11:22:18 +0000
commit3e2f2da58e33d7b091afaa4e9390d13d4ef75acc (patch)
tree14a36f3ea46a24792a79178450e9e01ca73819d4
parentd32f571395fe228a2a06ebc29ac1624805202077 (diff)
downloadports-3e2f2da58e33d7b091afaa4e9390d13d4ef75acc.tar.gz
ports-3e2f2da58e33d7b091afaa4e9390d13d4ef75acc.zip
graphics/py-pyzbar: New port
Read one-dimensional barcodes and qr codes from python 2 and 3
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/py-pyzbar/Makefile23
-rw-r--r--graphics/py-pyzbar/distinfo3
-rw-r--r--graphics/py-pyzbar/pkg-descr2
4 files changed, 29 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index dfde9395f10f..91bb51a36dfc 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -954,6 +954,7 @@
SUBDIR += py-pyvips
SUBDIR += py-pyvista
SUBDIR += py-pyx
+ SUBDIR += py-pyzbar
SUBDIR += py-qpageview
SUBDIR += py-qrencode
SUBDIR += py-qt6-3d
diff --git a/graphics/py-pyzbar/Makefile b/graphics/py-pyzbar/Makefile
new file mode 100644
index 000000000000..8a2e26b974ed
--- /dev/null
+++ b/graphics/py-pyzbar/Makefile
@@ -0,0 +1,23 @@
+PORTNAME= pyzbar
+PORTVERSION= 0.1.9
+DISTVERSIONPREFIX= v
+CATEGORIES= graphics python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= grembo@FreeBSD.org
+COMMENT= Read one-dimensional barcodes and qr codes from python 2 and 3
+WWW= https://github.com/NaturalHistoryMuseum/pyzbar
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+LIB_DEPENDS= libzbar.so:graphics/zbar
+
+USES= python
+USE_GITHUB= yes
+GH_ACCOUNT= NaturalHistoryMuseum
+USE_PYTHON= autoplist distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/graphics/py-pyzbar/distinfo b/graphics/py-pyzbar/distinfo
new file mode 100644
index 000000000000..0019dd982817
--- /dev/null
+++ b/graphics/py-pyzbar/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1707593195
+SHA256 (NaturalHistoryMuseum-pyzbar-v0.1.9_GH0.tar.gz) = 6b84ec4c1f36df590c65b610a7757ef8829f202a7df210d2891e6592a8bee8bb
+SIZE (NaturalHistoryMuseum-pyzbar-v0.1.9_GH0.tar.gz) = 45793
diff --git a/graphics/py-pyzbar/pkg-descr b/graphics/py-pyzbar/pkg-descr
new file mode 100644
index 000000000000..96300c23c1f8
--- /dev/null
+++ b/graphics/py-pyzbar/pkg-descr
@@ -0,0 +1,2 @@
+Read one-dimensional barcodes and QR codes from Python 2 and 3
+using the zbar library.