aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Engberg <diizzy@FreeBSD.org>2024-05-26 10:52:19 +0000
committerDaniel Engberg <diizzy@FreeBSD.org>2024-05-26 10:52:26 +0000
commit3ee20599dc55c0550802020b9d0146b1bc15f763 (patch)
treeee49a4993bda1c562f96244c253a666a358e6de0
parent547ee8e902f46e8b2642dc0bb3f4d09eff230d16 (diff)
downloadports-3ee20599dc55c0550802020b9d0146b1bc15f763.tar.gz
ports-3ee20599dc55c0550802020b9d0146b1bc15f763.zip
*/*: Remove incorrect libtool dependency
All these ports builds without libtool Tested using Poudriere Approved by: portmgr (blanket, build fix)
-rw-r--r--audio/rtaudio/Makefile2
-rw-r--r--devel/avrdude/Makefile2
-rw-r--r--devel/blitz/Makefile2
-rw-r--r--devel/thrift-c_glib/Makefile2
-rw-r--r--devel/thrift/Makefile2
-rw-r--r--graphics/libpano13/Makefile2
-rw-r--r--graphics/poppler/Makefile2
-rw-r--r--graphics/proj/Makefile2
-rw-r--r--graphics/xcftools/Makefile2
-rw-r--r--irc/weechat/Makefile2
-rw-r--r--net-im/tox/Makefile2
-rw-r--r--net-p2p/libtorrent-rasterbar/Makefile2
-rw-r--r--net-p2p/libtorrent-rasterbar2/Makefile2
-rw-r--r--net-p2p/transmission-components/Makefile2
-rw-r--r--net/libvncserver/Makefile2
-rw-r--r--print/qpdf/Makefile2
-rw-r--r--science/hdf5-18/Makefile2
-rw-r--r--security/libscep/Makefile2
-rw-r--r--security/yubico-piv-tool/Makefile2
-rw-r--r--sysutils/jstest-gtk/Makefile2
-rw-r--r--x11-toolkits/soqt/Makefile2
21 files changed, 21 insertions, 21 deletions
diff --git a/audio/rtaudio/Makefile b/audio/rtaudio/Makefile
index c2033fba6beb..0f9cf0d7c973 100644
--- a/audio/rtaudio/Makefile
+++ b/audio/rtaudio/Makefile
@@ -8,7 +8,7 @@ WWW= https://github.com/thestk/rtaudio
LICENSE= MIT
-USES= cmake:testing compiler:c++11-lang libtool pkgconfig
+USES= cmake:testing compiler:c++11-lang pkgconfig
USE_LDCONFIG= yes
USE_GITHUB= yes
diff --git a/devel/avrdude/Makefile b/devel/avrdude/Makefile
index 8491c17dae93..e5aab7b96484 100644
--- a/devel/avrdude/Makefile
+++ b/devel/avrdude/Makefile
@@ -11,7 +11,7 @@ WWW= https://github.com/avrdudes/avrdude/
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= libtool localbase readline cmake
+USES= localbase readline cmake
USE_GITHUB= yes
GH_ACCOUNT= avrdudes
GH_PROJECT= avrdude
diff --git a/devel/blitz/Makefile b/devel/blitz/Makefile
index 733c52c0d339..34adae116a35 100644
--- a/devel/blitz/Makefile
+++ b/devel/blitz/Makefile
@@ -10,7 +10,7 @@ WWW= https://github.com/blitzpp/blitz
LICENSE= ART20
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= cmake:noninja libtool localbase python:build
+USES= cmake:noninja localbase python:build
USE_GITHUB= yes
GH_ACCOUNT= blitzpp
USE_LDCONFIG= yes
diff --git a/devel/thrift-c_glib/Makefile b/devel/thrift-c_glib/Makefile
index f92aa8a86df8..cc7cd7027178 100644
--- a/devel/thrift-c_glib/Makefile
+++ b/devel/thrift-c_glib/Makefile
@@ -15,7 +15,7 @@ BUILDIR= ${WRKDIR}/${DISTNAME}/lib/c_glib
DISTINFO_FILE= ${.CURDIR}/../thrift/distinfo
-USES= bison cmake compiler:c++11-lang cpe gnome libtool pathfix \
+USES= bison cmake compiler:c++11-lang cpe gnome pathfix \
pkgconfig ssl
CPE_VENDOR= apache
CMAKE_ON= BUILD_C_GLIB BUILD_SHARED_LIBS
diff --git a/devel/thrift/Makefile b/devel/thrift/Makefile
index 6e9b0181c919..fe0eae0d8e74 100644
--- a/devel/thrift/Makefile
+++ b/devel/thrift/Makefile
@@ -11,7 +11,7 @@ WWW= https://thrift.apache.org/
LICENSE= APACHE20
-USES= bison cmake compiler:c++11-lang cpe libtool pkgconfig
+USES= bison cmake compiler:c++11-lang cpe pkgconfig
CPE_VENDOR= apache
USE_LDCONFIG= yes
diff --git a/graphics/libpano13/Makefile b/graphics/libpano13/Makefile
index 884b1390c29b..b379f1ef25f8 100644
--- a/graphics/libpano13/Makefile
+++ b/graphics/libpano13/Makefile
@@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libpng.so:graphics/png \
libtiff.so:graphics/tiff
-USES= cmake:testing cpe jpeg libtool pathfix perl5 pkgconfig
+USES= cmake:testing cpe jpeg pathfix perl5 pkgconfig
CPE_VENDOR= ${PORTNAME}_project
USE_LDCONFIG= yes
USE_PERL5= build # for pod2man
diff --git a/graphics/poppler/Makefile b/graphics/poppler/Makefile
index db03ad8217e7..c929c6151c56 100644
--- a/graphics/poppler/Makefile
+++ b/graphics/poppler/Makefile
@@ -23,7 +23,7 @@ BUILD_DEPENDS= ${LOCALBASE}/include/boost/container/small_vector.hpp:devel/boost
gsed:textproc/gsed
RUN_DEPENDS= poppler-data>0:graphics/poppler-data
-USES= cmake:insource compiler:c++17-lang cpe gnome gperf jpeg libtool \
+USES= cmake:insource compiler:c++17-lang cpe gnome gperf jpeg \
localbase pathfix pkgconfig tar:xz
CPE_VENDOR= freedesktop
USE_GNOME= cairo libxml2
diff --git a/graphics/proj/Makefile b/graphics/proj/Makefile
index 48799b5c95bc..71cec54ded4a 100644
--- a/graphics/proj/Makefile
+++ b/graphics/proj/Makefile
@@ -16,7 +16,7 @@ LIB_DEPENDS= libcurl.so:ftp/curl \
libtiff.so:graphics/tiff
#RUN_DEPENDS= proj-data>=0:graphics/proj-data
-USES= compiler:c++11-lang cmake cpe libtool pathfix pkgconfig sqlite
+USES= compiler:c++11-lang cmake cpe pathfix pkgconfig sqlite
USE_LDCONFIG= yes
CMAKE_OFF= BUILD_TESTING
diff --git a/graphics/xcftools/Makefile b/graphics/xcftools/Makefile
index 90d012d09b53..c076b9358b9b 100644
--- a/graphics/xcftools/Makefile
+++ b/graphics/xcftools/Makefile
@@ -17,7 +17,7 @@ GH_ACCOUNT= j-jorge
GH_TAGNAME= d72ba82
# option NLS (for gettext) is wrong as this port allways needs NLS:
-USES= cpe libtool cmake:insource,noninja gmake iconv pkgconfig perl5 gettext
+USES= cpe cmake:insource,noninja gmake iconv pkgconfig perl5 gettext
CPE_VENDOR= ${PORTNAME}_project
USE_PERL5= build run
GNU_CONFIGURE= yes
diff --git a/irc/weechat/Makefile b/irc/weechat/Makefile
index dba99258c742..ed9b626dcbb0 100644
--- a/irc/weechat/Makefile
+++ b/irc/weechat/Makefile
@@ -15,7 +15,7 @@ LIB_DEPENDS+= libcurl.so:ftp/curl \
libgnutls.so:security/gnutls \
libgpg-error.so:security/libgpg-error
-USES= cmake cpe libtool ncurses pkgconfig tar:xz
+USES= cmake cpe ncurses pkgconfig tar:xz
USE_LDCONFIG= yes
CMAKE_ARGS= -DLIBDATADIR=${LOCALBASE}/libdata
diff --git a/net-im/tox/Makefile b/net-im/tox/Makefile
index 71ae9c986797..d9b722cc1cb3 100644
--- a/net-im/tox/Makefile
+++ b/net-im/tox/Makefile
@@ -30,7 +30,7 @@ GH_SUBDIR= third_party/cmp:cmp
CPE_VENDOR= toktok
-USES= cmake cpe libtool pathfix pkgconfig
+USES= cmake cpe pathfix pkgconfig
USE_LDCONFIG= yes
PLIST_SUB= VER=${PORTVERSION:C/0.//}.0 SO=2
diff --git a/net-p2p/libtorrent-rasterbar/Makefile b/net-p2p/libtorrent-rasterbar/Makefile
index e31d9820b5b8..5d2badd59aca 100644
--- a/net-p2p/libtorrent-rasterbar/Makefile
+++ b/net-p2p/libtorrent-rasterbar/Makefile
@@ -15,7 +15,7 @@ LIB_DEPENDS= libboost_chrono.so:devel/boost-libs \
libboost_random.so:devel/boost-libs \
libboost_system.so:devel/boost-libs
-USES= cmake compiler:c++17-lang iconv:wchar_t libtool localbase:ldflags pathfix pkgconfig python:test shebangfix ssl
+USES= cmake compiler:c++17-lang iconv:wchar_t localbase:ldflags pathfix pkgconfig python:test shebangfix ssl
SHEBANG_FILES= test/socks.py test/web_server.py
USE_LDCONFIG= yes
diff --git a/net-p2p/libtorrent-rasterbar2/Makefile b/net-p2p/libtorrent-rasterbar2/Makefile
index 6096261fe9ed..4b8ca26cc9c2 100644
--- a/net-p2p/libtorrent-rasterbar2/Makefile
+++ b/net-p2p/libtorrent-rasterbar2/Makefile
@@ -16,7 +16,7 @@ LIB_DEPENDS= libboost_chrono.so:devel/boost-libs \
libboost_random.so:devel/boost-libs \
libboost_system.so:devel/boost-libs
-USES= cmake:testing compiler:c++11-lib iconv:wchar_t libtool \
+USES= cmake:testing compiler:c++11-lib iconv:wchar_t \
localbase:ldflags pathfix pkgconfig python:test shebangfix ssl
USE_LDCONFIG= yes
diff --git a/net-p2p/transmission-components/Makefile b/net-p2p/transmission-components/Makefile
index 366a4da0c741..ba93835a1d96 100644
--- a/net-p2p/transmission-components/Makefile
+++ b/net-p2p/transmission-components/Makefile
@@ -41,7 +41,7 @@ LIB_DEPENDS=
gtk_LIB_DEPENDS= libayatana-appindicator3.so:devel/libayatana-appindicator \
libharfbuzz.so:print/harfbuzz
-USES= cmake cpe iconv libtool localbase pkgconfig ssl tar:xz
+USES= cmake cpe iconv localbase pkgconfig ssl tar:xz
CPE_VENDOR= transmissionbt
CPE_PRODUCT= transmission
diff --git a/net/libvncserver/Makefile b/net/libvncserver/Makefile
index baef28d711b3..95d21bf23ad6 100644
--- a/net/libvncserver/Makefile
+++ b/net/libvncserver/Makefile
@@ -13,7 +13,7 @@ LICENSE= GPLv2
LIB_DEPENDS= libpng.so:graphics/png \
liblzo2.so:archivers/lzo2
-USES= cmake cpe jpeg libtool pathfix pkgconfig
+USES= cmake cpe jpeg pathfix pkgconfig
USE_LDCONFIG= yes
CPE_VENDOR= libvncserver_project
diff --git a/print/qpdf/Makefile b/print/qpdf/Makefile
index 1d2989583af1..4219bc239f1e 100644
--- a/print/qpdf/Makefile
+++ b/print/qpdf/Makefile
@@ -12,7 +12,7 @@ LICENSE_COMB= dual
LICENSE_FILE_ART20= ${WRKSRC}/Artistic-2.0
LICENSE_FILE_APACHE20= ${WRKSRC}/LICENSE.txt
-USES= compiler:c++11-lang cmake cpe jpeg libtool localbase
+USES= compiler:c++11-lang cmake cpe jpeg localbase
USE_LDCONFIG= yes
CPE_VENDOR= qpdf_project
diff --git a/science/hdf5-18/Makefile b/science/hdf5-18/Makefile
index 22467f05d507..1dbb840dc0c9 100644
--- a/science/hdf5-18/Makefile
+++ b/science/hdf5-18/Makefile
@@ -15,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
OPTIONS_DEFINE= EXAMPLES FORTRAN SZIP
-USES= cmake:testing cpe libtool:keepla localbase pkgconfig tar:bzip2
+USES= cmake:testing cpe localbase pkgconfig tar:bzip2
CPE_VENDOR= hdfgroup
USE_LDCONFIG= yes
PORTSUFF= ${PORTNAME}${PKGNAMESUFFIX}
diff --git a/security/libscep/Makefile b/security/libscep/Makefile
index bf11bb5226e3..9a03a3c30a7a 100644
--- a/security/libscep/Makefile
+++ b/security/libscep/Makefile
@@ -19,7 +19,7 @@ RUN_DEPENDS= check>=0.12.0:devel/check \
curl>=7.64:ftp/curl \
uriparser>=0.9.1:net/uriparser
-USES= cmake:noninja gmake libtool pkgconfig python:build ssl
+USES= cmake:noninja gmake pkgconfig python:build ssl
USE_GITHUB= yes
GH_ACCOUNT= openxpki
USE_LDCONFIG= yes
diff --git a/security/yubico-piv-tool/Makefile b/security/yubico-piv-tool/Makefile
index 36ad02e07c85..c95bdd788cc4 100644
--- a/security/yubico-piv-tool/Makefile
+++ b/security/yubico-piv-tool/Makefile
@@ -16,7 +16,7 @@ BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/check.pc:devel/check \
help2man:misc/help2man
LIB_DEPENDS= libpcsclite.so:devel/pcsc-lite
-USES= compiler cmake:noninja gmake libtool pathfix pkgconfig ssl
+USES= compiler cmake:noninja gmake pathfix pkgconfig ssl
USE_LDCONFIG= yes
CMAKE_ARGS= -D LIBCRYPTO_CFLAGS="-I${OPENSSLINC}" \
-D LIBCRYPTO_LDFLAGS="-L${OPENSSLLIB} -lcrypto -L${LOCALBASE}/lib -pthread" \
diff --git a/sysutils/jstest-gtk/Makefile b/sysutils/jstest-gtk/Makefile
index 6571ab838d88..d915c52ce18b 100644
--- a/sysutils/jstest-gtk/Makefile
+++ b/sysutils/jstest-gtk/Makefile
@@ -12,7 +12,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= ${LOCALBASE}/include/linux/joystick.h:devel/evdev-proto
-USES= cmake compiler:c++11-lang gnome libtool localbase:ldflags \
+USES= cmake compiler:c++11-lang gnome localbase:ldflags \
pkgconfig xorg
USE_GNOME= gtkmm30 libsigc++20
USE_XORG= x11
diff --git a/x11-toolkits/soqt/Makefile b/x11-toolkits/soqt/Makefile
index 415446da4c55..266e2acfc106 100644
--- a/x11-toolkits/soqt/Makefile
+++ b/x11-toolkits/soqt/Makefile
@@ -14,7 +14,7 @@ LICENSE= BSD3CLAUSE
LIB_DEPENDS= libCoin.so:graphics/Coin
-USES= cmake:noninja compiler:c++11-lang dos2unix gl libtool \
+USES= cmake:noninja compiler:c++11-lang dos2unix gl \
localbase pathfix pkgconfig qmake:no_env qt:5 xorg
USE_QT= buildtools core gui opengl qmake widgets
USE_GL= gl glu